Home has stopped!Support

Last Updated:

  1. fin3125

    fin3125 New Member

    When I press the blue apps icon on the home page of my LG Spectrum phone, it gives me a screen that says "unfortunately, home has stopped". I am not rooted. I dont want to reinstall everything.

    Why is that and what to do????



  2. sosaudio1

    sosaudio1 Well-Known Member

    Well think back to what were the last few things you were doing before you started getting this error?
  3. breadnatty08

    breadnatty08 pain rustique VIP Member

    Do you have a separate launcher installed like GoLauncher, Apex, Nova? Perhaps that's causing the problem.
  4. bones420la

    bones420la Well-Known Member

    Go to settings > apps > all apps
    Find the lg home and try clearing cache. If that doesnt work try clearing data for the lg home. That should make it work right. If not I would suggest trying out adw
    Dominionsam77 and allbroncos like this.
  5. sosaudio1

    sosaudio1 Well-Known Member

    And please report back on your progress....good or bad as it helps the community if others have the same problem
  6. ThorTram

    ThorTram New Member

    Best Answer


    I just had the same thing happen on my daughter's (non-rooted) Spectrum last night.

    The Home screen itself would work, but trying to bring up the Apps list resulted in "Unfortunately, Home has stopped."

    I was able to install ADWLauncher and verify that it worked fine and I was able to run all of the apps that I tried/

    After tinkering with it for a while, I was able to get things rolling again.

    What I think did it was a combination of clearing out the Cache and freeing up some space on the SD Card - it had less than 10MB free and just clearing out the Cache without getting some free space did not work.
  7. cbtat129

    cbtat129 New Member

    So I had this same problem and I haven't even had my phone for more than a week but i got it fixed thanks to the help of some on this website. When I went to clear the cache, I couldn't tap the option so instead I cleared the data. It got the app button to work again, but don't be freaked out if it gives you messages about creating folders and stuff, it just has tutorial stuff. Also the home screen might be reverted back to the original (like reordered etc.)

    THanks to everyone who replied, it really helped!
  8. pkjamwal

    pkjamwal New Member

    I had the similar problem with my phone and clearing cache actually saved me and my two week old phone.
  9. Devanuj

    Devanuj Member

    Yep Guys....clearing the Home data fixed the problem.....For better results restart once as well....Thank you for the solution :)
  10. Dunard

    Dunard Member

    Fix my issue today. Thanks :)

Share This Page