home screen after removing phone from dock


Last Updated:

  1. ralphtrent

    ralphtrent Well-Known Member This Topic's Starter

    Joined:
    Mar 8, 2010
    Messages:
    67
    Likes Received:
    6
    Running 2.2 from OTA when I take the phone out of a dock (Multimedia or car), the home screen has to rebuild it self. Meaning all the icons are slow to come back. think of it as on a windows machine Explorer dies and you have to do a start/run/explorer to get it back. Only difference i that this is automatic, just slow to get responsive again. Even swipping through the screen is slow at first.

    does anyone else see this?

    Is froyo, google's VISTA?
     

    Advertisement
  2. adostrom

    adostrom Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    74
    Likes Received:
    16
    How long does it take? I dock/undock many times/day (both car and home), and it never takes more than 2-3 seconds for the home screen to rebuild, usually less than a second. It used to take longer; many people, me included, have found that a "factory reset" has made things MUCH faster. It sounds scary, but it's not -- do a search of the forum and you'll see that it's pretty painless.
     
  3. ralphtrent

    ralphtrent Well-Known Member This Topic's Starter

    Joined:
    Mar 8, 2010
    Messages:
    67
    Likes Received:
    6
    about 2 seconds, but compared to pre 2.2 its long. Ill take a look at the factory reset.

    Since most of my "goodies" are on my sd card now, I should be ok to do the FR.

    Thanks,
    RalphTrent
     
  4. adostrom

    adostrom Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    74
    Likes Received:
    16
    I wonder if moving apps to the SD card is part of the slowdown... It has to take longer to read the icons off the card, though you'd think they'd be cached.

    I just went in and out of car mode about 20 times. i tried running some memory intensive apps like maps and navigation while in car mode, and then exited car mode, which did seem to slow down the refresh a little, but it still never took 2 seconds.
     
  5. ralphtrent

    ralphtrent Well-Known Member This Topic's Starter

    Joined:
    Mar 8, 2010
    Messages:
    67
    Likes Received:
    6
    I had noticed it before I moved apps to sd as well. it may not be exactly 2 seconds, but there is definitely a delay that was not there before.
     
  6. SNeitzel

    SNeitzel Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    637
    Likes Received:
    102
    Mine does that too except it is more extreme, like 6-7 seconds.
    I don't have the car dock but it does it when sliding out the KB and rotating the phone to landscape.

    I forced the 2.2 update and have done a reset since then as well.

    I had also thought it might be an issue with apps on the SD card. I might move all back to phone and see if that helps.
     
  7. adostrom

    adostrom Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    74
    Likes Received:
    16
    I have all the apps that will go on the SD card, on the SD card, and my performance is still decent. It might be worth a shot, though, just to see... Someone in another thread suggested turning off screen animations. When I tried that it certainly made things faster, though I didn't like the look, so I turned them back on. Might be worth a try, too...
     
  8. SNeitzel

    SNeitzel Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    637
    Likes Received:
    102
    So...

    I moved all of my apps back to the phone and my screen redraw issues went away. I started moving them back to the SD card one by one and the issue came back after about 5 or 6 apps and continued to get worse the more apps I moved.

    Then,
    With apps moved to the SD card, I removed shortcuts from my desktop to any apps that were on the SD card. The redraw issue went away. I began adding the shortcuts back and again after 5 or so the redraw issue was back.

    Would be interested to see if anyone else can reproduce this behavior...
     
  9. PhilosoRaptor

    PhilosoRaptor Well-Known Member

    Joined:
    Jan 26, 2010
    Messages:
    722
    Likes Received:
    108
    My phone takes prolly 10-15 secs for it to get responsive after undocking it in the morning. I use Bedside for my clock/alarm every night and it's dock-activated.

    I don't have any apps on my SD card whatsoever and haven't tried moving them.. I would rather keep them on my phone because I'm sure the phones internal memory is faster than the SD card.

    This definitely wasn't an issue with pre-2.2 either from what I remember. It's not a huge deal for me, but it's still a little annoying when I pick up my phone and it takes 10-15 secs for it to respond to any input afterwords.
     
  10. corbinator

    corbinator Well-Known Member

    Joined:
    Apr 28, 2010
    Messages:
    176
    Likes Received:
    13
    I did a factory reset, and I just timed it. 4 sec, and what took so long was the stock power widgit. I have launcher pro+ and the calendar and bookmarks widgit were up instantly.
     
  11. TharOosta

    TharOosta Well-Known Member

    Joined:
    Dec 10, 2009
    Messages:
    116
    Likes Received:
    3
    Mine takes around 6 seconds also. Im telling ya! Froyo sucks!
     
  12. Richman21

    Richman21 Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    452
    Likes Received:
    320
    Mine does it. 6-8 seconds at most. Not a big deal to me.
     
  13. Turdbogls

    Turdbogls Well-Known Member

    Joined:
    Jul 22, 2010
    Messages:
    817
    Likes Received:
    150
    Same here...about 6 seconds as well. 2.2 kinda sucks like that...but everything else is good about it
     

Share This Page

Loading...