Home/search buttons not working, not sleeping/locking properly.


  1. Register

    Register New Member

    After not using my phone at all yesterday, I picked it up to find the battery had almost completely drained, though I had put it to sleep using the same routine I do every day. As I puzzled over this, I started noticing these other issues.

    *The Home button no longer brings me to the home screen, in fact it does nothing other than-
    *The phone no longer uses my pattern to unlock, though it is still enabled in the settings. I can press any key (including end) when the screen turns off and it just brings the screen right back up (whichever screen/application I was on last). This is the same whether it times out or I hit End.
    *The Search button is equally as ineffective as the Home button, only functioning to turn the screen back on.
    *Holding down the End button no longer gives me the options of Silent/Sleep/Power. Only Power is available.

    I hadn't installed any applications recently enough for them to be logical triggers.
    I had downloaded 1.6 a few days ago, several days before issues began.
    A suggestion I've gotten- using Spare Parts to set the End key to sleep still doesn't cause the phone to actually sleep/lock. Setting it to "home then sleep" causes the button to not function at all. I'm attributing this to the whole "1.5 ONLY" thing, though.

    I've searched through the forums and have found a couple threads with some common issues, but none that quite match mine. If there is a thread with this exact problem, I apologize for missing it and would greatly appreciate a link so that I may be on my way.

    Advertisement
  2. kabbie_mcfeely

    kabbie_mcfeely Well-Known Member

    Dumd question, but have you shut the phone off ? Have you tried taking the battery out for a couple minutes and restarting phone ?

    Just a couple ideas???
  3. Register

    Register New Member

    Yes, I've tried both of these things.

    However, speaking of turning the phone off- I have noticed that upon startup the icon for Dialer starts out highlighted. This could have occurred previously, but I never noticed it until now.
  4. kathrynrose

    kathrynrose New Member


    I am also having the same exact issues with my phone ever since the battery drained completely last night. Please let me know if you resolve the issue outside of this forum! I would rather not do a hard reset.
  5. EinZtein

    EinZtein Well-Known Member

    I just returned a Hero because of battery problems. Apps never closed, had to use a task killer app to close apps and processes. The stock messages app would lock the dialer so the dialer process would never let the phone sleep. Total nightmare managing that device and the "live" feeds on the home screen for weather and sports always had to be updated manually even though they were set for automatic "live" updates. Horrible device.

    I was hoping MyTouch didn't have those problems but it looks like it may.

    Battery would be dead just sitting on my counter in 6 hours even will all the processes killed.

    Still considering the Fender Edition.
  6. wrex

    wrex New Member

    I'm experiencing the same exact problems as the OP since yesterday. Home/search buttons don't work. The screen lock no longer works. Auto spell check/correct is enabled and I can't disable. Wow, like the phone but this is total fail.
  7. wrex

    wrex New Member

    Bluetooth also no longer works. Ringtones were all set back to default. Lost the Touchpal keyboard. Debating takign it back to Tmo or just rooting/flashing with a new rom.
  8. wrex

    wrex New Member

    Workign again now after factory reset (settings > sd card & phone storage). Just back everything up and make sure contacts/ect are sync'ed.

    Gonna root/rom now.
  9. khooke

    khooke Member

    I've got the same problem on my MyTouch3G after I powered it on this morning.

    - Home button not working for single or long click (have to press back to get out of apps)
    - Lock pattern is not working, even though still enabled in settings. Can now press any button and get into the phone straight away without having to enter the pattern
    - Search button doesn't work
    - Power off menu's content has changed. Instead of listing 'Airplane Mode', 'Power Off' (and I'm sure there was another option?), now it just shows 'Phone Options' as the title and one item 'Power Off'.

    Seems like there's a few other people who have seen this, but no other solution other than a hard reset to factory defaults? This is worrying me slightly as I really don't want to go through the hassle of setting everything up again. I'm looking at using MyBackup to save everything to my SD card and then restore after resetting.

    The other unusual think: pressing the search icon in the Market and entering words for a search hangs the phone and then after about 30 seconds it reboots. Made it slightly more difficult to find MyBackup in the store!

    Anyone have any easy ways to fix this? It seems like something has changed some settings on the phone that's put it in this weird state? The different options in the power off menu seems to imply to me this is a software issue and not hardware.
  10. diobando

    diobando New Member

    I have my mytouch 1.2 and exactly the same problem just happened to me. Have somebody found any solution to this? Thank you
  11. Jnoc

    Jnoc Active Member

    This happens to me once in a while too. All i do to fix it is boot into recovery, wipe all, and reinstall my last nandroid backup. For whatever reason if you don't do a wipe it doesn't fix it.
  12. DeadPlasmaCell

    DeadPlasmaCell Well-Known Member

    This has happened to me twice, yesterday was the most recent in fact.. Never figured out why it happened, but a system restore has always worked. Luckily I have everything synced with Google so getting back up and running again just takes about 15 minutes.
  13. kaiablu

    kaiablu New Member

    I had the exact same problems all of you have listed. The first time in July 2010. Tmobile told me to do a master reset. I did, lost everything and then a month and a half later, the phone did the same thing. The first time it took about a week for all of the symptons listed above to show up, this time, it took a matter of an hour. The rep at T-mobile told me to do a master reset. When I argued that it was unresonable to do a master reset every month and a half, she told me it wasn't. That it was common. That seems ridiculous to me to lose everything every 2 months. Why have a smart phone?! When I asked what would happen if it happened again in another month and a half when my warranty was up, she said I should have gotten the insurance on the phone and that I couldn't get a replacement!!!! She said as long as it worked after the master reset, Tmobile would consider it fixed! (Unitl it happend again.)
    I got very frusterated and it made me doubt both my MyTouch and T-mobile.
  14. Swizz

    Swizz Well-Known Member

    Quit calling customer care. The entire MyTouch line is covered by the in store warranty exchange program. Wait for symptoms to show up, take it to the store and ask to swap it out.
  15. kaiablu

    kaiablu New Member

    Thanks. I brought it to a T-mobile store to begin with and they told me I had to call customer care, there was nothing they could do.
  16. dbgrigg189

    dbgrigg189 Well-Known Member

    I can confirm what Swizz said and do one better. Not only is it covered, but there is a policy with Tmo that states that any MyTouch branded phone can be exchanged at ANY Tmobile store and if they don't have an exchange in stock they have to give you new inventory. An android department rep found this out for me the other night and copyed the policy verbatim into my account notes.
  17. DaftRascal

    DaftRascal New Member

    EASY WORKAROUND:


    ->Settings->Applications->Manage applications->Google Apps->Clear data->OK
    back to Settings (<-<-<-)
    ->Data synchronization
    it will then prompt you to re-enter gmail address and password.


    Works for me (TMobile MyTouch 3G 3.5mm 1.6)
    rickcr and webjawns like this.
  18. webjawns

    webjawns New Member

    Thanks, DaftRascal! This issue started a few days ago, and your workaround fixed it instantly. Thanks again.
  19. althotos

    althotos New Member

    Well, it happened to me yesterday, one day after I got my Android 2.2, Froyo upgrade. I don't know if it was caused by an application I downloaded or some combination of events, but the home and green phone button stopped working. After researching the issue, I had to do a hard reset.

    1) I copied all the data from the phone on to my laptop.
    2) I turned off the phone.
    3) I waited 10 seconds.
    4) I held the red phone button and the home button down together.
    5) I waited for 20 seconds until the warning sign appeared.
    6) I released the keys.
    7) I held both buttons (red phone and home) down again.
    8) I scrolled through the selection list to complete wipe and factory reset.
    9) I pushed the thumball.
    10) Factory reset executed.
    11) I rebooted the phone.
    12) Copied all my files back to the phone from the laptop.
    13) Had to download all my apps from the Android Market.
    14) All buttons are fine now, but I am still customizing the phone to the way it was.
  20. undantaker

    undantaker New Member

    OK wow, that actually worked for me. I had the exact same symptoms with my screen lock, home button, search button and keyboard change and the steps above work flawlessly. So my question is this, how could that have possibly fixed it? It really doesn't make any sense. The only thing my phone synchronizes in google apps is my Gmail, contacts and calendar. That shouldn't have anything to do with the functionality of the phone. Let me know if anyone has and creative explanations to this.
  21. xtreme777

    xtreme777 New Member

    The new versions of Market do not have a Clear Data button. Here is what I did instead.

    Go to Settings, Accounts, Add Account. Add another google account. Don't sync anything. Remove that google account. My lock screen, power options, and Home button started working again. Quick and easy and the best thing is you don't lose your main account. Enjoy!
    rickcr likes this.
  22. rickcr

    rickcr Member

    Incredible! Adding and removing a Google account worked for me as well. Found this post searching for a solution , didn't want to do a factory reset. thanks!
  23. lizardcell

    lizardcell Member

    same problem here but the account didn't seem to work... PLEASE HELP I'M FREAKING OUT

Share This Page