Honeycomb 3.2 update rolling out.


Last Updated:

  1. beefyy

    beefyy Well-Known Member

    Just got the update on both off my xoom's. sd card and zoom feature are working fine, but swype is not working in portrait mode.

    Advertisement
  2. scary alien

    scary alien not really so scary Moderator

    Just got my update too :).

    Typing seems just a little more responsive than in prior versions...will play with it more tomorrow.

    Cheers!
    marctronixx likes this.
  3. redpanda

    redpanda Well-Known Member

    Yeah, swype isn't working anymore. It says unsupported resolution. Laaaame
    marctronixx likes this.
  4. beefyy

    beefyy Well-Known Member

    It works ok in landscape view, just not in portrait
    marctronixx likes this.
  5. Mitchrapp

    Mitchrapp Well-Known Member

    Just got it now. It gave me a error about swype but it still works for me. Wifi only here.
    marctronixx likes this.
  6. gamul1

    gamul1 Well-Known Member

    Just got mine. I have a new 32gb sdcard in there. How can I tell if its working? I have ES file explorer but it seems to only be reading the system memory. To confuse things, system memory has a folder labeled "sdcard". File manager says I have 13gb of 29.xx remaining.
  7. coldsteel2005

    coldsteel2005 New Member

    Just got my update overnight and installed it this morning. I wrote a quickie blog post about it Motorola Xoom SD Card support has landed | Winston Lawrence but basically it works and the SD card is there plus the whole thing just seems noticeably faster. Glad they took the time to get the update done right.
  8. Jbart15

    Jbart15 Well-Known Member

    Swype is working fine for me, I think the new update fixed the issues
    marctronixx likes this.
  9. krouget

    krouget Well-Known Member

    I also received my update this morning. Most everything is operating as it did on 3.1. I can't say I notice much of a speed difference, myself (non-rooted).

    Swype works fine in landscape, but not so good in portrait view. It detects touches about 3 keys left to what I'm actually pressing.

    I'll be throwing in my 32GB SD card later today.
    marctronixx likes this.
  10. marctronixx

    marctronixx Moderator Moderator

    use file managr HD which is optimized for tablets. you have to back out of the root folder to see the external Sd card.
    krouget, Mitchrapp and scary alien like this.
  11. redpanda

    redpanda Well-Known Member

    I was getting the error every time the keyboard came up, so I tried to uninstall and reinstall it. In retrospect, that was a mistake, because when I try to install, it's telling me the resolution isn't supported.

    Oh well, I should be getting a bluetooth keyboard today that I can use until Swype figures out how to patch this.
  12. marctronixx

    marctronixx Moderator Moderator

    you cats should try swift key. its now avail in the market for 50% off. i use it on the 3D and the xoom and its a great board. its come a long way from the beta days...
  13. scary alien

    scary alien not really so scary Moderator

    Thanks for that heads-up, marctronixx, re. File Manager HD...I'll have to check that out.

    The thing I think is coolest about this is how apps (specifically my Market apps ;)) are now full-size on the screen and not imcorrectly shrunken-down (its like Honeycomb selected the smallest possible phone's screen (like the original G1) to use for a screen size for apps that are not yet optimized for the large screen).

    I do know that I need to figure-out how to update my apps for Honeycomb and larger resolution devices, but that's why I got my Xoom in the first place, eh? (just haven't had time yet, ugh :p).

    Cheers!
    marctronixx likes this.
  14. commander24

    commander24 Well-Known Member

    Just got the update. Interesting thing is the SD card now mounts but it looks like its write permissions are not set correctly. Tried to transfer files from internal mem to /mnt/external1 but its not letting me. Reformatted the SD card just in case. But no luck so far. :mad:

    wifi zoom, non-root running stock 3.2
  15. lowboydrvr

    lowboydrvr Well-Known Member

    The problem (found on another forum) is that the API used to write the apps did not have the ability to utilize the new path, "mnt/external1", only the old path "mnt/sdcard". Once the new API is released to developers, they will then be able to update the apps for the new path.
  16. scary alien

    scary alien not really so scary Moderator

    Didn't have time to test / check this out last night when my update came in...(it was already was past bedtime, LOL).

    I changed my two apps several months ago (thanks to a nice heads-up from Andrew P. Moore, the developer of Light Flow) on how to dynamically determine the external storage directory (I had previously hard-coded "/sdcard" or "/mnt/sdcard").

    Here's the code I now use that I hope still works:

    File sdCard = Environment.getExternalStorageDirectory();
    ext_storage_dir = sdCard.getAbsolutePath();

    I'll test / verify and report back that this still works when I get home tonight...my hope / thought is that apps written using something like the above will already work on a 3.2 Xoom.

    Cheers!
    metalimi likes this.
  17. BiGMERF

    BiGMERF Well-Known Member

    ok got my update yesterday.. mounted the sd card but cant do nothing with it.. ok , let me get this right.. enable sd card but cant do shit with it anyway? what was the pint
  18. gamul1

    gamul1 Well-Known Member

    I'm using File Manager HD now - I agree a much better explorer tool.

    But - my problem is not much better. I checked the permissions on the folder /mnt/external1 - and it is listed as "dr-" - which seems to mean it is a directory and it is readable. But not writable. From what I have heard, I can't change the permissions on this unless I am rooted - which I am not.

    So - whats the point of enabling SD Card support only to have a read only micro sd card? :mad:
  19. marctronixx

    marctronixx Moderator Moderator

    ^^^ although that is a very acceptable and highly probable reason, its not an official release from Moto or Google, so lets keep that in perspective. :)

    I know from which forum you speak however.. ;)
  20. commander24

    commander24 Well-Known Member

    At least, its half a solution...:p
  21. MartinS

    MartinS Well-Known Member

    Uk 3.0.1 laggy and currently extremely ****ing ****ed off :rolleyes:
  22. scary alien

    scary alien not really so scary Moderator

    Guys,

    I've stickied this thread...seems fair since the 3.1 roll-out thread has been sticked for a while...:D

    Any thoughts to un-sticky-ing (is that a word?) the 3.1 thread...

    Cheers!
    beefyy likes this.
  23. richpal

    richpal New Member

    I was having problems playing my media files on the sdcard or reading any type of document. I have a class 4 Kingston 32gb sdcard.

    I decided to format my 32gb sdcard even though it was already formated as
    32 fat. I formatted it again as 32 fat, reinserted the sdcard. Using the USB cable from my PC I added a movie file, mp3, a pdf and picture to the sdcard. On the xoom I used Astro manager to access the sdcard (mnt/external1) and I was able to play the movie and mp3 files, I was able to read the pdf file and view the picture file. I am still unable to move or copy files from another xoom directory to the sdcard but I can copy files from the sdcard to a directory on the xoom. Hopefully the write to bug to the sdcard from within xoom will be rectified soon. I am fairly happy with version 3.2.:)
  24. scary alien

    scary alien not really so scary Moderator

    Okay, didn't get time to report back last night, but here's what I've found (and not found), so far (much of it you've already gathered):

    1. I can't find or figure-out which API will return the "/mnt/external1" value for Honeycomb 3.2.

    So, I thought perhaps the Environment.getExternalStoragePublicDirectory() method would return a different value than the Environment.getExternalStorageDirectory() method.

    Unfortunately, it still returns "/mnt/sdcard" as the directory prefix instead of "/mnt/external1" on my Xoom:

    Code (Text):
    1. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_ALARMS).getAbsolutePath()
    2. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_DCIM).getAbsolutePath()
    3. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_DOWNLOADS).getAbsolutePath()
    4. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_MOVIES).getAbsolutePath()
    5. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_MUSIC).getAbsolutePath()
    6. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_NOTIFICATIONS).getAbsolutePath()
    7. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_PICTURES).getAbsolutePath()
    8. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_PODCASTS).getAbsolutePath()
    9. Environment.getExternalStoragePublicDirectory (Environment.DIRECTORY_RINGTONES).getAbsolutePath()
    Here's the logcat LOG entries that I recorded for this simple test:

    Code (Text):
    1. V/testme  (15151): testme(): DIRECTORY_ALARMS:        /mnt/sdcard/Alarms
    2. V/testme  (15151): testme(): DIRECTORY_DCIM:          /mnt/sdcard/DCIM
    3. V/testme  (15151): testme(): DIRECTORY_DOWNLOADS:     /mnt/sdcard/Download
    4. V/testme  (15151): testme(): DIRECTORY_MOVIES:        /mnt/sdcard/Movies
    5. V/testme  (15151): testme(): DIRECTORY_MUSIC:         /mnt/sdcard/Music
    6. V/testme  (15151): testme(): DIRECTORY_NOTIFICATIONS: /mnt/sdcard/Notifications
    7. V/testme  (15151): testme(): DIRECTORY_PICTURES:      /mnt/sdcard/Pictures
    8. V/testme  (15151): testme(): DIRECTORY_PODCASTS:      /mnt/sdcard/Podcasts
    9. V/testme  (15151): testme(): DIRECTORY_RINGTONES:     /mnt/sdcard/Ringtones
    2. There's lots of discussion going on over at the Moto Support forums re. this:

    https://supportforums.motorola.com/thread/53816

    as well as at least one formal issue reported to Google:

    Issue 18559 - android - 3.2 SD card read-only - Android - An Open Handset Alliance Project - Google Project Hosting

    I'm sure you can modify the mount permissions of the /mnt/external1 mount point from "dr-" to "drw" if/when you are rooted, but its not here yet for non-rooted Xooms :( :mad:.

    3. It is certainly going to be interesting to see how a developer knows when its appropriate to use /mnt/sdcard vs. /mnt/external1. I can sort-of understand Google / Moto not wanting to break apps by having the aforementioned APIs start automatically returning a new / different mount-path for the "SD card" (which is obviously internal to the Xoom). Its going to be "interesting", for sure...;)

    Anyway, I'm betting that there'll be a patch / update out "soon" for us...

    Cheers!
  25. dinoknots

    dinoknots New Member


    OK so please let us known if you actually disabled your wifi and actually surfed the web only using your Bluetooth tethering from your moto droid phone. I need to know because I just accepted the new 3.2 update which was pushed to my xoom and now allows use of SD card slot, however, my bluetooth tethering connection via rooted moto droid which was working before but no longer functions after update to 3.2. I cannot load webpages despite having a "using [bluetooth] connection for internet access" message under Bluetooth settings. Now I get a message next to my clock indicating "no internet access" despite everything looking like it should have an active connection. Has anyone else experienced this? I'm really pissed if there isn't a workaround to this.:mad:

Share This Page