Horrible Screen IssuesSupport


Last Updated:

  1. SpezXVII

    SpezXVII New Member This Topic's Starter

    Joined:
    Nov 6, 2010
    Messages:
    1
    Likes Received:
    0
    This is to see if I can find some help here. Previously posted on the XDA forums. Reference this thread: Strange issues... - xda-developers

    First:
    I'm into about week 2 of my first EVO and I love the phone. Yesterday, however, I started to have strange screen issues. I'll try my best to explain:

    In some browser pages, forums, and even my home screens the screen will act as though I am rapidly moving it up and down. It is impossible to stop it because it freezes up all the buttons. I figured I had a bad app so I went drastic and hard rebooted my phone. (Which is stock 2.2) Initially it seemed better but it started happening again, even while writing this post...I did not install any apps so I can only guess my screen is bad?

    Then:
    Ok, it happened again for about 2 minutes this time. I studied what it was doing and it seems it is trying to zoom in then out very rapidly. Occasionally jumping to different spots on the screen.

    Followed By:(Checking the possibility of an improperly grounded screen)
    Well, that isn't the issue. Read some posts, watched a few videos detailing said issue, tried the tests and downloaded the Multitouch Visualization App just to be 100% positive. Passed all tests.

    I have Hardware Revision 0003. Everything else runs flawlessly with the exception of this weird screen issue. Now it seems like it is trying to push "buttons" on its own, pull down the shade, etc.

    Kind of frustrated now. It's just so random.

    Finally:
    Ok, I made 2 crappy videos for you guys to see....

    http://www.youtube.com/watch?v=hIK3DlbKKWc

    http://www.youtube.com/watch?v=FPze7PdNiHE
     

    Advertisement
  2. Mr. Ed

    Mr. Ed Well-Known Member

    Joined:
    Jun 27, 2010
    Messages:
    6,675
    Likes Received:
    1,464
    Another user here posted something similar this week. Is your phone stock or rooted?

    Its my belief that if you are stock and the issue remains after a hard reset that it could definitely be a hardware issue and you should take it in for repair

    If rooted try wiping dalvik and cache and bat stats, reflash your rom

    If that doesn't work try the above but flash a new rom

    And if that doesn't work unroot and take in for repairs.

    Also look at the possibility that it could be a custom kernel...if u are using one
     
  3. sitlet

    sitlet Banned

    Joined:
    Apr 11, 2010
    Messages:
    5,867
    Likes Received:
    633
    try a hard reset
     
  4. SamuraiBigEd

    SamuraiBigEd Under paid Sasquatch! Moderator

    Joined:
    Nov 8, 2009
    Messages:
    4,181
    Likes Received:
    2,088
    Second for hard reset, if that doesn't fix it take it straight to Sprint.
     

Share This Page

Loading...