How can I downgrade back to D?Support

Last Updated:

  1. cjbandroid

    cjbandroid Well-Known Member

    I'm thru with version E... its a mess.

    Tethering is all messed up. Even 4G internet is gone screwy... at least half the time I need to reload a page because it times out, then loads normally.

    Speeds seem just a little slower.. not much, could be a fluke... but anywhere I go since the upgrade... and its chugging on first attempt on almost all internet functions. SpeedTest is giving me 4500down/2800up... slower than my usual 6200down/4500up. I'm wondering if the PRL got messed with too?

    If anyone could kindly point me in the direction to a downgrade... many thanks in advance.

  2. Jenna_Lenna

    Jenna_Lenna Active Member

    Were you able to extract the D firmware? I refreshed numerous times and continued to get Forbidden. Even tried under different browsers and continued to refresh as per the instructions but nothing. :(
  3. cjbandroid

    cjbandroid Well-Known Member

    Me neither... cant get the D firmware... always FORBIDDEN

    Is there some alternate link to the cab file?
  4. cjbandroid

    cjbandroid Well-Known Member

    Well, this basically sucks.

    Here's what I have ... now....

    I could not get the firmware D at all... so... I went to C (from E)

    This is a bad thing. Don't do it.

    What you end up with is a mix of E and C... and worse.

    Firmware reports that its C. However, the USB tether is still grey'd out. And 4G tether does not work... why? Because I totally lost 4G access. Tried popping in and out of airplane mode, rebooting... fuggetaboutit. Removed battery. Removed 4Gaccess card and reseated it. It REPORTS 4G access, but... when you actually try to do anything, it reports that connection with proxy server was denied.

    And... can't re-root either.

    Tried flashing C again. Still no 4G, still no re-root. The daemon just sits there and sits, and sits.... and sits.

    Yes, drivers loaded. Yes USB debug is on. Yes I ran the exploit .apk, opened it and rebooted. Nada. Cannot re-root.

    I am thinking E messes with things that C does not care or know about, and when C is again resident, it has some problems with the mess that E left behind. Just a guess.

    Any thoughts would be appreciated.
    snake557 likes this.
  5. kdellea

    kdellea Active Member

    I've had no problems with E. Works amazingly for me.
  6. DocBlue

    DocBlue Well-Known Member

  7. Ubercharrge

    Ubercharrge Well-Known Member

    I went from E to C yesterday and i rooted, tether works, try factory resetting.
  8. orangejuicebox

    orangejuicebox Well-Known Member

    i dont have problems
  9. sammyz

    sammyz LG Whiz Kid Guide

    It seems that your 4G sim card may have went bad, an employee told me that sometimes they go bad within days. Visit an authorized retailer/corporate store and they'll fix it for free.
    Also, try factory resetting to see if that fixes root not working.
  10. Tokenpoke

    Tokenpoke Well-Known Member

    OK. Back to the op question...

    How do I get the D firmware.. clicking refresh does not work!!!! I have a cramped finger to prove it.

    I KNOW somebody has to have the darn kdz or cab file on your PC or SD card, could you PLEASE just upload it to drop box or media fire?
  11. sammyz

    sammyz LG Whiz Kid Guide

    It was working before...what the heck...(sigh)
  12. Tokenpoke

    Tokenpoke Well-Known Member

    I guess lg noticed the mad downloads of the firmware and upped the protection... says I dont have permission or something abt logging in. I forget exactly, but its like the links are locked down good now.

    I did discover a workaround I think but I need to try tomorrow.

    Here's the gist...
    Flash c.
    Reboot once
    Check for update
    SHOULD update you to D

    I just thought of this... reason?
    When I unbricked with the media fire download a few days ago I got the D ota. Rebooted and got E

    I want d because it has been deodexed btw
  13. cjbandroid

    cjbandroid Well-Known Member

    Something went afoul....

    I have no bluetooth, no 4G, good EV.

    Gallery, or any other program that shows images, shows black squares instead!

    I images are ok, as I pulled the storage SD, and they're good to go. So its something in the rendering.

    Gonna back up what I can, then do a reset.... more as it comes.
  14. sammyz

    sammyz LG Whiz Kid Guide

    Yea it seems like it just needs to be factory phone does too, it only connects to MTP USB and nothing else.
  15. cjbandroid

    cjbandroid Well-Known Member


    Have not tried to re-root... I'll do that later...

    Got the 4G back, got pretty much everything back that I could think to check on. Gallery, bluetooth, etc etc.

    So... just gotta reload all the crap I had in there... good time to houseclean anyway.
  16. sammyz

    sammyz LG Whiz Kid Guide

    Cool, factory resets are useful :eek: MetroPCS stores were right :rolleyes:
  17. Ubercharrge

    Ubercharrge Well-Known Member

  18. cjbandroid

    cjbandroid Well-Known Member

    What a saga....

    Whatever messed up, the "first" hard reset didn't fully work. The first hard reset went right to the "new phone" screen, where you sign up accounts, set up wifi, etc.

    I thought it funny that even though the phone was "virgin"... all my apps and downloads were in the app menu. Just had to drag them back to the home screens.

    Everything worked at this stage - lost all my email, but that was no biggie. Lost past text messages, again, no biggie. Web favorites, that sort of thing... gone. Based on the new phone setup screen, and things being gone, I thought the phone was reset. However, I never got the 'droid with the churning thing in his tummy when I did the reset.

    Thinking it was totally reset, I tried to root again. Nada, failed. And when it failed I lost 4G, bluetooth, gallery, etc etc... just like before.

    Another hard reset (vol down, power, middle and left soft keys). This time I got the 'droid with the churning tummy. I felt good about this reset.

    And, voila... rooted as it ought to. And everything works. And I'm on version E.

    Whew. And, I lost all those apps....which is no great loss, as I have screen shots... showing me exactly what I had, where it was :p (old man syndrome... I qualify!). There are some things I thought I'd use, but didn't, so I'll streamline.

    What a long strange trip its been....
  19. Jenna_Lenna

    Jenna_Lenna Active Member

    Goodness.. yeah ever since I updated to firmware E things have been more buggy then usual. Sending MMS has been a pain at times.. Seeing as firmware D is inaccessible I was going to try flashing C and then doing OTA to D like Tokenpoke (let me know if that works!)..but I'm kind of scared after cj's troubles.. :p. Anyone? Firmware D? :(
  20. Tokenpoke

    Tokenpoke Well-Known Member

    What I ended up doing was using cwm to flash the deodexed d ROM.... I lost the thread but will bump later... its in the all things root guide though...

    What isn't there is this awesome AOKP CM10 I found on
    Sepero likes this.
  21. cjbandroid

    cjbandroid Well-Known Member

    FWIW, I think I found my original problem... with E.

    The problem is - AdFreeAndroid

    When its installed, on my phone at least, its slowing browsing with MetroWeb to a crawl. This has to do with the number of, and vastness of, the lists you can subscribe to with AdFreeAndroid. I had it maxed out. That didn't bother D, but on E... another story.

    With AdFreeAndroid un-installed, browsing is fast. With the stock(default) list, and no subscriptions, its fairly fast, with the odd hiccup or two when you get a page thats really filled with ads.

    If I can get D, I'm going back... but at least I've got a handle on the situation.

    Was a frustrating few days!
    sammyz and rooob like this.
  22. rooob

    rooob Well-Known Member

    thanks for this, i was having this horrible lost of 4G and i had Ad Free too, when i opened the app it said i needed to do the upgrade, so i removed the app and installed the new one and boom... 4G again!
    Sepero and sammyz like this.
  23. sammyz

    sammyz LG Whiz Kid Guide

    I recently had to do a factory reset, since then I've been getting better battery life with all the same apps installed except Adaway (i never reinstalled it because the host file still works without the app).

    Hmm it is strange that the app alone is causing issues, but the host file doesn't.
  24. cjbandroid

    cjbandroid Well-Known Member

    Jenna_Lenna - you have a PM

    I see DocBlue has posted an alternate link for the D firmware - which I'm DLing as we speak!

Share This Page