How do I add ringtones without them appearing in the Music Player app?Support


Last Updated:

  1. maignacio

    maignacio New Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    4
    Likes Received:
    0
    Greetings!

    This is my first Android phone, and I'm fairly confused as to how I am to go about this problem. I've tried putting them in /media/audio/ringtones as well as the .nomedia text file solution, but unless I am doing something wrong, or it just works differently with this phone, the files still appear in the Music Player app.

    Any help would be greatly appreciated. Thank you.
     

    Advertisement
  2. johoe

    johoe New Member

    Joined:
    Jun 28, 2010
    Messages:
    3
    Likes Received:
    2
    put a file (can be empty) called ".nomedia" in the ringtones directory...

    johoe
     
    t-readyroc likes this.
  3. maignacio

    maignacio New Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    4
    Likes Received:
    0
    I've tried creating a text file as well as a generic empty file with that filename and it does not seem to work
     
  4. johoe

    johoe New Member

    Joined:
    Jun 28, 2010
    Messages:
    3
    Likes Received:
    2
    you sure that you did not miss the "dot" at the beginning of the filename

    eg.:
    Code (Text):
    1. /sdcard/media/audio/ringtones/.nomedia
    johoe
     
  5. maignacio

    maignacio New Member This Topic's Starter

    Joined:
    Jul 5, 2010
    Messages:
    4
    Likes Received:
    0
    I tried it again last night (this time using the command prompt to create the file) and the files finally disappeared from the Music Player app. However, this also rendered them unusable as ringtones (not inside the tone selection menu).

    so far, the choice is to see them in the Music Player app, or to not use them at all.

    anyone have a different solution to this problem? thank you.
     
  6. brunster

    brunster New Member

    Joined:
    Jul 11, 2010
    Messages:
    4
    Likes Received:
    0
    HI All,

    I've searched the 15 pages here without success... I have debugged & added a trimmed mp3 file into the above root folder. It appears in ringtones fine however when I set it & get a call or try changing the ringing volume, it is silent. In media player it errors saying player cannot support file type.

    It is definitely mp3 - can anyone please advise what it is I'm doing wrong/??
     
  7. ILOVEMYGALAXY

    ILOVEMYGALAXY Member

    Joined:
    Jul 27, 2010
    Messages:
    21
    Likes Received:
    0
    This is also the case with me.
    Is there any app or setting to fix this? Id like to have different ringtones and not end up in my music folder thanks
     
  8. blonkster

    blonkster Well-Known Member

    Joined:
    Jun 23, 2010
    Messages:
    87
    Likes Received:
    2

    Try 'ringdroid'
     
  9. -Ollie-

    -Ollie- Well-Known Member

    Joined:
    Jun 15, 2010
    Messages:
    188
    Likes Received:
    21
  10. tase25

    tase25 Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    102
    Likes Received:
    4
  11. Mytra80

    Mytra80 New Member

    Joined:
    Oct 14, 2010
    Messages:
    1
    Likes Received:
    0
    I personally, after creating the ringtones folder in all lowercase, had to restart my Galaxy S device. Once it restarted and ran it's media scanner, the ringtones were in the sound and display->voice call ringtone. I wasnt required to create the .nomedia text file.
     
  12. tase25

    tase25 Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    102
    Likes Received:
    4
    Hey guys, use this Mortplayer to play music. It works great because you can choose which players to play music from.

    I make a general folder just called "Music" and dump all the music I want played in there. No ringtones on the playlist :)
     
  13. cosmeramirez

    cosmeramirez New Member

    Joined:
    Oct 27, 2012
    Messages:
    1
    Likes Received:
    0
    i got my ringtones/notification sounds to not show up in the music player simply by converting my .mp3 ringtones to .ogg and my .mp3 notification to .m4a


    this is for the galaxy s3 i did not try with other phones

    also i put my ringtones into the ringtone folder of the internal memory and notifications in the notification folder in the internal memory
     

Share This Page

Loading...