How do I delete my search history on my google widget?


Last Updated:

  1. CitationNeeded

    CitationNeeded Member This Topic's Starter

    Joined:
    Jul 28, 2010
    Messages:
    21
    Likes Received:
    0
    I have a samsung moment and I can't for the life of me figure out how to delete my search history in the google widget. I've tried deleting the cache and cookies and form data, but it doesn't clear it!
     

    Advertisement
  2. sprintgirl1218

    sprintgirl1218 New Member

    Joined:
    Aug 5, 2010
    Messages:
    3
    Likes Received:
    0
    Okay, go on the browser and then push menu. Select more and go to the last option ,settings, scroll down to Privacy settings and click clear history!! There you go! happened to me to.
     
  3. CitationNeeded

    CitationNeeded Member This Topic's Starter

    Joined:
    Jul 28, 2010
    Messages:
    21
    Likes Received:
    0
    Clearing history doesn't work. =/
     
  4. Roze

    Roze Hiding behind a mystery VIP Member

    Joined:
    Jan 20, 2010
    Messages:
    9,813
    Likes Received:
    2,183
    thepinkc likes this.
  5. CitationNeeded

    CitationNeeded Member This Topic's Starter

    Joined:
    Jul 28, 2010
    Messages:
    21
    Likes Received:
    0
  6. Roze

    Roze Hiding behind a mystery VIP Member

    Joined:
    Jan 20, 2010
    Messages:
    9,813
    Likes Received:
    2,183
    Contact the dev and request that she/he have that feature :)
     
    CitationNeeded likes this.
  7. silverrocket

    silverrocket Member

    Joined:
    May 3, 2010
    Messages:
    20
    Likes Received:
    0
    Ok if you mean the drop down history that shows up. If you bring up search then click the g icon and change to web. Then hit menu button and select google search it will let you deselect personal history
     
  8. CitationNeeded

    CitationNeeded Member This Topic's Starter

    Joined:
    Jul 28, 2010
    Messages:
    21
    Likes Received:
    0
    Yeah, it's the drop down history that shows recent searches. I don't know what G icon you're talking about, but I did go to the google page and go to settings and clear settings and set it to not save my searches. But no luck. Of course. :mad:
     
  9. syst3merror

    syst3merror Member

    Joined:
    Jul 29, 2010
    Messages:
    16
    Likes Received:
    2
    can you go into settings>applications>and find the widget and clear cache in there? I don't have my droid so I can't check.
     
  10. CitationNeeded

    CitationNeeded Member This Topic's Starter

    Joined:
    Jul 28, 2010
    Messages:
    21
    Likes Received:
    0
    That seemed like it would work! I found the google search widget, but I couldn't clear the cache. There was a button to, but it wasn't clickable.
     
  11. brad22353

    brad22353 New Member

    Joined:
    Aug 16, 2010
    Messages:
    3
    Likes Received:
    0
    this worked on mine... when in Google Search hit the menu button, then hit search settings, then clear shortcuts.. on operating system 2.2
     
  12. hobnobdude

    hobnobdude New Member

    Joined:
    Jul 31, 2010
    Messages:
    1
    Likes Received:
    0
    lol! you've been looking at some filth and dont want your missus/friends to notice eh :D
     
  13. vikesfanjay

    vikesfanjay New Member

    Joined:
    Jun 3, 2010
    Messages:
    2
    Likes Received:
    0
    I was able to do it on my Samsung Moment. From the home screen click on menu/settings, scroll down to search and click "Clear search shortcuts"

    That's it, it should be clear
     
  14. CazHatesBP

    CazHatesBP New Member

    Joined:
    Aug 24, 2010
    Messages:
    1
    Likes Received:
    1
    Go to "Settings"

    Click on "Search"

    Click on "Clear search shortcuts"

    This should be done regularly to speed up your search functionality, when it stores the history it has to load it everytime you launch search.
     
    regression likes this.
  15. rudy711

    rudy711 New Member

    Joined:
    Nov 14, 2011
    Messages:
    1
    Likes Received:
    0
    i had the same troubles and i found the solution,
    SETTINGS>APPLICATIONS>MANAGE APPLICATIONS>GOOGLE SEARCH (which is what you want to clear)> and just press clear data! :cool:
     
  16. Brucew0617

    Brucew0617 Banned

    Joined:
    Jan 27, 2011
    Messages:
    269
    Likes Received:
    7
    I think you can go to settings to clean the data
     
  17. chrisj1226

    chrisj1226 New Member

    Joined:
    Nov 30, 2011
    Messages:
    1
    Likes Received:
    0
    "this worked on mine... when in Google Search hitthemenu button,then hitsearch settings,then clear shortcuts.. on operating system 2.2"

    This worked for me on 2.3.5 Thank you
     
  18. cliftonburton

    cliftonburton New Member

    Joined:
    Jun 1, 2012
    Messages:
    1
    Likes Received:
    0
    to erase the list of searches you've performed in google on your samsung android, do the following:

    1. click on the google textbox
    2. click on the menu button (far left)
    3. select search settings
    4. select Clear shortcuts
     
  19. jcal22999

    jcal22999 New Member

    Joined:
    Jun 21, 2014
    Messages:
    1
    Likes Received:
    0
    Good looking out on the info Caz.
     

Share This Page

Loading...