How do I get the ota update prompt back?


  1. Modman

    Modman Well-Known Member

    The first time a tried to install it with twrp installed it failed.

    Then it came back and being stubborn I tried again and it failed.

    Seems like it took forever but eventually it came back by itself.

    Today I updated Wugs and flashed stock recovery.

    Other than waiting for the ota to appear again how can I get it back?

    Advertisement
  2. jmar

    jmar Nexican VIP Member

    If you go to Settings>Apps, swipe over to ALL.

    Find Google Services Framework and select it.

    Now Clear Data. Note, this will reset all data contained within all Google Apps, such as gmail, etc. Meaning you will have to resync everything. You can do this by Going to Settings under Accounts and selecting Google and resyncing.

    However, before you do any of that, go back to About Tablet and Select System Updates. This should then prompt the OTA installation.

    No guaranteeing it but it worked for me in the past.

    Good luck.

    jmar
    scary alien likes this.
  3. Modman

    Modman Well-Known Member

    I hit clear data. Didn't look like anything happened could try again.
    I think the ota will eventually come again by itself. Didn't notice it ask me to log in again when I opened play store.
  4. jmar

    jmar Nexican VIP Member

    After you clear data for Google Services Framework, you gotta go into settings, scroll to the bottom and select About Tablet. At the top of the About Tablet Menu will be Software Updates. Choose that, then Check Now. Should pull the OTA for ya.

    jmar
  5. Modman

    Modman Well-Known Member

    I got en error message with the dead android.

    I'm unlocked and rooted.

    I his root with ota root keeper.

    Not sure what to do?

    Will reflashing twrp and doing it with the zip file wipe out my apps and settings?

    Pretty sure I'd have to reroot with wugs.

    Why did Google all of sudden stop wiping custom recovery.
    Hiding root and taking otas was easy the last two updates.
    jmar likes this.
  6. jmar

    jmar Nexican VIP Member

    Flash stock recovery and try the method I described to manually pull the OTA again. Then let me know how that goes. I might have one more thing you can try after that short of a ROM flash:D

    jmar
  7. Modman

    Modman Well-Known Member

    Another thing to mention after it failed it seems to have broken my updates even though everything else in 4.2.1 still works. It fails the integrity check and if I hit update again it tries to update and then it leaves me at the dead android.
  8. Modman

    Modman Well-Known Member

    The only reason I dont want to flash stock + unroot is having to reinstall all my apps but I will have to if you don't have a better way.
    What is the last thing you wanted me to try?
  9. jmar

    jmar Nexican VIP Member

    You don't have to unroot and flashing stock recovery is necessary to take the OTA. Flashing stock recovery won't wipe anything BTW, only locking or unlocking your bootloader will do that.

    Take these steps:

    1. Backup your apps using Titanium Backup or your personal favorite for backing up apps.

    2. If you want to be even more cautious, copy the contents of your internal storage to your computer. You should do this any way from time to time. Trust me, I've lost everything before and I consider myself to be pretty well versed in these things.

    3. Save root using OTA ROOT KEEPER APP.

    4. Flash stock recovery. I use Scary Aliens Android Root Toolkit. (Edited: I was mistaken about Goo Manager having this functionality)

    5. Wipe data in Google Services Framework.

    6. Check for software updates in About Tablet.

    7. Take OTA.

    8. Restore Root.

    9. Let me know what all happens :D

    jmar
    scary alien likes this.
  10. Modman

    Modman Well-Known Member

    Will there be any difference flashing stock recovery from goo manager than wugs? I use stickmount to back up my data directly to a mybook drive.
  11. jmar

    jmar Nexican VIP Member

    I have never used Wugs. I made an error however. Goo Manager doesn't have an option to flash stock recovery. But my buddy's, scary alien, app, Android Root Toolkit does for sure. And it's free. Makes it very simple. Couple of clicks and that's it.
    scary alien and El Presidente like this.
  12. Groid

    Groid Well-Known Member

    From stock rom,rooted 4.2.1, cwm recovery, voodoo ota rootkeeper, I downloaded the ota from one of the many places available and copied it to my N7. Saved root with in ota rootkeeper. In cwm recovery, I installed the update, said 'Yes' to the two prompts after the install completed to keep cwm recovery and root. Upon booting up I kept root and cwm recovery with no data or app loss. You do not need stock recovery to get to 4.2.2 if you install the update file from cwm recovery.
  13. Modman

    Modman Well-Known Member

    Can I flash it with twrp also?
    I can just hit restore root in its rootkeeper without hiding root?

    I already reflashed stock recovery and its failing to update.

    The zip wipes data?

    Where does nexus 7 save ota or another source?
  14. jmar

    jmar Nexican VIP Member

    If the OTA fails to flash in stock recovery, then it won't flash using a custom recovery either. What you need is OTA Verifier, also by scary alien. This app can analyze the OTA zip (so you will need to know the location of the OTA zip on your device to point the app to it) for you and cross check it with you current installation to test whether or not an OTA will install properly through stock recovery. Use it to see WHY, which the app will tell you, it won't install. I used it to take the OTA to 4.2 from 4.1.2. I had frozen an app and modified another. The app told me that was why it wouldn't flash.

    (The app will provide you an output of what it finds. Copy this info so you can send it to scary alien, especially if you don't understand the findings)

    I fixed those two things then took the OTA without a hitch.

    Gonna PM scary alien to take a look here since he is the dev of the app and can provide a higher level of assistance.

    jmar
    scary alien and Modman like this.
  15. Modman

    Modman Well-Known Member

    I used to know the directory with the ota but I forgot.
  16. jmar

    jmar Nexican VIP Member

    /cache

    :D
    scary alien likes this.
  17. scary alien

    scary alien not really so scary Moderator

    jmar's doing a great job with you here, Modman.

    Let us know what is reported by OTA Verifier and/or if you have any questions.

    Cheers!
    jmar and Modman like this.
  18. Modman

    Modman Well-Known Member

    Not sure why? If it were there id check it
  19. scary alien

    scary alien not really so scary Moderator

    Is this the 4.2.2 OTA for the N7 (wi-fi grouper)?

    If so, I'll see if I can dig-up the link and have you download it to wherever you like and then scan it with OTA Verifier.

    Let me know.

    Thanks!
  20. scary alien

    scary alien not really so scary Moderator

    Actually--I just thought of something!

    If you can confirm what exact OTA or flashable .zip file you're trying to install, I can make you an "empty" .zip file that just contains the updater-script file and you could run OTA Verifier against that to tell you exactly what you are missing.

    That way, you wouldn't have to download and install the whole OTA file (or worry about where/how to get it) until you've figured-out why it won't flash/install.

    Let me know.

    :)
  21. Modman

    Modman Well-Known Member

    Ota verifier can't open /cache folder

    When I look at /cache through Astro the folder is empty.

    Sounds good.

    Post the link

    Thanks for your help
  22. jmar

    jmar Nexican VIP Member

    Hey brother,

    Astro doesn't have the capability to see the /cache folder. A free root file explorer that can is ES File Explorer. Find in the Play Store. Once downloaded, go into setting and scroll down to the root settings section. Tap on it and check all the boxes that are unchecked. Now you should be able to find the OTA in the /cache folder. Now copy that zip to your internal storage, in a folder of your choosing, so you can use OTA Verifier to select the zip. Then you should be able to know what is causing the OTA to fail.

    Keep us posted.

    jmar
    scary alien likes this.
  23. scary alien

    scary alien not really so scary Moderator

    Modman,

    Are you still rooted?

    If so, OTA Verifier should be able to look in the /cache directory...

    Although, I do think that the OTA .zip file might get removed after a failed install (but not 100% sure), so that might explain why you can no longer see it.

    I've almost got the .zip file ready for you...BRB!
    jmar likes this.
  24. jmar

    jmar Nexican VIP Member

    The zip remains until cache is cleared in recovery.

    And yes, you should be able to find the OTA in the /cache folder using OTA Verifier.

    Thanks scary!

    jmar
    scary alien likes this.
  25. scary alien

    scary alien not really so scary Moderator

    Okay, here's a truncated .zip file for the 4.2.2 N7 OTA:

    View attachment ota-verify-me.zip

    I ran OTA Verifier on my N7 against it and it came back just fine (I'm on 4.2.2 already, so I would expect a clean status).

    There are actually no files inside there ota-verify-me.zip file other than the 4.2.2 updater-script and the update-binary file (there are a few others, but these are the main, relevant ones), so it wouldn't do you any good to use it with anything other than OTA Verifier.

    So, copy this to your N7's SD card area and point OTA Verifier to it, long-press the filename, and select "Verify OTA .zip".

    Let us know what it reports!

    Cheers!

Share This Page