How do I get the thing to not ring when I unplug charger?Support


Last Updated:

  1. Simba1

    Simba1 Member This Topic's Starter

    Joined:
    Jan 18, 2010
    Messages:
    17
    Likes Received:
    0
    Just got the 2.1 update for my Moment. Have a problem. I leave my phone on at night on the charger. I get up way earlier then my wife. Now after the update - my text notification ringer goes off when I plug in and unplug the charger. I tried turning off the "Notification Ringtone" - and that worked to kill the charger plug/unplug sound - but it also turned off the ring when I get an incoming text. That just will not work - turning that on and off all the time. Is there a way to just disable the sound when the charger is plugged/unplugged? PLEASE???
     

    Advertisement
  2. ovrrdrive

    ovrrdrive Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    1,215
    Likes Received:
    389
    I have the same complaint with mine. It really sucks. I think I read once you can set a notification tone in handcent for your texts and then turn off the stock notification ringer but I haven't tried it.
     
  3. Simba1

    Simba1 Member This Topic's Starter

    Joined:
    Jan 18, 2010
    Messages:
    17
    Likes Received:
    0
    What is "handsent" and can anyone tell me if this might work??
     
  4. jasonacg

    jasonacg Well-Known Member

    Joined:
    Mar 11, 2010
    Messages:
    245
    Likes Received:
    37
    Handcent SMS would do the trick.

    Within that app, you choose your notification tone for text messages. It can be different than your default alert tone (which, in your case, is nothing).

    The app goes one step further, and lets you assign different ringtones to different phone numbers/addresses, just like you can assign different ringtones to voice callers.

    I've been using it for nearly two months, with no complaints. It's free in the Market.
     
  5. Stoney62

    Stoney62 Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    512
    Likes Received:
    38
    Menu/Settings/Sound and Display Settings--Remove check from SD card notifications.
     
  6. ovrrdrive

    ovrrdrive Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    1,215
    Likes Received:
    389

    Have you actually tried that in 2.1?

    It doesn't work.
     
  7. Stoney62

    Stoney62 Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    512
    Likes Received:
    38
    Actually, no. I never bothered with it since it's comforting to hear the notification sound when I plug in the usb.
     
  8. ovrrdrive

    ovrrdrive Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    1,215
    Likes Received:
    389
    For some reason sprint broke that fix when they released 2.1. I did that on the stock 1.5 and it worked but no one has been able to fix that part in 2.1. I figured a dev would have found it by now but evidently the problem is buried deep within the code...

    I unplug my phone early in the morning when I leave and it's pretty annoying. I'm just dealing with it like all the other little minor annoyances in the phone.
     
  9. Stoney62

    Stoney62 Well-Known Member

    Joined:
    Nov 8, 2009
    Messages:
    512
    Likes Received:
    38
    I heard that! All-in-all, I've been very happy with my phone. But can't wait to be able to get the EPIC or whatever's next in line.
     
  10. HeadlessPonch

    HeadlessPonch Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    255
    Likes Received:
    29
    Have you gone into 'Messaging/Menu/Settings/Select ringtone' to set a ringtone? If not, then the phone is using the stock tone for messaging/usb/whatever else. The stock notification ('MenuSettings/Sound and display settings/Notification ringtone') and the text notification are two separate ringtones, as long as you've set a separate messaging tone.

    I just had a friend text me after setting the stock ringtone to 'Silent'. I heard my messaging tone (Worf telling me "Incoming message") just fine. Then I plugged/unplugged the usb charger - no sound.

    Now it's too quiet. I'm going back to 'Voila'.
     
    roadzombie and Simba1 like this.
  11. Simba1

    Simba1 Member This Topic's Starter

    Joined:
    Jan 18, 2010
    Messages:
    17
    Likes Received:
    0

    You ROCK!!!!!!!!
    Works PERFECTLY! Not to mention I discovered the way to dump messages automatically after 200 and how to make the phone vibrate when receiving messages!

    THANK YOU!!!!!
     
  12. HeadlessPonch

    HeadlessPonch Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    255
    Likes Received:
    29
    Glad I could help. Also glad I wasn't completely wrong (it's been known to happen).
     
  13. Simba1

    Simba1 Member This Topic's Starter

    Joined:
    Jan 18, 2010
    Messages:
    17
    Likes Received:
    0
    Maybe the Mods can put your fix up in the "Tips and Tricks" sticky? I've had the phone now for months and never knew there was a menu for messaging....
     
  14. namecie

    namecie New Member

    Joined:
    Sep 13, 2010
    Messages:
    1
    Likes Received:
    0
    I'm just glad I'm not the only one who doesn't know some of these seemingly simple things. I've been a Moment owner since June, and have already had to have it replaced twice for lock-up issues. Hopefully I can find future fixes on here with you guys.
    Thanks,
    J
     
  15. AndroidSPCS

    AndroidSPCS Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    3,222
    Likes Received:
    478
    I must be missing something.

    I only have two areas to customize the ringtone:

    1 - ringtone (phone calls only)
    2 - notifications (text, all other notifications)

    I don't see a separate text notification ring tone.

    Can you please clarify your statement?
     
  16. my1zamboni

    my1zamboni Well-Known Member

    Joined:
    Apr 18, 2010
    Messages:
    62
    Likes Received:
    13
    Your text ringtone is actually in the text app not in the phone settings.
    Just open your text app go to settings and select the ring tone there.
    You do only have 2 ringtone options (phone & notifications) in the actual phone setting.
     
    AndroidSPCS likes this.
  17. AndroidSPCS

    AndroidSPCS Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    3,222
    Likes Received:
    478
    Holy crap you're right!!!! I've never really messed with the settings of the text app. I've been wanting a separate text ringtone for ages and never thought to look there, since the "Sound and Display" seemed to make it clear that all sound / notification settings should be in that single place!!

    This makes me a bit pissed off...the poor design. Shouldn't the Sound and Display settings also show the text notification ringtone as well? This is a bit haphazard and ill designed!!

    No wonder people complain that Apple's iPhone seems easier than Android!!!! :mad:
     

Share This Page

Loading...