how do i give an app super user premission?


Last Updated:

  1. pirate943

    pirate943 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    207
    Likes Received:
    10
    so im trying to get 'ad-free' to work and super user keeps denying it premission.

    i set super user to automatically allow permissions. webkey and all the other apps that need SU haven't been a problem. its only this one.

    so, have you guys tried ad free? does it work? and how do i force super user to give an app permission?
     

    Advertisement
  2. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    so i assume your rooted and unlocked?
     
  3. pirate943

    pirate943 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    207
    Likes Received:
    10

    yes sir. i only have a few apps that need root and unlock, and those had no problems getting super user permission. i was promoted with a window asking if i would like to grant permission or not...with ad free i didnt get a prompt
     
  4. IzelTokatl

    IzelTokatl Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    579
    Likes Received:
    88
    Yes, works fine.

    If you block it on accident the first time, then it's blocked ever time after. Just go into the super user app and look through the list of apps asking for permission. You can allow there or clear that app.then turn on ad free again and you should get the root access request again.
     
    trophynuts likes this.
  5. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    Moving thread to HTC Rezound All Things Root section.
    Reason: Thread is a root specific topic. You'll get additional feedback in there.

    Thanks for understanding. :)
     
  6. pirate943

    pirate943 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    207
    Likes Received:
    10

    where can i allow it? i go into the superuser, and it has a list of apps that have permission, and a log of which apps were allowed and not allowed...i dont see an option to add an app to the allow list

    also, i never blocked it. it was automatically denied for some reason
     
  7. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    try uninstalling and reinstalling ad free.
     
  8. pirate943

    pirate943 Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    207
    Likes Received:
    10

    tried it. i also tried another blocker app...same results, automatically gets denied with out prompting me
     
  9. trophynuts

    trophynuts Well-Known Member

    Joined:
    Jul 6, 2010
    Messages:
    5,630
    Likes Received:
    1,792
    hmmmm... maybe try contacting one of the devs of one of the apps?

    sorry i'm not much help man but i'm drawing a blank.
     
  10. pwned

    pwned Well-Known Member

    Joined:
    May 12, 2011
    Messages:
    75
    Likes Received:
    30
    Clear the super user app data.
     
    ou7shined likes this.
  11. ou7shined

    ou7shined Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    131
    Likes Received:
    1
    Brilliant idea. I had a similar problem and this fixed it for me. Cheers.
     

Share This Page

Loading...