How do I mount my Milestone under my Linux without the media cradle?Support


  1. back2usenet

    back2usenet Member

    Hi,

    I've got a Motorola Milestone and would like to mount it to my Linux (Suse 11.2) without the use of the media cradle.

    With the cradle, you pop the phone on, connect your USB cable to the cradle and to the computer, and -- very important! -- switch your cradle from "charge" to "sync". Then your Milestone is immediately recognised as a USB mass storage device and all is fine.

    But without the cradle? The phone charges from USB but won't talk to my Linux. There is absolutely nothing in the syslogs, so it looks like the phone is not behaving as a USB-enabled device.

    It seems from the above that I should switch my phone from the charging mode to sync, but does anyone know how to do it?

    Any pointers are much appreciated!
    Elena

    Advertisement
  2. back2usenet

    back2usenet Member

    Hi, here's my reply to my own post :) in case someone else is faced with the same problem.

    I've been investigating this further, and I now suspect that the problem lies with the cable. I've been trying to connect the phone using a micro USB to USB B connector that came with it, and a random USB B to A cable. Nothing. Charging works, that's all. I've also tried a micro USB to USB A cable that came with my camera -- the same result.

    However, after reading this and that out there on the web, I now believe that these cables fail to connect one wire that makes it impossible to establish USB over them, whereas the cradle connects all the wires properly.

    I have ordered two micro USB to A cables, one actually from Motorola, that claim to be able to establish both data and charge connection. They'll be here early next week, I recon. I'll post a new update once they arrive.

    With this said, if anyone does know anything else about this business, I'm still very interested to hear it, please! :)

    Keep cool
    Elena
  3. Szadzik

    Szadzik Well-Known Member

    Waht about simply choosing memory card access in usb connection manager that pops up in notification bar when you connect it?
  4. back2usenet

    back2usenet Member

    I don't get any USB icons in the notification area... That's why I think now it must be the cable.
  5. back2usenet

    back2usenet Member

    Hi guys,

    Just in case someone faces the same problem, here's the solution.

    It was indeed the cable. There are plenty of USB B to A cables that don't in fact connect all the five wires. In some cases you can only charge, in other cases you get nothing at all.

    The correct cable will be listed as data/sync AND charge.

    Once connected, you get the USB icon in the notification area of the phone (the bar at the top of the screen that you can pull down). You get four options: portal & tools, windows media sync, memory card access and charge only. For Linux, only the latter two options are of use, and are working as expected.

    Note that when your phone is connected for memory card access, the SD card is mounted to your PC (if you have automount enabled, otherwise mount it manually), and is UNmounted from the phone.

    Hope this helps someone! :)

    Keep cool
    Elena

Share This Page