How do I push Droid contacts back to Gmail's "My Contacts"Support


  1. My phone will pull from "My Contacts" occasionally but it isn't sending the phone's contact information back up. VZ pulled my info from my old phone and loaded it on here. Now I want to get that info back up to My Contacts so I can edit/merge. Then I'd be fine with blanking the phone's contacts and pulling down a fresh/clean list.

    Advertisement
    :
  2. rawness

    rawness Well-Known Member

    I want to know this too.

    I'm more concerned about when I add a number while I'm out...I want it to be synched with My Contacts.

    Also, if I delete a contact, I'd like to delete in My Contacts as well.
  3. This is an inexcusable flaw in my view. There is a stream of contact questions just floating by the front page on this forum with no answers/insight... documentation!

    Its a phone for crying out loud. Contact functionality is a primary objective. If this platform is going to play in the same league as BB/iPhone this stuff has to "just work" when the platform comes to market. Yeah yeah, "open source" blah blah blah. I run Linux and BSD for fun, I get it. I just expected better.
    iron mongoose likes this.
  4. bthoward

    bthoward Well-Known Member

    Just works for me. Exchange synchronization does what its supposed to. And the gmail sync seems to be doing the same as well.
  5. Hext'd

    Hext'd New Member

    From contacts, go to the menu, select your gmail account, and make sure that sync contacts is checked. Phone should have been set up to do this automatically.
    Ta2DnHim likes this.
  6. It is' that is how it pulls from gmail. Where do your phone contacs appear within your google contacts?
  7. Bxsteez

    Bxsteez Active Member

    Here is what i gather from the contact layout. There is a local account that i believe is specific to the device and doesn't get synced and then there is another full contact setup below the first that goes to the gmail account. So basically when you edit a contact the first set of information is information that came from you gmail and now is your local setup. The second set of info is info that will go back to you gmail account overwriting the info that is on gmail.
  8. Darth_Penguin

    Darth_Penguin Well-Known Member

    To test this flaw, I simply created a contact in contacts called "test". I saved it and then logged into gmail and went into contacts to see that "test" is there. I immediately created in gmail a new contact called "test2" and after saving it checked my phone and saw "test2" on it.

    To summarize, THERE IS NO FLAW...

    Here are a few things you can try if your phone wasnt properly set up at verizon.

    http://androidforums.com/motorola-droid/15069-contacts-dont-really-synchronize.html#post90296

    Hope that helps :cool:
  9. Man, I can say with ab solute certianty those things are all done. I remind you it is pulling from mycontacts so obviosly accounts are aligned, permissions given and Sync is enabled.
  10. CRPercodani

    CRPercodani OFWGKTA VIP Member

    Well sucks for you but my contacts having always synced both ways with my G1 and now with my Droid. You obviously have something setup wrong because it constantly syncs with Google so any contact you create on the Droid WILL sync with Google unless you have a setting disabled. Try calling VZW or Google as maybe your problem is deeper then the phone itself.
  11. Darth_Penguin

    Darth_Penguin Well-Known Member


    I just tested this both ways. I made a new contact in my phones contacts, showed up on gmail's contacts, deleted from gmail contacts and it deleted from my phones contacts. I then made a new contact from my phone, waited for it to show up on gmails contact list, deleted it from my phone contacts, refreshed gmail and its still there.

    It appears that if you add a contact to gmails contact list the only way to remove it is via gmail, even if you delete it off your phone. I dont think this is really a bad idea because in the event that you mistakenly delete someone it will still be up on gmail.
  12. Derekv

    Derekv Member

    I just found out about google contacts through this thread lol. Checked and all the contacts I added yesterday were there.
  13. Darth_Penguin

    Darth_Penguin Well-Known Member

    OK, I took this one step further just to test a more few things. Somehow gmail knows which contacts you have deleted off your phone because even though they stay on your gmail contact list they dont resync. I tested this by adding a new contact on gmail while leaving the previously deleted contacts in place. I then checked my phone and only the new contact synced to the phone. I have to say, its pretty impressive.
  14. Shootr

    Shootr Well-Known Member

    X2 - Jeez, this just gets better and better!!!
  15. Gnome

    Gnome Member

    I can get my contacts to sync from gmail and if I add a contact from phone it goes to gmails. However the info that was on my phone from verizon switiching over my contacts is not and if i edit it has a account labels Phone-Only (unsynced) contact.

    Could this have to do with the Verizon rep adding my contacts before my gmail account as added to the device? Going to try and reset phone and load my gmail account and then the vcards. This processed worked!

    If you phone contacts will not go to gmail do the following:

    If verizon rep moved out your contacts more then likely you will have a vcard on your sdcard aleady but to be safe export contacts to sdcard.

    Then go into settings/privacy/factory data reset.

    Once the phone is reset follow the on screen instructions

    Once u have your gmail account set up go to contacts and select import contacts.
  16. Gnome

    Gnome Member

    Hope that helps some people.
  17. Sounds like this is probably my problem. Did you lose all your installed apps and settings in this process?
  18. Gnome

    Gnome Member

    U will not lose your installed apps but you will lose settings. But not a big deal for me since i got the phone yesterday. Just happy to be able to get all my contacts synced together.
  19. I went though the reset and nothing pops up on Gmail. I'll check again in the morning.
  20. Nope. That just blew away everything I had from my old phone.

    I did back it up, thankfully.

    How can I totally blow the phone away and start from scratch?
  21. cmebionic

    cmebionic New Member

    When I purchased the droid, before I could sync my gmail contacts, Verizon rep helped me transfer my contacts from my previous phone, a blackberry. Now I have duplicate information for each of my contacts, one set from gmail and the other set which says "Phone only (unsynced) contact". How do I remove the information from "Phone only (unsynced) contact"? Thanks.
  22. Gnome

    Gnome Member

    That the same thing that happened to me. First check and see if the vcard fromyou blackberry is still on your sdcard. If not go to contacts and select export. Factory reset the phone and then follow the on screen instructions. Setup your gmail account and sync. Once this is complete import your old vcard.
  23. rawness

    rawness Well-Known Member

    Well, if I delete a contact I want it to be deleted, so I wish there was an option for full synching, in that respect.

    Contacts added from my phone are now showing up in Gmail, so that's a relief, and if the contacts I delete from my phone are not resynched when I add another contact and it resynchs, then I can live with it. I still wish it would delete it from Gmail, though.
  24. cmebionic

    cmebionic New Member

    Hi,

    I was also facing all the problems with contact, that is being discussed under this thread. I think factory reset is drastic step and so I didn't prefer doing it.

    My solution:

    1) First ensure that you have all the contacts as you desire in your google/gmail account.
    2) Export these contacts as vCf (vcard) format and save it to your computer.
    3) To give a fresh start. No go ahead and delete all or as much as contacts as you need from your droid, especially the onces where you need to get rid of "Phone only (unsynced) contacts".
    Now you will get a notification which says "Too many deletes" Its o.k. to leave it as such. It will also give a 'sync error' when you try to sync with gmail contacts. Dont worry!
    4) Now connect your droid with your computer using USB. I assume you know how to enable transfer of files.
    5) Copy the "contacts.vcf" to SD card in droid (under folder 'DCIM') that you had previously exported from gmail and had saved in your computer.
    6) Now go back to your contacts in droid and import from SD card this vcf file. It will import all the contacts in to droid.
    7) Now try to sync it with gmail account. It will do it as instructed!
    8) Go to your notifications. Find the alert "Too many deletes". Long press on it, it will give you the option to delete all. Do it and you are done.

    I hope this helps.
  25. cww256

    cww256 New Member

    I am having this same problem, and it is getting pretty frustrating.

    I can create or delete a contact from gmail contacts using my computer and the change shows up in my Droid contacts.

    If i delete or add a contact from the phone it is NOT changed in gmail on my computer.

    I checked the sync settings and noticed something odd. On the Accounts > Manage Accounts menu there is a list: Sync Calendar, Sync Contacts, and Sync Gmail. Each has a date and both Calendar and Gmail are up to date, but Contacts is from 2 days ago when I forst bought the phone. Pressing the menu button brings up an option to sync all. Each account will sync, get a sync icon that disappears, and the date updates, but the contacts' sync icon does not disappear and the date does not update.
Loading...

Share This Page