How Do I Upload Photos From Samsung Galaxy S to PC?


  1. jbass58

    jbass58 New Member

    I'm a Tech-Moron, can someone please tell me how to do this? I plug in the phone to the computer with a USB connection and the computer doesn't seem to know that the phone is there. That's where I've been stuck for a month now. Like I said, I'm a tech moron.

    Advertisement
    :
    rukhsar likes this.
  2. Gleth

    Gleth Member

    After you plug the phone into the pc, check the status bar of your phone. There should be a USB Connected link there to select which will give you the option to Mount the phone. Once you've done that your pc should see your phone ok.

    Don't forget to remove your phone from the pc using the tray icon before selecting Unmount from the phone.
    platyfly likes this.
  3. Gleth

    Gleth Member

    Double post...
  4. dredayholiday

    dredayholiday Member

    If you look at your phone and there is nothing in the status bar after connecting it, which my Samsung Behold 2 used to do sometimes, go into the phone options and toggle the connection setting, then it should come up.
    bininjette04 likes this.
  5. zylstra

    zylstra New Member

    So I see my phone in the file system. Now I'm trying to figure out which folder on my phone contains the photos (if the connection doesn't crash my Windows Explorer first). Any ideas?
  6. Shak-Attack

    Shak-Attack Member

    As almost ANY Digital camera would be...
    the DCIM folder contains your photo's taken from your phone..
    Media folder would be any photo's you placed yourself...
    But Generally DCIM is your Main folder...
    This is after you Set your Photo to Mass Storage.

    Samsung Galaxy S Exact Instruction to Confirm and explain Below;

    Plugging in Samsung Galaxy S:

    Step 1. Settings > [Scroll to the Bottom] About Phone > USB Settings > Select "Mass Storage" [This should be the one with Green Dot, if it isnt, Select it] - Once this is done Exit to home screen (Press the back button until back to main screen with background - Not necessary but no point having it on setting screen)

    Step 2. Plug in Device to Computer via USB Cable - XP / Vista / 7 works good - Mac Tiger or up Works good too

    Step 3. Use the Top Status Bar and pull it down.

    Step 4. Select the Status that mentions "USB Connected"

    Step 5. A pop up window will show up. Press - MOUNT

    Your Device SD is now mounted to PC and is acting as a Mass Storage Removable Disk.

    My Computer > Removable Disk X (where X is the next letter available to name a drive)

    There you'll find your DCIM folder Plus other folders.
    Drag / Copy / Move - Any files you need
    Once Done Follow these Steps:

    Removing / Unplugging Samsung Galaxy S:

    Step 1a. Close the Removable Disk Folder and Make sure No Files is Transferring and/or make sure no program (including windows) is talking to the Removable drive.

    Step 1b. You can Safely remove your Drive from your computer. But this step isn't necessary.

    Step 2. Open your Status Bar on your Phone on the top screen by pulling it down

    Step 3. Click on Status bar "Turn off USB Storage"

    Step 4. a Pop up will show up. Click "Turn Off" - This will Dismount your removable Drive from your computer.

    Step 5. Unplug your USB cable.

    You Are Done.
    Simple...:p

    You have another Option. Download Samsung Kies. from Samsung Official Website.
    Support for that program is offered by 1-800-SAMSUNG. Although I personally ill advise using that program unless you need to update your phone or back up Device Memory Contacts. That program has known issues and Samsung has taken it off there website numerous times to do "Patch updates" on it to prevent it from crashing.

    Hope This Helps. :D
    sarahbeee, Bonaney, Snowsmile and 6 others like this.
  7. LouiseG

    LouiseG New Member

    Simple when you know how - thank you!
  8. CdnGoose

    CdnGoose New Member

  9. TeamConway

    TeamConway New Member

    Hi

    Thanks to the above advice I'm making progress and can get to step four, but I don't get the "mount" pop up and seem to go in a continuous loop of

    "usb connected to computer via usb. tap the button below to copy files between teh computer and SD card/2, so I tap "connect to USB storage" and it says "usb storage in use, disconnect SD card from computer before disconnecting USB storage" so I tap the button below saying "turn off" and then it goes back to the begining.

    I don't ever get to actually access the phone's memory - can anyone help?

    (and yes, I've now switched it so that my photos save to the SD card but I'm trying to get to the 300 photos I've already taken!)

    all help much appreciated

    a new mum trying to print photos of her new baby!
  10. LeepyLee

    LeepyLee Member

    What about the Galaxy S2?
    There is no "USB Settings" in the "About Phone" section...
    My PC simply sees the S2 as a camera, but shows no files or folder structure for it.

    Anyone any more info for the S2 please?

    Thanks
  11. Usta

    Usta Well-Known Member

    These are fairly standard steps, but for the exact Menus you are better asking that in SGS2 forum section.
  12. tez70

    tez70 New Member

    Hi Everyone,

    LeepyLee I have the Galaxy S and my 'USB Settings' are in my 'wireless and network' section and not in the 'about phone' section.

    I too cannot for the life of me transfer my mobile pics to my PC I have tried using Kies and the mass storage option but I cannot get to step 3! I can select the mass storage option but there is nothing in the drop down menu (notifications) does anyone know what I could be doing wrong?

    Many thanks!
  13. belltech1275

    belltech1275 New Member

    I use Wifi Explorer Pro and I use my wifi via my lan to trnfer files go to Android Market 99 cent app for the Pro.The free version you can't transfer files.:)
  14. Denny58

    Denny58 New Member

    I had same issue, handbook didn't explain this and only mentioned Kies. In frustration have downloaded Kies and it didn't kill my computer or my ophone, alrho this is still uploading music so not actually sure :cool: Kies has uploaded photos OK.
  15. JosieJoce

    JosieJoce New Member

    I have spent the last week reading all your comments and solutions for the problem that I am having. My problem appears to be the same as the majority of comments - I am also struggling to get access to Samsung Kies from my Galaxy S in order that I can download photos.

    Kies will allow me to highlight "connect to a device", however when I do this, a picture screen comes up informing me of the various ways I can connect, (my phone says connected however the computer doesn't!) Plus it won't allow me to highlight any of the pictures, so I am not connected to Kies!

    When I followed the steps above, I was able to follow the instructions for the phone, however when I got to the my computer, I could not find the following:

    > Removable Disk X (where X is the next letter available to name a drive)

    Any help and advice would be much appreciated!!!!
  16. VinBarbarelli

    VinBarbarelli Member

    Hi,
    I have a solution in my next post.
    Forum requires me to introduce myself before I can include a link.
    Hi.
    Be right back with solution.
  17. VinBarbarelli

    VinBarbarelli Member

    Hi,
    I have a Galaxy S (GI9000) and had this problem and found NO help on Internet for days. Until I happened across a YouTube clip from Samsung. That was the missing piece for me. Here are the steps:

    1. Hook up Galaxy S to computer with USB cord.
    2. My phone gives me three options: 'Kies' (which doesn't work), 'Media Player' or 'Mass Storage'. Select 'Mass Storage'.
    3. My phone says 'USB Connected', but it just means the cord is connected. Hit the 'Connect USB storage' button.
    4. You should see Windows Explorer open with the phone's INTERNAL SD card's folder.
    5. Follow the instructions in Samsung's video here: Captivate - How to Transfer Media to a Computer - YouTube. Basically, you need to copy from the INTERNAL SD card to the EXTERNAL SD card. Then, you can copy from the EXTERNAL SD card to your computer.
    6. Make sure you copied every file you selected. It took me a couple of tries; it may require several passes with different files selected; it may depend on the size of your EXTERNAL SD card.
    Hope this helps someone.
    ALF2011 likes this.
  18. narrowboat

    narrowboat New Member

    Check List for you:
    'Settings' on phone select'Wireless and network'.
    From this select 'USB settings'. You will get 4 choices but select Mass Storage(should be green circle next to it.
    Connect camera to PC via USB and little green android man will give you a nudge to select 'connect USB'.
    Voila. On PC you should get a nudge that you now have removable Disk which has several choices. Select DCIM.
    You will get 3 folders one of which is Camera. Select this and all your piccies will be displayed for you to move where ever you want them to go. Such as create a folder to put them in or send individual piccies to places such as documents etc. Hope this helps.
  19. ALF2011

    ALF2011 New Member

    Thank you for your post. Very informative and solved my problem. You're a life saver!
  20. silverquill

    silverquill New Member

  21. brumbrum

    brumbrum New Member

    Hi All,

    Sorry to butt in but I need simialr help ;-) I also have a samsung galaxy S and I am unable to get the photos from my phone to my PC via USB. It seems my computer is not reading the fact the phone is connected. The phone tells me 'USB connected' and I choose to 'Mount' but at this point, i assume the removable disk should be accessible but its not. No pop-ups and not on the 'computer' tab??
    Any help would be greatly received!!
    Thanks
  22. scorpio11

    scorpio11 New Member

    Suffered similar frustration for a while today with my new new Samsung Galaxy S Plus as my PC was not recognising the phone, could not automatically find a driver and other issues. Never had an issue with any other phone I've owned and Samsung should provide proper instructions. This is how I did it eventually and transferred my photos to my PC.

    1. Press Settings
    2. Press + Add
    3. Press Widgets
    4. Scroll down and select Program Monitor to add this widget to your Samsung screen
    5. Tap the widget and close all active applications
    6. Press Settings
    7. Press Wireless and Network
    8. Press USB settings
    9. Click Media Player so green dot beside it
    10. Connect USB cable to PC slot
    11.Connect USB cable to Samsung Galaxy S Plus
    If you do not close all applications prior to connecting the USB cable you will see a message now saying "PC connection only available in idle. Close any running applications", in which case, start again as described 1-5 above.
    12. Once the USB is connected with all applications closed, your PC should detect the Samsung Galaxy Plus S and automatically install the Samsung driver. It did with mine.
    13. Your phone should now show a black screen with a silver USB connector image and below it:
    "Connected. Press the home key to exit Media Player"
    Do not press anything, leave as is and now your PC Autoplay window should have opened on your computer.
    14. Click Open Device in Autiplay window to view files
    15. Double click phone icon on next window
    16. Double click DCIM on next window
    17. Double click Camera to access your photos and select/drag/drop to your PC folder.
    MissJeezey likes this.
  23. dancing

    dancing New Member

    Hi all,
    My fone (samsung galaxy s2) has apparently got moisture init and they are sending me a replacement in tomorrow.
    But it dont even switch on or nothing so how can i get my pictures of it to go on PC as will not work via cable. I did not get a memory card with it and they did not tel me this and so all photos are on fone but i dont really want to loose them all but how can i get them off?

    Any help would be great thank you
  24. I think you should select the mode as removal disk mode.
  25. Gojipoj

    Gojipoj Member

    Hi there I have a problem, since upgrading my galaxy s2 software to 2.3.5 My IMac does not display my phone icon, as it did before the upgrade. However it is greyed out in the Disk Utility area and it asks me to do a fist aid on it and I have tried a number of times and still no luck. All this with the phone connected of course.

    It tells me that I need to back up my phone and format it due to some errors, I don't know how to back up my phone. I'm relativly new to Android phones and not sure how to do it. Any assistance will be great as I want to transfer my photos and music and movies to mac and to the phone before the upgrade took place.
Loading...

Share This Page