How do you root a PendoPad 4.0 PP4MT-7?


  1. Whitto69

    Whitto69 Member

    Hoping somebody maybe able to help.

    I purchased a PendoPad 4.0 PP4MT-7 on the weekend from Coles for $99. After getting home found out that although it is an Android pad it is not one that has "Playstore" but instead uses "Getjar" for applications. Doing a search on how to root this pad has proved fruitless and hoping that there may be somebody out there who has managed to root this item and can share their experience?

    I have read the threads on this forum on the pendo pad and suggestions on how to root but this is for earlier versions of the pad with a different chipset, all attempts to root using Z4Root, Universal Androot etc have failed.

    My fingers are crossed for some info on this one.

    Cheers

    Advertisement
  2. FrAsErTaG

    FrAsErTaG New Member

    Gday

    I just got one of these for $99 and when searching for root I found your post, I found out how to root it so i signed up to share.

    Use this free program
    mediafire.com/?6dblmt98qj8wxeh
    it is from unlockroot dot com but there download is broken at the moment.

    Connect via USB with Debugging mode enabled.
    Once its rooted and reboots you can put Vending.apk and GoogleServicesFramework.apk in /system/app with 644 permissions.

    Once that is done market works :)


    P.S. Had to remove links
    styelz, Jules13 and bubbasd like this.
  3. Whitto69

    Whitto69 Member

    Thanks for the reply FrAsErTaG however my pc is not picking up the PendoPad when I go to root it using UnlockRoot V2.3.1. It wants to install a driver however searching on the net I have been unable to locate the one I need. Found a write-up about needing to get a driver for it however Pendo is not in the list of available ones. Can you advise which driver you used?

    Thanks
  4. FrAsErTaG

    FrAsErTaG New Member

    I've got lots of drivers installed on my system, I did not need to install ADB drivers as I had a driver installed that worked.

    I think these might be the drivers that are working
    LiveSuit.rar

    Note there are two folders, one is for a device in Fastboot and the other was ADB, I am not 100% these are the working drivers but they share almost the same hardware.
    Whitto69 likes this.
  5. Ninjafrogv3

    Ninjafrogv3 Member

    Hi there,
    I get the error messages that Android and GP have stopped responding.

    I was able to do this with your method which installed GP and GSFW (With out Drivers,Through ASTRO File Manager, But was unable to put them in System/Apps?) but i got the error message for GP. I then used an older version of the apk which installed and added the "Shop" feature to my Pad and let me accept the terms and conditions but then those 2 error messages. But since i was able to access the GP App on it, The Google.com/Store now has my device add (As Unknown PP4MT-7) and i tried that way it says its downloading then installed but nothing....

    Ive got alternative Markets, But wouldn't mind having GP..
    Any help would be appreciated.

    PS: Even a way to downgrade ICS to GingerBread or HoneyComb?

    Thanks.


    Terms- GP- Google Play. GSFW- Google Services Frame Work.
  6. willfa47

    willfa47 New Member

    Hi
    I'm still struggling with this.
    I downloaded livesuit and still can't find the drivers.
    Has anyone been successful yet? I really want to get gp on my pendo.
    Can anyone give me a step by step?
    Thanks :)
  7. Whitto69

    Whitto69 Member

    I have finally managed to get Unlockroot working, had to use my 2nd pc running XP as it wouldn't work however hard i tried on my Windows 7 pc. Still having issues get GP working...try to logon with my credentials but trying to use a mobile service, even though connected via wi-fi....stupid pendopad :(
  8. Ninjafrogv3

    Ninjafrogv3 Member

    Been able to load GP and Ive had market as well but still get the error message that GP/GSFW/Market/Android has stopped responding and it force closes. Ive looked at some other ways including using HTC Components, but sadly still nothing.

    These are the links to those two i used:
    Install Android Market on Coby Kyros MID7012 (or most other tablets running Android 2.3.3) | Northwest Tech Experience
    Phantom's Tech DB: How to Install the Google Services Framework on Tablets and Other Devices (without rooting)

    Market Links (Open on device to install App)
    snappzmarket.com
    applant.net

    Also since the Pendo Pad is a 'Android' Device, is it possible to downgrade?
    bubbasd likes this.
  9. Whitto69

    Whitto69 Member

    I'm now getting the same issue Ninjafrogv3 :( finally got google acct to sync but get the Google Playstore stop responding and close. Never had issues with Android before but this pendo pad is giving me the.........
  10. Ninjafrogv3

    Ninjafrogv3 Member

    Hey Guys,

    I tried to take a couple of days since the pendo pad is officially starting to become a head doer inner :p But i cant get it out!
    Now GOOD and BAD NEWS, Another way of installing Apps!

    GOOD-
    Theres another alternative AM known as Pandaapps and Its Apps aren't just for free but also have the apps with current Update and there Updates past.

    Ive tried there Market app and so far it hasn't been a huge favorite so i started downloading them to the comp and SDing them and BOOM!

    But Now the Bad news }SadFace has ran away{
    Ive been able to do it on 1 of my pendo pads but wasnt able to do it on my other two. Im thinking since ive installed HTC Components and those android.com.google.(Insert) That might have something to do with it. Could someone try this and give us the verdict?

    Anyone else been any more successful? wouldn't be alright if some more of the 211 who viewed this posted helped out? even if they didnt know exactly what there talking about....

    Also on pendos site they have firmware but not for our pendos. gonna do the smart thing and ring them up and get the gist
  11. bubbasd

    bubbasd Well-Known Member

    Yay my PP4MT-7 is on google play now :D
    google play is finally installed i dont know how but it did it but im gratefull anyways.

    my steps
    1. -rooted- by use unlockroot and SuperUser (build.prop changed to samsung gti-9100)
    Uninstalled getting rid of getjar using supermanager's apk manager (it backs it up on the sdcard)
    2. using root explorer (paid) (used for copying and changing permissions)
    3. and finally got gapps-ics-20120429-signed (#cough# goo im goo.im/gapps)

    4. extracted gapps-ics-20120429-signed's system/app contents into my root/system/app folder and gave them the 644 permissions each

    5. then rebooted me pendo it it gave me the sign up procedure entered my info in and saw googleplay was installed ran and used it no force close, yay again.

    this google play is version 3.7.15

    so far soo good.

    thanks mainly to FrAsErTaG your info was Invailable thanks very much.;)
    and Ninjafrogv3 your links were great to compare too.
    cheers.
    :five:

    death to the Getjar :bike:
    KomusoDroid and Jules13 like this.
  12. Ninjafrogv3

    Ninjafrogv3 Member

    Hey bubbasd!,

    I myself am still trying to do it :p. I tried following your instructions but got lost after the apk manger step. Backed getjar up and tried uninstalling but wouldnt let me...

    Would you mind putting another little detailed step-by-step :)

    Sorry for being simple lol.
  13. styelz

    styelz Active Member

  14. Ninjafrogv3

    Ninjafrogv3 Member

    If you mean that when you put gapps system folder into /root then i got the same problem i think.
    I followed your steps and managed all that, but when i give them permissions and try to install them it says application installation failed.
    at a stand still here,
    Iam i doing something wrong? and also how did u reboot? (Unlock root, root.bat,reset on the tablet itself?)

    and here there i get a google service framework stopped responed
  15. Ninjafrogv3

    Ninjafrogv3 Member

    My steps-
    1- Downloaded Gapps and extracted on my desktop
    2- moved System (All folders inside) folder to SDCard
    3- Moved System from SDCard to Root
    4- Gave permissions and tried to install (failed)
    5- Turned off and then rested device and when turned back on says google service framework is not responding.
  16. Jules13

    Jules13 New Member

    I have been working on this for days using suggestions from all of the above and have just got it working. Ninjafrogv3 you are on the right track, dont give up.
    After extracting gapps and moving it to the sdcard download folder, open it using root explorer, copy all the files in gapp/system/apps to /system/app folder of your device not the root. I gave the whole folder permissions then rebooted pendo and now it's working.
    I had already gone through many processes before this but play store kept closing everytime so I'm unsure if this fixed something I had already done or will work on it's own.
    Credit goes to FrAsErTaG because thats where I started and bubbasd for Superuser, Supermanager, Root Explorer and Gapps which I found easily thru google. I have another Pendo to work on and I will write down each step as I do it and if it works I will post it here.
    Hope this has helped somewhat, good luck
  17. styelz

    styelz Active Member

    I have GooglePlay, 1Market and GetJar all installed and working fine together.
    I haven't changed the build.prop file and noticed that when an app on GoogleApps is not compatible with the device, the same app using 1Market will install just fine.

    I've also experienced random resets, often days apart. But i suspect the tablet is overheating.
  18. styelz

    styelz Active Member

    This works to give full "root" on the PP4MT-7.

    Make sure the tablet is in USB Debugging mode (under Settings -> Developer Options).
    Plug USB to PC.
    Download and use UnlockRoot to gain root access.

    This will root the device, but requires you to type "su" to get root and the /system partition is not writeable.

    From CMD Prompt, go to where you have adb.exe and type "adb shell", when you connect you will see the prompt with a "$" at the end, this is a normal user.
    shell@android:/ $
    When you type "su" you will become the root user.
    shell@android:/ $ su
    shell@android:/ #

    Typing "exit", will send you back to being a normal user.
    Typing "exit" again will drop you back to CMD Prompt.

    Backup your current nandc just in case:
    Code (Text):
    1. adb shell
    2. [I]su
    3. dd if=/dev/block/nandc | gzip > /data/local/tmp/nandc-backup.dd.gz[/I]
    To recover the Backup:
    Code (Text):
    1. adb shell
    2. [I]su
    3. busybox zcat /data/local/tmp/nandc-backup.dd.gz | dd of=/dev/block/nandc[/I]
    This custom nandc will drop you into root@android as soon as you start adb shell.
    The /system partition is mounted read/write by default.
    This allows AndroidCommander to work correctly.
    Download my custom nandc-root.zip (PP4MT-7 ONLY) to your PC
    Connect the USB cable to PC. Then do this using ADB:
    Code (Text):
    1. adb push "c:\path\toyour\nandc-root.zip" /data/local/tmp/.
    2. adb shell
    3. [I]su
    4. sync
    5. busybox unzip -p /data/local/tmp/nandc-root.zip | dd of=/dev/block/nandc
    6. reboot[/I]
    Adding Google Apps/Calendar/Gmail and 1Mobile Apps
    Use ADB from PC CMD prompt to connect to tablet, and push your APK's to /data/local/tmp/

    Here is a link to Latest GAPPS which contains the APK's. You can use CWMR to install this file or use the method below. You can also put the APK's into "/data/app" instead of "/system/app" if you have no room left on /system.

    Code (Text):
    1. adb push Vending.apk /system/app/.
    2. adb push 1MobileMarket.apk /system/app/.
    3. adb push MarketUpdater.apk /system/app/.
    4. adb push GoogleServicesFramework.apk /system/app/.
    5. adb push GoogleBackupTransport.apk /system/app/.
    6. adb push GoogleCalendarSyncAdapter.apk /system/app/.
    7. adb push GoogleContactsSyncAdapter.apk /system/app/.
    8. adb push GoogleFeedback.apk /system/app/.
    9. adb push GoogleLoginService.apk /system/app/.
    10. adb push GooglePartnerSetup.apk /system/app/.
    11. adb push Gmail.apk /system/app/.
    Wait about 30 seconds, while the apps install and then type.
    Code (Text):
    1. adb reboot
    Also, ES File Explorer needs to be upgraded to work with root access correctly but wont let you as it is installed as a system app. Do this to remove it:

    Code (Text):
    1. adb shell rm /system/app/es_file_explorer_v1_6_1_0.apk
    ..then install the latest version from the app store.
    KomusoDroid and Ninjafrogv3 like this.
  19. Ninjafrogv3

    Ninjafrogv3 Member

    Jules13- Thanks and i tried that way(only gave the folder permissions, not all files) and when i restarted it, it came up with android upgrading and then when i open google play it closes.

    Stylez- i saw u on another forum :p. Anyways i did it like that but this where im confused, should of mentioned im new at this :)
    I did the root with unlock root (Worked first time, But didnt need to type in "su")
    But now this is where i need major help, ADB i open it from programfiles/android/platform-tools/adb it opens, loads and closes.

    at abit of a stand still, going to keep figuring it out but hopefully someone could help me out here one last time :) CHEERS and again thanks to everyone for helping :)
  20. Ninjafrogv3

    Ninjafrogv3 Member

    Sorry Styelz, also i downloaded that file and cant do anything with it?

    Just to let everyone know, Im kinda simple haha XD
  21. styelz

    styelz Active Member

    When you say you ran adb, did you type "adb shell" ?

    Follow the instructions step by step. Once you have ADB working.
    Let me know where you get stuck.
    Ninjafrogv3 likes this.
  22. bubbasd

    bubbasd Well-Known Member

    I guess i rushed my steps a little i was a bit excited that day. but im glad it opened up to other suggestions (this post ive included referances that may clear up some confusion)

    i have found a small problem after i got google play and its services on me pendo, its not a biggy but i couldnt add other email accounts on the pendo only google could.
    eg.
    Code (Text):
    1. Settings - Accounts & Sync
    2.      - add account
    3.                             Google
    So i grabbed a couple of apk files from my ainol elf 2 tablet and copied them over to the pendo
    they were Email.apk and Exchange.apk
    (added Gmail.apk and Googlestreet.apk as also too, ive added them in atached zip if anyone else is interested.) and copied to my system/app(check notes:*) folder using Root Explorer
    then changed with 644 permissions each (within root explorer long Press the file then choose "Permissions" (check notes:^) )
    then power off/on the tablet.
    afterwards Corperate and email was added
    eg.

    -After-
    Code (Text):
    1. "Settings - Accounts & Sync"
    2.      - add account
    3.                            Corperate
    4.                            Email
    5.                            Google

    ---------------
    Notes: using Root Explorer to change file permissions to 644 while the file is on the sdcard wont work you will get
    "Warning - Permissions change was not successful. Please Note that some file systems (eg. SD Card) do not allow permission Changes."
    make sure its in the /system/app directory then change permission.

    *this Link explains the android file system structure as an example Android File System Hierarchy

    ^Root Explorer file permission 644 looks like this
    Code (Text):
    1.         Read       Write      Execute          Special
    2. Owner    [✓]         [✓]        [ ]             SetUID  [ ]
    3. Group    [✓]         [ ]         [ ]             SetGID  [ ]
    4. Others   [✓]         [ ]         [ ]             Sticky  [ ]
    eg. the file permission that you changed would look something like this
    gmail.apk rw-r--r--



    (Misc read http://androidforums.com/behold-2-all-things-root/73177-understanding-android-file-permissions.html)

    Caution extra info:
    Super manager if u give it the root permission u can uninstall system applications
    this is achieved by accessing the settings of super manager
    Find
    General Settings
    ROOT
    "Enable ROOT function" then tick it
    now the APK Manager in Super Manager can uninstall system applications (like getjar)

    Attached Files:

    KomusoDroid likes this.
  23. styelz

    styelz Active Member

    In case anyone needs them. PP4MT-7 Stock NAND Dumps

    I am also creating a Stock LiveSuit image. Will send link later. Handy if you totally trash your tablet. As you can recover it using safe mode. Pretty much un-brickable these things.

    UPDATE: Here is a STOCK PP4MT-7 LiveSuit Image :)
    KomusoDroid, Ninjafrogv3 and bubbasd like this.
  24. Jase987

    Jase987 Member

    Excellent Job. guys. Thanks

    Mostly worked for me.

    I can load and search google play but I can't install anything from site. (says I have not compatible device)

    Is that right ?

    Also I'm not sure which vending.apk to use. If that is the problem why I can't install anything from google play.
  25. bubbasd

    bubbasd Well-Known Member

    easy fix is to "pose as another phone or tablet" (because this pendo 4.0 is clearly not connected as a googleplay compatiable tablet it was connected to getjar c***p why the hell they did that is beyond me maybe the builder though it was cheaper to go with getjar than googleplay over royalties. just maybe)

    you'll need to edit your /build.prop of your tablet (you need ROOT and use a text editor to edit it or i personally use Root Explorer)

    (Warning: changing the build.prop of a tablet or phone is consitered illegal, but in this situation u need to if ya want the play store to regonize your tablet.):rolleyes:

    in the file build.prop change
    Code (Text):
    1. ro.product.model=PP4MT-7
    2. ro.product.manufacturer=unknown
    to eg.
    Code (Text):
    1. ro.product.model=GT-I9100
    2. ro.product.manufacturer=samsung
    and then save it
    reboot ya tablet then try the googleplay store again
    this time googleplay will show that your tablet is the samsung GT-I9100
    now
    cheers.:)
    (i found that posing as GT-I9100 shows more apps than others i could be wrong but if someone could start a topic on that could be helpful for many people including me.)


    Note:
    this link here has another way of changing the build.prop (with pics)
    how to install incompatible android apps from google play


    Other Misc notes:
    Just a read Google Play Device compatibility
    ------------------------------------
    Evolution of the Google Play store apk's was
    vending.apk (Android market and Google Play store)
    and now its phonesky.apk (Google Play store current)

    this link can explain better than me. A Google Apps Wiki

Share This Page