1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

How do you root a PendoPad 4.0 PP4MT-7?


  1. kaneelias

    kaneelias Member

    AWESOME work Stylez,

    Downloading now to test.
  2. styelz

    styelz Active Member

    I have a feeling that i may have messed up the boot.img
    I used "abootimg" to create it instead of "mkbootimg" and I think I was supposed to use "mkbootimg". Let me know if it worked anyway.
  3. kaneelias

    kaneelias Member

    Hey Stylez,

    Seems to be stuck at the boot screen. All that is showing is your Avatar logo and has been on this screen for 20 minutes.

    Could the boot image be the problem?

    Was able to restart the device and Flash the original image from Pendo and have restored it to the previous state for now. Am happy to test again if you change the boot image. Cheers.
  4. styelz

    styelz Active Member

    Yes, I think it may be the system image that's the problem.
    I needed to use mkuserimg.sh but left it as raw. I will try again.
    Also, I messed up the boot image by using abootimg instead of mkbootimg

    Will post URL's in a few hours.

    I am also creating a guide on how to do this here (WIP)
  5. kaneelias

    kaneelias Member

    Oh cool on both fronts.

    Will gladly test when it is available as I have managed to resurrect my Pendo Pad on 2 separate occasions now :)
  6. styelz

    styelz Active Member

  7. kaneelias

    kaneelias Member

    Stylez, you are an absolute legend. Worked a treat. Thanks a heap for all your help.
  8. Ninjafrogv3

    Ninjafrogv3 Member

    {PHANDROID, I Posted this here cause iam a 100% noob when coming to forums and thought this the easiest way to contact this person :)-Nfv3}

    Hey styelz,

    Just wondering if you would happen to know anything about the XTE-Racer (T3020 in Oz)? i was trying ROM Manager and got stuck on the green android screen, i got this mooncake recovery but when i went and did everthing and reboot it, it loads to the android and then these colored shard looking things just spin around :S i think its trying to boot and cant? ive looked at a couple of other places and am at a stand still.

    Thought i would come to the homie for advice :p

    Cheers,
    Ninjafrog
  9. bushy73

    bushy73 Member

    Styelz, thank you so much. You a champion, and have turned my cheap and nasty "free bonus", "closed system"android tablet, into a decent true android tablet. Awesome.
  10. styelz

    styelz Active Member

    Hi mate, sorry to hear about your troubles. I'm afraid i don't know anything about this phone. Try find a relevant forum for your device and ask there maybe.

    Possibly check out this thread. ZTE won't factory reset nor access FTM mode - ZTE Racer - Racer.MoDaCo.com - MoDaCo not really sure.
  11. styelz

    styelz Active Member

    Here's an attempt to get CWM Recovery installed for PP4MT-9.

    root_recovery-pp4mt-9.zip

    The tablet needs to be rooted first.
    Plugged into the PC with USB Debug Mode enabled.
    Extract the ZIP file and run root_recovery.bat from Windows.
    This will use ADB to write the CWM recovery image to nandg.
    Press enter when done and your tablet should autoatically boot into recovery mode.
  12. bushy73

    bushy73 Member

    Thanks styelz. I'll give it a try.
  13. bushy73

    bushy73 Member

    Hi Styelz, when I run root_recovery.bat from windows I get the following error message:

    " adb is not recognized as an internal or external command, operable program, or batch file ".

    Does this mean I do not have ADB properly installed on my pc? I just installed the latest Android SDK tools. Please excuse my ignorance!
  14. styelz

    styelz Active Member

    You need adb.exe and the two DLL files.
    I've added them to the zip file now.

    You can also download ADB for windows >HERE<.

    Just extract the EXE and DLL files to C:\windows\system32\
  15. styelz

    styelz Active Member

    No matter what I did to my build.prop, I could not get Play Store to recognise my device for apps like Chrome, Digitally Imported Radio and Shazam.

    I started to think it had something to do with the kernel. So i copied a kernel "zImage" from an update i found for a "HTC Holiday" device and created a new boot.img.

    Finally, it worked!

    Even RomManager works and installs a ClockworkModRecovery image.

    [​IMG]
  16. kaneelias

    kaneelias Member

    That is awesome. Does it mean there is now a new LiveSuit image for the 7 and 9.7 inch Pendo's coming *wink, wink*
  17. bushy73

    bushy73 Member


    Thanks Styelz. After following your instructions I successfully manager to run "root_recovery.bat" . However, after pressing "Enter to reboot tablet", nothing happens. When /I manually reboot, there is no CWM app showing on the tablet. Any further suggestions?
  18. NikoB

    NikoB New Member

    Hi everyone

    Firstly thanks to the contributors for the great work!

    Secondly, 2 total newbie questions:
    1. If I attempt to root Pendo pad and something goes wrong, will I always be able to fix it by pushing the 'reset' button? I'm guessing 'no' but it would be nice to know at what point I cross the line and risk bricking the device.
    2. Is there an easy newbie guide to rooting android devices (oxymoron?) someone can recommend?
  19. kaneelias

    kaneelias Member

    Are you using a 9.7 or 7 inch pendo pad? I have written up a walk through of how to root both versions and it is pretty much fail safe if you follow the instructions to the letter. There is also an option to revert back to stock rom if it does not work. If you are interested let me know what version you have and I will direct you to the walk through.
  20. Jase987

    Jase987 Member

    Great news Stylez,

    Can you give me a new Image for Pendo 9.7" with new kernel Image or tell me how to do it, so I can get Chrome to work on Pendo.

    Thanks
  21. Whitto69

    Whitto69 Member

    Kaneelias,
    If you could provide the link to the walk-throughs that would be great.
    PP4MT-7 is my version...haven't really looked too much into "rooting" the pad after i put panda-apps on it. Pretty much just using the pad as a comic/book reader

    Cheers
  22. Whitto69

    Whitto69 Member

    Stylez, you are my hero. Just followed your instructions and now have Playstore working. Thanks very much for your time and effort.
  23. kaneelias

    kaneelias Member

  24. alancramer

    alancramer New Member

    I have some news that I am about to post outside this forum that I think would be of interest to some. As this is my first post, I can't post links yet.
  25. alancramer

    alancramer New Member

    Styelz, you may want to add the following applications to your rom as well...I manually pushed all the gapps from this [SCRIPTS] - Allwinner A10 Tablets Google Play Script - SlateDroid.com site to my Pendo Pad, and now, i am able to download a heap of apps from the Google Play store, without changing my build.prop.

    In your image, you may want to change the size of system to make it a little larger, as I have 1MB left.
Loading...

Share This Page