How I fixed my lenovo ideapad a1's unresponsive screenTips

Last Updated:

  1. dbguru

    dbguru Member

    Bought the A1 as birthday present for my 8 year old daughter.

    She has been using it non-stop until the battery dies.

    While charging, she got impatient and turned it on, then the screen stopped responding to any touch. Turning it off by holding the power button, then turning it back on didn't help.

    I called lenovo tech support, told me the same, turn it off by holding power button for 10 seconds, then power on, waisted 2 hours, they wanted me to ship it back to have it fixed, then shipped back to me ! I said, no way, this is her birthday present, so tech support guy suggested I call sales and have it refunded.

    This morning I decided to try something, after powering it off by holding power button for 10 seconds, I pressed the volume + button and power button simultaneously, it powered up into some restore screen, there are a few menu options, i.e. restore to factory settings, the last was recalibrate touch, I used the volume buttons to scroll through the menu, then used the power button to "select" the recalibrate option, it said don't touch the screen, took a few seconds and powered off.

    I pressed the power button until you feel the gsensor, then let go, tablet powered up and the screen is working again !

    Hope this helps anyone else having this issue.

    Felim_Doyle likes this.
  2. Eagleridge

    Eagleridge New Member

    Do an update and it should solve the problem (Settings -> About Tablet -> System Update)
  3. dbguru

    dbguru Member

    No, that displays: Your system is currently up to date.
  4. emorrison33

    emorrison33 Active Member

    The unresponsive screen issue is not solved with the touch calibration or the update, at least in my experience. I have even gone to factory reset and the issue keeps happening. I did root the phone, and the screen issue only occurs once a week or so now. Lenovo really has to issue another update to fix the many common issues people are having with this tablet. The XDA Developers website has information on how to root the tablet. It is very easy.
  5. isomswim

    isomswim New Member

    I have some what determined what is stemming this issue but have not figured out a fix yet. While charging my 2 brand new A1s, they become unresponsive after no use and then are unplugged. If I plug it back in, either one, they become responsive again. Unplug nothing, plug back in full control. Turn it off, unplug, do touch calibration and it will fail, but after reboot it is all ok. If I leave it in standby for too long I get nothing again unless I plug it in. The 2 units I have are updated fully, 1 is rooted and another is not.
  6. isomswim

    isomswim New Member

    Double post. my bad
  7. kratos316

    kratos316 New Member

    have the same problems like the Op . just got my A1 tab fro kid 4 days a go
    cant understand how to stop the games etc that are running .also dont know how to stop music playing the only button i c is play n pause :9 any help
  8. mmmmna

    mmmmna New Member

    My NEW A1 was suffering from the virtual keyboard being almost unusable when pressing near the edges of the screen. The recalibration technique quoted above seems to have corrected the problem. I am absolutely sure response speed and location sensing greatly improved by this recalibrating method. FWIW, my bad sensitivity problem did not get worse after adding a screen protector (same problems happened before screen protector as after the screen protector), and, the new calibration includes the screen protector - location and sensitivity is now better than ever.

    I wonder if every new A1 should have this calibration...?
  9. carlsnilsson

    carlsnilsson New Member

  10. carlsnilsson

    carlsnilsson New Member

    That's helpful, dbguru and mmmmna. I had the same problem with my Lenovo A820. Screen froze and I could not unlock it, except if I had power (USB) plugged in. Then it worked perfectly. Investigated battery - it was just fine. Still had problem even if battery 100% @ 4.0V. Last night discovered problem went away if phone was out of case and in my hand. Investigated plastic case closely for an hour. Nothing wrong with it. Problem came back if I laid phone on insulated tabletop. Light dawned. It is a capacitance problem, I believe. Phone needs some capacitance to hand or ground connection in order for screen to function. Maybe recalib as above might help, but I need to enlist a chinese reader first! What position is recalib option re top or bottom of list on A820? I don't want to reflash! My fliptop case had sturdy plastic back which reduces capacitance to hand too much, I believe. Before doing anything drastic, I suggest just taking phone out of case and holding it in palm of hand - see if screen works just like mine did.

Share This Page