How I unbricked two phones.


  1. So this was my problem:
    "So last night my wife deleted "LG Home" from her phone when I wasn't looking (she didn't know what it was) and while I was looking at it I decided to see where mine was stored on my phone but when I opened Root Explorer (app name) it froze at "getting root permissions". I backed out and forced it to quit and tried again with the same result. So I restarted my phone only to have it show LG splash, T-mobile sequence, and then an Android with a box and a status bar. The status bar stopped after a couple seconds and the phone reboots only to do it again."

    This is how I fixed it:
    You will need Windows to do this so if you're like me and use Linux you will need to run Windows in a virtual box. I suggest VMware Player found at VMware Player: Run Windows 7, Chrome OS - Free Download for a Virtual PC
    After you download and install it you will need to install Windows on it (I don't need to know where your Windows came from ;)).

    Now that you're on Windows you need LG updater. I suggest http://forum.xda-developers.com/atta...5&d=1287222698
    because other downloads I found did nothing but crash.

    This is a .7z file so you need to install 7zip found here Download

    Install 7zip and unzip the KDZ_FW_UPD_EN.7z file. Go into the folder and install the updater.

    Then you will need to download LG official firmware android version v2.2.2 build v10 found here http://csmg.lgmobile.com:9002/swdata...00/V10E_00.kdz

    Plug your phone into the computer and it should ask to install drivers. Let it do this. If it doesn't ask or it can't find them you can find them here Cell Phone Support - Mobile Phone Customer Service & Cell Phone Information - LG Electronics US (NOTICE: Don't be dumb like me and forget to do this. If you are running Windows on a virtual box you will need to disconnect from your host OS and connect on Windows. Only one system can access the device at a time. You can do this through the VMware tools tab in the window after you start Windows.)

    Open the LG updater and leave all the setting alone except select the V10E_00.kdz file and click the start button.

    Not long after your phone should switch into emergency mode and approx. 5min later the phone will restart and should be back to factory settings. (I didn't loose all my stuff and settings just some of them and apps I had downloaded)

    This works in any screen I believe because my wife had a blank black screen with the "task bar" at the top and my phone was off with the charging battery animation on the screen.

    I suggest having the SD card out of the phone as I have read this process can sometimes wipe it.

    I owe some credit to Yeahha for helping to point me in the right direction.

    I really hope this helps someone. Post your success here or message me.
    Good luck and never give up, remember there is always a way.

    Advertisement
    :
    stepthrough, jnh4ever and TnIan like this.
  2. kolosus

    kolosus Well-Known Member

    I tried this method. This method is outlined in other threads too but this thread has good links.

    Unfortunately it didn't work for me. My phone is an Optimus T. I think I flashed the wrong recovery to it.

    Phone will not boot. Shows the LG logo for a few seconds before turning completely off. Sometimes it'll show the LG logo and go no further. I can get into Emergency Mode.

    The program does something for a few minutes and then exits with the line "PHONE NOT FOUND". I've tried from emergency mode and from the stalled LG splash screen.

    If someone has some pointers or an alternate method to try I'm all ears. I need my Optimus T back on!
  3. I had something similar to this happen while I was doing my phone the first time I tried. It turned out that Windows had not installed the drivers for my device. You need these drivers for the program to "see" the device.
  4. metrony

    metrony New Member

    i will try this in am, i hope it works, i have spent in and out of all day today trying to find info to fix it, and some of the stuff i had no idea on what they meant .
    after i saw a post that said when rooting / freezing leave LG HOME alone, i realized that was the problem, it was the last thing i did before putting it down and going to sleep.
    i froze the files, it wasnt titanium, it was AntTek App Manager ,,i froze LG HOME . i used gingerbreak to root it, had super user installed and it worked, the root you used, Z4, it is on the phone still or sd caard would not work, this try it gave a message before root saying the cpu was different and probably wouldn't work sio i didnt even try this time , since it failed about 3 times before .
    busy box is on there , stand alone, a couple more too, i have to look at the other android place i dl from to see. I had a very hard time rooting.
    did your wife remove or freeze, just hoping there is some way of unfreezing via usb and maybe it would work, i also froze t mobile mall. i think the rest were safe, pacman etc, but i could be wrong i was last night
    i just saw my profile phone is wrong
    LG- p509
    android 2.2
    kernal version 2.6.32.9android buildserve#1 sun uct 219:10:09kst
    build FRF 91
    i had the upgrade that ended in l not sure if it was a 1 or a L , it sucked, the previous was better, so i am going to need a new rom too , hope 2.3 is possible
    .
  5. TnIan

    TnIan Well-Known Member

    cybernetictoas - You Are Awesome. Thanks so much for posting this.
  6. TnIan

    TnIan Well-Known Member

    Some follow-up notes: The ROM linked above (V10E_00.kdz) worked fine, but it's a build for the India market, and was missing some things specific to T-Mobile like the wifi calling app and Telenav GPS. Also, my phone identified itself as a 500 (Optimus One) rather than a 509 (Optimus T).

    I flashed this ROM:

    http://csmg.lgmobile.com:9002/swdata/WEBSW/LGP509TN/ATMOTN/V10s_00/V10S_00.kdz

    ...and it's the stock T-Mobile ROM, identical to the one I borked earlier (except it's Android 2.2.2 rather than 2.2, which I originally had).

    In both cases, the phone went into the Android-logo-screen boot loop after flashing. After a couple battery-pull-reboots (including that trick where you pull the battery and hold down the power button for 30 seconds), it booted fine.

    Thanks again to everyone on androidforums who've helped me with this kind of stuff. Awesome community.
    mecampo likes this.
  7. kolosus

    kolosus Well-Known Member

    I finally got my LG back from my buddy and windows crashed! I reinstalled windows and tried this procedure again with the correct drivers. Device Manager shows that the phone is recognized etc... Unfortunately the process didn't work. PHONE NOT FOUND is still how the program exits.

    I'm all ears as to suggestions.
  8. MarkaRagnos

    MarkaRagnos New Member

    I registered here to reply to this, because it was incredibly helpful, and also because this is the second time I have bricked my LG Optimus T, and had to do the same steps twice that I figured out and that weren't listed anywhere.
    My phone was stuck in emergency mode (which I've always found to be hilarious and distressing, because it says "EMERGENCY MODE!!" complete with exclamation points), and when I'd connect it to the computer it wouldn't show up.
    Here's what i did.

    1. Take out the battery to force it to shut down
    2. Leave the battery out, and hold volume UP and the home button (the button combination for a hard factory reset is home and volume down, I believe, but if you do the opposite it works, and doing the thing you're supposed to doesn't)
    3. While continuing to hold the buttons, plug your phone into the computer (this may take some dexterity, having to do so many things at once).
    4. Voila, nothing may happen, but now you can run the updater and everything should work FINE.

    Oh god I was scared all over again, and couldn't find my backup of the stock ROM, thank you for linking to that that was the best thing ever.

    tl;dr: if you're stuck on emergency mode, take out the battery, hold volume up and home, and plug it in.
  9. ailurophile

    ailurophile New Member

    I also deleted LG Home, thinking it was just a link to a website, and my phone bricked. I've tried using the KDZ_FW_UPD_EN as described here and on other forums, but the program wants a .kdz file, and there isn't one within KDZ_FW_UPD_EN. Strange, since that seems to be where the .kdz file would be . . .
  10. mecampo

    mecampo Well-Known Member


    This two posts fixed my tmobile lg optimus that is stuck on lg screen, have to use the kdz on 2nd post for it to work 1st one got me in a loop.

    thanks guys ;)
  11. mecampo

    mecampo Well-Known Member

    just found out the incoming call always goes to the voicemail and the home key does not work after this fix :(. i may need to get a new or correct kdz for a P509M (burgundy lg optimus from tmobile)

    edit: hard reset (home + volume down + power) fixed it, phone's back to normal ... wheeeeew
Loading...

Share This Page