how long did it take you to root?


How long did it take you to root?

  1. 5-10 minutes

    23 vote(s)
    44.2%
  2. 20-30 minutes

    12 vote(s)
    23.1%
  3. 40-50 minutes

    4 vote(s)
    7.7%
  4. about an hour

    2 vote(s)
    3.8%
  5. hour and a half

    1 vote(s)
    1.9%
  6. 2 hours

    1 vote(s)
    1.9%
  7. 3 hours

    1 vote(s)
    1.9%
  8. Over 3 hours

    8 vote(s)
    15.4%

Last Updated:

  1. jrappy87

    jrappy87 Well-Known Member

    took me about 4 hours.

    Advertisement
    D13 likes this.
  2. D13

    D13 Well-Known Member

    lol:D
    No offence to you just made me laugh
    I think it took my from 10 am to 10 pm to root my droid 1
    So maybe you should have a 10 hrs plus
  3. jrappy87

    jrappy87 Well-Known Member

    it took me about 15 mins to root my droid 1. the directions to root the droid x weren't very clear. :-(. i had to put it in charge only mode instead of usb mass storage mode to load superuser.apk otherwise i got permission denied.
  4. D13

    D13 Well-Known Member

    Yeah I was clueless with the d1 I made every little step a big deal:)
  5. krichek

    krichek Well-Known Member

    Took me 20-30 as I didn't have the sdk installed or anything, then I was stupid and chose to install and update all lol!
  6. tumadre159

    tumadre159 Member

    I had a hell of a time trying to get adb.exe to work. Then I had to get the phone drivers figured out but in the end I finally got it. I haven't done anything with it yet but its there for when I make decision to.
  7. Candroid

    Candroid Well-Known Member

    I had a hard time pushing the command prompts and such. once I got the ADB up and running it was smooooooth sailing from there!!! I am SOOOOOOOOO Happy with ROOT! But when Froyo comes out...this Process all over again... :(. But agian as it always is, it will be worth it!!! Thanks Devs for all the unknown crazy work code program'n crap you guys do!!! almost as important as our military!!!! ;)
  8. jroc

    jroc Well-Known Member

    5-10 minutes.

    I already have my PC setup for adb from using it on my Droid. It was a matter of copy n pasting lines into the command prompt. I'm lazy....lol

    And I also missed my phone asking for super user request the first time. I was like WTH did I do...then I looked at my phone...lol
  9. 1stAndroid

    1stAndroid Well-Known Member


    first time rooter here. Is there an actual adb.exe or program I needed to have installed before even starting? I downloaded both zips, the ADB Driver zip, and the root zip already, and I've installed the ADB zip, but didnt know there was also an .exe program.

    thanks
  10. colchiro

    colchiro Well-Known Member

    I was watching the blurry video and trying to type them in until I noted the text, then just copy'n paste.
  11. droidSPARX

    droidSPARX Well-Known Member

    40-50
    adp problem and uninstalling Motorola drive on the USB section of devices which made me re-download the drivers with computer restart
  12. chrlswltrs

    chrlswltrs Well-Known Member

    First time took about 5 hours because I just couldn't get the drivers right and adb working. ->

    ****ed up my phone and got a new one ->

    Second time about 10 min
  13. Fabolous

    Fabolous Superuser VIP Member

    Heh, where's the 0-5 minutes option :D

    To be fair, I have a lot of experience from the original Droid and my ADB environment was already set up.
  14. Piiman

    Piiman Well-Known Member

    Once I got the Moto drivers installed about 5 minutes.
  15. HalfFrozen

    HalfFrozen Well-Known Member

    When I found vaio's Post.. all of about 3-5 mins... but Scrambling around looking at those ******ed difficult threads, I would say a good 2-3 hours.
  16. jr0065

    jr0065 Well-Known Member

    I would 4-5 hrs & most of that time was trying to get the right USB drivers to work. Once I got the CPU to recognize my phone correctly (BTW all I needed to do was download the driver from mototolla website apparently) it took me like 10 minutes.. and it was that long cause I was waiting for it to ask me for my password, didn't realize I had to hit the next line of code to be ask for the password.

    In reality once you have your phone hooked up properly to your CPU it takes like 5 minutes.

    This is my 1st Android phone though and obviously 1st time rooting one. I didn't even realize I had to use the DOS prompt until I saw a video.
  17. Stone

    Stone Well-Known Member

    +1

    It took me less than 2 minutes, but I had already set up ADB so I could do screencaps. I'm an old Linux guy so this was a simple process IMO.
  18. tumadre159

    tumadre159 Member

    The adb.exe file that I used came in the tools folder with the Android sdk I downloaded.
  19. Azaka

    Azaka Member

    That's what I did. Took about 2 minutes to root the phone, already had the drivers and sdk installed so all I had to do was copy/paste the commands. I've never rooted a phone before.
  20. jrappy87

    jrappy87 Well-Known Member

    i wish i had it that easy azaka. i rooted my original droid and it didn't take nearly as long as my droid x. first, when i typed "adb devices" no devices were found. so i had to uninstall/reinstall a bunch of different drivers. then when i finally got it to show my device, i kept getting permission denied when i tried to load superuser.apk to the sd card. the problem was i had it in usb mass storage mode, for it to work, i had to have it in charge only mode....then i finally finished rooting.
  21. jr0065

    jr0065 Well-Known Member

    Did everyone get an "allow prompt" on their phone? I didn't.
  22. Android_LIFE

    Android_LIFE Well-Known Member

    Had my DROID X rooted in literally no time using the terminal method.
    No cables, No Computer.
    A breeze;)
  23. 91STT

    91STT Member

    about 10 minutes, the process was pretty straight forward.
  24. rjoudrey

    rjoudrey Well-Known Member

    82 seconds! Only kidding not rooted.
  25. Sheba611

    Sheba611 Well-Known Member

    Yes I did when I did the "Confirm root" steps. The first couple of times I ran those steps, I got the "Permission Denied" error. Than I read somewhere you have to make sure the phone is unlocked and you are looking at the phone when the "allow prompt" pops up.

    It took me a long time to root. The Droid X is my first Android phone so I never rooted a phone before. I was also not familiar with how Android OS worked so there was a lot of stuff I did not know. I had problems with the usb drivers because the terminal window could not find my Droid X. I had to delete the usb drivers that were installed and go to the Motorola website and download the 64 bit usb drivers (I am running Windows 7 64 bit). I looked for help on 3 forums to find info when I ran into problems. After all that, I was finally able to root my Droid X. Hopefully next time it won't take nearly as long.:)

Share This Page