How to add / remove words from Swype in Samsung Galaxy S II


  1. Chuqui

    Chuqui New Member

    Hi everyone,

    I have a Samsung Galaxy S2 with Android 2.2.3 and Swype 2.29.71.20642

    I love using Swype, but it doesn't let me add or remove words from the dictionary. I've read many people have the same issue, but I can't find a solution. I tried to uninstall the application but it's not possible.

    Is there a way I can update it? How to add / remove words from the dictionary if the traditional way doesn't work?

    I appreciate any hints.

    Advertisement
    :
  2. chanchan05

    chanchan05 The Doctor Guide

    To add words, just type it normally. The moment you hit space after typing, its in the dictionary. I actually added almost an entire language to swype since my language isnt available. To remove words, highlight the incorrect word you typed, then press the swype button on the lower leftmost corner.
  3. ninja_reject

    ninja_reject Well-Known Member

    Unfortunately, that is one of Swype's limitations. You can add words, delete words you added, but you can't delete words in the original Swype dictionary. And it has some pretty stupid words that you will likely never use, which like to pop up when you are trying to swype a normal word. But luckily for you, you have an Android! There are plenty of keyboard replacements available to you on the market. Most of the good ones cost a couple bucks, but a lot have trial versions so you could give it a test run. I use SwiftKey myself, but it doesn't have the swipe feature. Many people swear by SlideIT or Flex T9 as good Swype alternatives.
  4. Chuqui

    Chuqui New Member

    Thanks, but that is what is not working at all. I go ahead and type (not swype) a new word, character by character, then hit space, but the word is not added. Same for removing.

    @ninja_reject Thanks, but I've already tried another keyboards and I just prefer Swype. Is there a way I can update it to it's newest version?

    Thanks again!
  5. chanchan05

    chanchan05 The Doctor Guide

    That's pretty odd. However I must also point out that I have unchecked all languages. Try it.
  6. Chuqui

    Chuqui New Member

    Very good point! Maybe Swype doesn't know where to add every word. Now... how does it recognize your language if you uncheck all of them?
  7. chanchan05

    chanchan05 The Doctor Guide

    It defaults to English for some reason. Besides, my country's language isnt part of the available ones, so basically I taught skype almost my entire language. :)
  8. radbrad85

    radbrad85 Member

    I was wondering about this last night, thanks for the information guys!
  9. tcat007

    tcat007 Well-Known Member

    ??? In my Swype settings, I can add or delete any word in the personal dictionary. I usually get a pop up asking if I want a new word added while typing. I'm on 3.26, but I think it acted the same before I updated.
  10. Tre Lawrence

    Tre Lawrence Well-Known Member

    I might be wrong (and someone please correct me if I am), but isn't built-in Swype different from the beta with regards to dictionary actions? OP, which do you have?
  11. davidtheprof

    davidtheprof Active Member

    I wish I got a pop up before it adds new words!
    over time, it more frequently slows me down with an idiotic screen saying that the word I want is covered by another word, or something similar, I always hit cancel...
    when this gets bad, I just delete the data, effectively starting again with the default dictionary and none of the garbage words.
  12. chanchan05

    chanchan05 The Doctor Guide

    The new version now doesnt add words automatically. On v3.25 or later, whenever you type a new word that's not in the dictionary, a popup comes asking if you want to add it.
  13. Dieselbud

    Dieselbud Well-Known Member

    THIS is more annoying than any other thing about swype. I do not understand why it is compelled to do this almost once in every message I text.

    PS: how do I delete all data and start over? And how can I actually text the number 3 without it being changed to 39ers every. single. time.

    oops, that is a 4 being changed to 49ers LOL
  14. chanchan05

    chanchan05 The Doctor Guide

    Clear the swype dictionary would be starting over. The option is somewhere in the swype settings. What you can do as well is turn off autosuggest/autocorrect.
Loading...

Share This Page