How to change build.prop from computer (not from phone using root explorer)


  1. from3iichaos

    from3iichaos Member

    I was trying to change my phone model (from admire to nexus s) in the build.prop a week or so ago in order to try to run the "watch espn" app (which did not work). I forgot to change it back after it didn't work and this morning I rebooted my phone and now I am stuck at the start up animation. When I turn my phone sideways (landscape) I can see that my phone is trying to work as a nexus s (which it is not). Therefore, I somehow need to get back into the build.prop to make the simple change back to admire, just not using the phone since it is stuck on the startup animation. Also, I am 99% sure that I backed up everything using cwm recovery v5.0.2.7 as well as titanium backup but all backups seem to be missing or I just can't find them. I'm also pretty sure that I have the old build.prop backed up on my sd card if that helps. Any help on how to fix this is greatly appreciated!

    Samsung Admire-Rooted
    Monster 4 Rom

    If you need anymore info just let me know. THANK YOU IN ADVANCE!!!!

    Advertisement
  2. from3iichaos

    from3iichaos Member

    I guess it's impossible....
  3. Rusty

    Rusty Well-Known Member

    Pretty easy, boot it up as best you can, adb pull /system/build.prop

    Edit it (using a suitable editor if in Windows, like Notepad ++)

    Then mount system as r/w, push the modified file back in place, chmod it to 644 and reboot.
  4. ^that but i bet ops ass doesnt know what adb is.
  5. from3iichaos

    from3iichaos Member

    How exactly do I do an adb pull? I tried to research it before I asked but I didn't find much help.
  6. from3iichaos

    from3iichaos Member

    Nevermind the previous post. My new problem is that in cmd my device is not found when I type in "adb devices". Do you guys have any tips for this? I installed to drivers for the admire numerous times and I am certain that phone is properly connected via usb to my computer since the phone shows that it is charging. Thank you for the help!
  7. Rusty

    Rusty Well-Known Member

    Try adb from recovery instead, it might not be booting enough for it to initialise.
  8. from3iichaos

    from3iichaos Member

    I fixed it!!! A big thank you to everyone who helped!
  9. wunna

    wunna New Member

    I have problem too! I want to edit build prop
    i can open it but i can not save it it's read only
    how to i can overwrite it ? Please
  10. viperdink

    viperdink Well-Known Member

    if rooted. D/L absolute system tool off of playstore. its free and does all the backing up for you.

    viperdink
  11. If your using root explorer (at the top it should have a toggle switch,from r/w to r/o) change it to r/o then edit it and save
    Hope this helped
  12. Spz0

    Spz0 Well-Known Member

    Erm, how about changing it to rw so he can actually save the doc? ;)
    gaazakid876 likes this.
  13. Lol on my phone i changed it r/o so i can edit it and save it....
    But try each one and see which on works
  14. Forget I said a thing
  15. Spz0

    Spz0 Well-Known Member

    Ro=read only
    Rw=read write

    You're reading it wrong. Look at the text in root explorer- when it's mounted rw , the button says "mount ro" (which means switch to ro) but the text states "mounted as r/w" ;)
    gaazakid876 likes this.
  16. Oh sorry i read that wrong thanks bro :)
  17. bill_starr

    bill_starr New Member

    I'm new to doing things with a rooted phone and am not sure the best place to post this, but it seems related to this thread.

    Sunday this week (12 Aug 2012), I successfully rooted my phone using Steps 1 to 9 of the following page.

    [HOW TO] Fix the "Low on space" problem (in plain English) - xda-developers

    I have Droid Incredible with Gingerbread 2.3.4 and it keeps trying to push me the "4.08.605.15" OTA update I don't want to install. Rather than hitting the "Later" button every time it pops up a reminder, I wanted to get it to stop reminding me.

    So with Root Explorer, I mounted "/system" to R/W and opened "build.prop" with the text editor function of Root Explorer and changed the "ro.build.fingerprint" entry from "185897.2" to "264040" as described here.

    How to disable Verizon's OTA updates - xda-developers

    When I selected Save and Exit from the text editor menu, "build.prop" seems to have disappeared from "/system" and there is a zero-length "backup" copy named "build.prop.bak" created by the editor.

    So far, the phone seems to be working okay, but I am afraid to restart it now.

    I have a copy of the pre-edit "build.prop" saved on my SD card and have it copied to my laptop as well.

    Trying to copy it back to "/system" via Root Explorer does not seem to work. I don't get any error, but the file does not appear either.

    Anyone have a suggestion for the simplest way to get "droid.prop" restored to the "/system" folder?

    Or maybe it's really there and I just can't see it.

    Is there anything that will get me into trouble with a missing "build.prop" file other than restarting the phone?

    Thanks, Bill
    Wed, 15 Aug 2012, 4:35 pm EDT
  18. qandres12

    qandres12 Well-Known Member

    wrong forum guy
  19. bill_starr

    bill_starr New Member

    Just after posting, I remembered that I had done a Nandroid backup with CWM two days ago, so I did a restore and got my original "build.prop" back in the "/system" folder that way, at the minor expense of losing a couple of days of call and text history and needing to reinstall a couple of apps.

    I guess pressing "Install Later" every once in awhile isn't so bad after all.

    I'll do more research before trying to edit "build.prop" again.

    Thanks, Bill
    Wed, 15 Aug 2012, 5:09 pm EDT
  20. enigmadroid

    enigmadroid Well-Known Member

    Check out FOTAkill Bill :)
  21. angad420

    angad420 New Member

    sir i am using micromax funbook talk p350:confused: tablet ics tablet 4.0.3 ,and want to work some game loft games on it.and for this i have to change my model number from micromax funbook talk p350 .to samsung gt-i9100 or any other ,but sir i want to tell you that by using es file explorer i succesfully change my ,buil.prop and model number to 2nd.but in settings it remains as first as micromax funbook p350,and in build.prop file its says that device model is samsung gt-i9100,and after changing the build.prop file and when for changes to be done i restart my tab ,and one more file in system folder (build.prop.bak ) pop up on automatticaly in system folder,,,,,, sir plz help ,me how i let the changes and change my device model number in build.prop,succesfully .and after mc3 works.please
    please please
    thanks in advance
  22. angad420

    angad420 New Member

    help me
  23. twogbsd

    twogbsd Well-Known Member

    Wrong place....

Share This Page