How to change from ICS to Gingerbread


Last Updated: 2012-08-09 22:01:11
  1. anksoni

    anksoni Member

    Hi

    I am new to this. And I apologize if I am posting on wrong place.

    I have htc desire and have recently rooted it and updated with Ice Cream Sandwich latest version 0.16. And I found it CRAP. Always my phone gets hung up and need to restart it every time by removing battery. Neither Play store nor any other app can work properly. So finally I have decided to go back to gingerbread which was far more better then this one. So would like to request you if some brilliant minded people can help me.

    Thank you for considering.

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Hi anksoni, and welcome to AF.

    You do exactly what you did to install the ICS ROM in the first place. Choose a Gingerbread ROM (after reading its requirements), download it to your SD card, back up any data that need backing up, boot into recovery, wipe, install the Gingerbread ROM. That's it.
  3. anksoni

    anksoni Member

    I did the same way as explained. But in recovery mode my phone is "NOT" showing me gingerbread file. So can you please tell me which file shall I use. I am currently using

    HTC_Desire_Android_2.3_Upgrade

    So if you can paste any link that i can use that will be really helpful.

    Thanks in advance.
  4. Hadron

    Hadron Well-Known Member Contributor

    If that's the file from shipped-ROMs, it's an RUU (just inside a zip file). To use that you unzip it on a Windows PC, connect the phone via usb (phone in fastboot mode), and run the .exe from inside the zip on the PC. That will unroot the phone, remove your custom recovery and return it to stock gingerbread.

    If you look in the All Things Root Guide sticky post you will find a link to a list of Desire ROMs at xda-developers. Most of these are Gingerbread. They range from a rooted stock Gingerbread (just like what's in that RUU, but rooted and won't remove your recovery) to ports from newer HTC devices (which need an extra partition on the SD card to run) to various non-Sense Gingerbread ROMs. There's a sticky post "what rom type are you using?" which will give you different people's impressions of different ROMs. What I had meant was to choose one of these ROMs and flash it, rather than unrooting using that package.
  5. anksoni

    anksoni Member

    Hi
    I tried to install again and it is like

    Finding update package....
    Opening update package....
    Installing update....
    Installation aborted.


    Now what can be reason for this installation abortion.
  6. Hadron

    Hadron Well-Known Member Contributor

    Because that package isn't a flashable zip. You cannot install it from recovery.

    If you do want to run it, see the first paragraph of my previous post. But note that if you do that it will unroot you and remove your custom recovery (if you rooted using Revolutionary you will still be S-Off, but everything else is undone).

    Otherwise, select a different custom ROM from the list you'll find linked from the sticky post. These can be installed from recovery. This ROM is virtually identical to the stock gingerbread you are trying to install, except that it is rooted, won't remove your recovery and supports a few more options. The download links at the start of that thread are broken, but post 445 (near the end of the thread) has mirror links you can download it from.
  7. anksoni

    anksoni Member

    Hi
    I did as you mentioned and I donwloaded MokeesOS_RMGv0.6RC2-signed.zip.

    And I run it from Recovery menu and after installation there comes only one screen that

    a picture with 4 colour box and says like "HEY! I'M MOKEE OS!"

    So shall I go again in Recovery mode or what shall I do?
  8. Hadron

    Hadron Well-Known Member Contributor

    Have you partitioned your SD card (see the "root memory faq", in the All Things Root Guide sticky post)? The requirements for that ROM, in the first post of the XDA thread, state that it needs an ext4 partition on the card.

    If you have, did you do a wipe before flashing?
  9. anksoni

    anksoni Member

    I have partitioned the sd card and then installed it doing wipe all.
    but now there is a new problem is phone is getting started all working very fine but network is not there.

    After booting up the phone first 30 seconds network is there but after that no network coverage.

    M sorry harrassing you since morning but please help me out solve this problem
    Thank you

    I would like to add up that I am currently using T Mobile. I have tried to use other network simcard O2 and it worked fine. So what are we ending up with?
  10. Hadron

    Hadron Well-Known Member Contributor

    OK, that is very odd. Is it no network coverage at all, or just no data connection?

    If it's just data that might be a problem with the APN settings.

    If it's no network coverage at all that's very strange. The only time I've had network for a minute or so and then nothing was when I was mucking about and flashed a RIL that was incompatible with the ROM, but you will not have done that (the RIL is part of the ROM by the way), and I wouldn't have thought that type of thing would depend on the network.

    Have you tried turning 3G on/off, to see whether it's a general problem or 3G only? I really am just guessing/trying to work out the nature of the problem here.
  11. anksoni

    anksoni Member

    I have tried all of them
    can you please tell me any other rom
    which can support plz....

Share This Page