How to clear browsing history?


  1. plnelson

    plnelson Well-Known Member

    The dropdown in the browser navigation bar shows every site that I've been to . How do I clear it?
    I
    Menu>more>History>Clear History says my history is cleared but when I go back to my browser and tap the navigation field it's all still there - every site I've visited for days! Ditto if I go to Menu>More>Settings and clear the forms, history, cache, and cookies.

    So how do I clear the browser navigation history? Thanks in advance! (Droid Incredible 2.2)

    Advertisement
  2. jbdan

    jbdan Well-Known Member

    Few ways to do this. I prefer the easy route and use the app "History Eraser" in market.
  3. mike1

    mike1 Well-Known Member

    Menu more settingsclear history
  4. plnelson

    plnelson Well-Known Member

    If you look at the OP again you'll see that I tried that.

    I did that; along with clearing the cache, cookies and form data. After doing it it, if I do Menu>more>history, it says says "Browser history is empty"; then when I go back to the browser and tap the navigation form, ALL the history is still there!

    Maybe it means something different by "browser history"?

    After doing the above, if I open the browser again but don't go to ANY website, if I do a menu>more>History it STILL says "Browser history is empty". But if I browse to site "A" and do menu>more>History it only shows the URL for site "A".

    But if I tap the navigation bar the URL for site "A" simply becomes the top or most recent one in the list. So clearly there are two different histories!

    BTW, this is all with the default browser.
  5. mike1

    mike1 Well-Known Member

    Ok I said you go to menu more settings then clear history NOT menu more history
  6. plnelson

    plnelson Well-Known Member

    And if you look at the OP you'll see that I did that as well. (the OP describes BOTH METHODS - neither work.)
  7. plnelson

    plnelson Well-Known Member

    I called Verizon - they had no clue so they switched me to HTC. The HTC tech was very helpful and tried different methods on the Incredible and on a different HTC phone too, and NADA, nothing, zilch! He couldn't find ANY way of clearing the browsing history.

    So what is "clear history" supposed to do? The tech thought it was search history not browsing history.


    (my wife has an iPhone and this illustrates why iPhone will rule once they get off of ATT (Verizon gets the iPhone in January). Android is too fragmented - too many cooks spoil the soup. On a problem like this there is no one to "own" the solution. Google itself doesn't have tech support but this isn't really a Verizon or HTC problem.)
  8. plnelson

    plnelson Well-Known Member

    I tried History Eraser but it didn't work. It was sheer optimism to try it -- there are lots of comments on Market saying it no longer works on 2.2.

    So does anyone have any ideas on this?
  9. mrootes

    mrootes Well-Known Member

    OK, I have the same issue. Oddly, it deleted about 80% of the sitres in the navigation window. a few still are there. I will keep playing with this to see if I get anything helpful to share.
  10. fatpomp

    fatpomp Well-Known Member

    The only way Ive been able to clear everything is to go into Menu>More>Settings and clear the forms, history, cache, and cookies. Then back out to of the browser to your home screen and reset your phone. After it boots back up when you go to the browser and click on the browser navigation bar everything should be cleared. The only thing that will show now is what ever bookmarks you have saved.
  11. mrootes

    mrootes Well-Known Member

    Sorry, but the process you tried did indeed delete my entire browsing history in the navigation window. The ones that remained without going away stayed becasue they were bookmarks I had set - those will always remain.

    Have you removed the app from the screen and then put a new internet app back on? Otherwise, there must be an issue on your phone that is not deleting the history from the nav drop down window.

    Maybe go to your browswer settings and select ""reset to default".

    (by the way, this is different than "web search history" in google, for example.) they have their own history in their drop down window that must be done through their webpage. I have done that as well.
  12. plnelson

    plnelson Well-Known Member

    No, I never tried that. Why would anyone do that?

    I think the issue with my phone is that it's running Android. You didn't say what phone/OS version/browser version/rooted/unrooted you used but it turns out the problem I described is related a known bug in Android. Android does not erase the browser history when you ask it to.

    Issue 2622 - android - Browser behaviour with clearing history and back button changed - Project Hosting on Google Code

    ... what I thought was interesting was Andy Minkewicz in the forum asking, "So....What's the point of clearing the history?"


    BTW, I tried History Eraser, and it didn't work, either, but that's no surprise - there are lots of comments on the Market saying it doesn't work anymore as of 2.2.
  13. mrootes

    mrootes Well-Known Member

    I have the Droid incredible, unrooted, Froyo 2.2, stock browser. And as I said, the clear history works fine on mine. Since no one else on this thread identifies with your issue I find it hard to believe it's a bug. Nonetheless, your porn sites will have to remain on your nav drop down until you find a fix.

    Time to close this thread as it's only your issue.
  14. EI2468

    EI2468 New Member

    OMG!! I FINALLY FOUND A WAY!!!
    Ok, so i was trying to clear my history for a long time but it doesn't really "clear" it.
    So what i did to REALLY clear it was that i downloaded an app called "History Eraser" from the market, just like what @jbdan said, and then just run it. Once you run it, you should turn off ur phone and the turn it back on. This method worked perfectly for me :) .

    I hope I resolved your issues.
  15. Drewbkilla

    Drewbkilla New Member

    All, Most of you are right and aren't even aware of it.
    Click the clear browser history button and restart your phone,

    (It seems to keep your Urls in Cache) After a reboot, you should be good.
  16. kingsway8605

    kingsway8605 New Member

    Add the google search widget to your homescreen. Click the search widget, click the menu key (on the phone, you know, the back, home, menu, and a search key). Clear the search history.
  17. golfbiz

    golfbiz Well-Known Member

    that worked on my phone no problem, other than keeping my bookmarks which stayed. Don't really need to erase my browsing history but curious if this works as it does....also don't really want an iPhone as the poster states how it is more seemless although Apple reported revenues of 24 billion this quarter, almost double last year, amazing company...
  18. Shoop2

    Shoop2 New Member

    Actually no, I have the same issue with my HTC smart. Clearing history does not clear the "history" when entering a website in the address bar. It is a severe oversight and I am seriously considering an iPhone because of it.
  19. cephalopod23

    cephalopod23 New Member

    I just found this thread because I've been having the same problem with my thunderbolt. I would also erase my history, cache, and cookies under settings but still have the old sites show up in the drop down bar of my Google app and on on the search bar in Google. Also when I hit the back button on my phone it would take me right back to the sites I thought I had erased. I discovered two fixes. First while i am in the first part of the google app I hit menu and then search settings. There is an option to erase browsing shortcuts. Then when in Google on the web, I tapped the search bar and there is an option there to clear the history. This solved it for me, so I hope this can help some others.
  20. cephalopod23

    cephalopod23 New Member

    Sorry, a correction. When in the google app you hit menu, then search settings, then clear shortcuts
    Sharondippity likes this.
  21. ecgberht

    ecgberht New Member

    I have the same problem on my HTC phone, but not with google , but with the Internet app. Nothing in this tread enables me to clear the history. Anyone have any more ideas?
  22. pixelpusher220

    pixelpusher220 New Member

    I believe the correct answer here is that deleting the browser history is working BUT the stock internet app is by default loading any sites you have bookmarked into the address bar.

    Anyone know a way to prevent the stock internet app from loading bookmarks into the address bar when you click it to type a 'new' address? I don't want my bookmarks coming up...that's why they are saved in bookmarks and not browsing history!

    htc evo 4g unrooted
  23. Jimmy10341

    Jimmy10341 New Member

    I just cleared the instant drop down list from the 2.3 display google bar by selecting "clear the short cuts" from a menu. Not sure how I did it though, it was only a few steps from the home screen.
  24. partygearz

    partygearz New Member

    1. Know your Four Buttons: Home, Menu, Back, and Search for droid incredible 2 (Search button is the magnifying glass). Menu button has lines (droid) or square in square (other phones).
    2. Clearing the Google Search Toolbar app/widget
      1. Select the Google Search Toolbar, the Google 'g' search toolbar comes up ready for input.
      2. Press the Menu (lines or square in square) button while you are in the app.
      3. Press the Search Settings button that pops up
      4. Under 'Phone' header, select "Clear shortcuts", popup should say "This will clear all shortcuts to recently chosen search suggestions", select OK.
      5. Previous search items should be cleared
    3. Clearing the stock search browser app (not Google Search bar)
      1. Select the stock search browser app
      2. Press the Menu (lines or square in square) button immediately, do not press the URL display area.
      3. Select More->Settings->(scroll down into Privacy Settings)Clear History
      4. (you can also select Clear Cache and Clear cookies, but I probably wouldn't)
    4. Last method: Clearing from Main display (Other users have said this)
      1. Go to your main default view
      2. Press the Menu button
      3. Select Settings
      4. Select Applications
      5. Select Manage Applications
      6. Select Running
      7. Select Browser (clear data) or Select Google Search (clear data)
    Hope this helps --partygearz. com
    Good luck.
  25. Kirk0001

    Kirk0001 New Member

    Go to the dropdown, and then go Menu> Search Settings> Clear Shortcuts. I don't know if this totally erases the search history, but it makes it pretty hard to find. I did this on my Samsung Galaxy Mini (Froyo(2.2.1)) If you find any problems with this, include it as another reply.

Share This Page