1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

how to clear internet history for HTC desire?


  1. pini

    pini Member

    Hi, I desperately need to clear my internet history. On my new HTC all previous addresses come up when typing in an address and there are two in particular I need to delete.

    please reply asap. Thanx.

    Advertisement
  2. kboya

    kboya Well-Known Member

    Have u tried opening the browser menu, settings, scroll down, clear internet history ?
    pini likes this.
  3. HYCAET

    HYCAET Guest

    Hit the menu softkey while in the browser then more>settings>delete history/or delete cookies/or delete cashe
    pini likes this.
  4. !Afrokid!

    !Afrokid! Member

    On top of clearing the browser settings in the browser itself, you can download a free app called "History Eraser" which can erase internet browser history as well as android market history, call logs, google map searches and frequently called in contacts. You probably save yourself 4 button presses or menu nagivation screens there.

    Works a treat.
    oiler and oldnick like this.
  5. oldnick

    oldnick Well-Known Member

    Great app - thanks
  6. gloss123

    gloss123 New Member

    Hi there am new to forum as I have just bought a HTC HD. So far I am impressed with the phone and as it is my first android I am still working my way round the whole system. With regards to this thread I am having problems to with deleting history. Even when you delet the history, cookies or cashe through the settings menu (as described here) I still get the all the previous addresses showing up in the address bar at the top and also even if I dont go on the internet for a few days as soon as i go back on I can still back page using the 'menu' soft key and clicking 'back page' soeven if I have clicked on delete browser history people can still click back as many pages as they like to see my history. Also I have noticed when I go on the internet it doesnt open up on my home page which is set to google it always opens up on the last page I was looking at! Any help on this one guys would be useful.

    Also while I am on does any one know how to move photos off your memory sd card on to your phone memory, there doesnt seem to be a way of doing it via the phone or when hooked up to a pc via USB cable.
  7. Diamondhead

    Diamondhead New Member

    Hi,

    Sorry to re-open an old thread if it has already been covered elsewhere, but I have the same problems Gloss123 has raised. Does anyone know how to fully clear the history under these conditions and also how to stop it opening up on the last page viewed rather than the home page.

    Any help would be much appreciated.

    Cheers,

    Graham.
  8. furious duck

    furious duck Well-Known Member

    Clear cache, open up a new window and close the original window.
  9. Diamondhead

    Diamondhead New Member

    Hi Furious Duck, thanks for responding.

    I'm new to this smart phone lark so please bear with me if I ask some noddy questions. How exactly do I clear the cache?
    As to closing the window I've shut down the phone, restarted it and then pressed the internet button, the window it comes back with shows teh last page I looked at. Do I need to close the window in a different way?

    Cheers,

    Graham.
  10. furious duck

    furious duck Well-Known Member

    Ok, when you're on Internet on your phone press the menu button on the bottom of the phone. Then press Windows. If you have any more than one window open then close them down so you just have one window open. Press the plus button so you now have 2 windows open. Close down the other window so you're just left with the new window open.

    Once you've done this then you'll need to clear the cache. Menu button | More ... | Settings | Tap on Clear cache | Tap on Clear History.

    You should now be left with just your home page and your history and cache cleared.

    Or just stop looking at porn. ;)
  11. Diamondhead

    Diamondhead New Member

    Thats great, thanks.

    One final question, I still don't get my homepage coming up on the one remaining page, it just comes up as blank. Any idea how to get it go come up with say Google.

    Cheers.
  12. Griff_LI

    Griff_LI Well-Known Member

    When you open a new window it should come-up with your home-page. Check the homepage settings under the Browser's Settings menu. Make sure you can access the site by typing the address URI in.
  13. madmonk

    madmonk Well-Known Member

    To get original homepage up, you need to force close the Internet app, in "Manage Applications". The last page looked at, irrespective of history, will now be gone.
  14. furious duck

    furious duck Well-Known Member

    As Griff_Li mentions, just make sure you've set your home page - menu | more... | settings | set home page and add Google. Any new window should then open with Google.
  15. hainman

    hainman Well-Known Member

    i've found that you can go to settings,applications then manage apps,all apps then scroll down to internet then clear data and it clears everything and free's up your memory a bit.....
  16. Diamondhead

    Diamondhead New Member

    Hi Guys,

    All sorted now, thank you all very much for your help :).

    Cheers,

    Graham.

Share This Page