How to disable data usage?Support


  1. STM

    STM New Member

    Is there a way to completely disable data usage? I'm with koodo so if i use like 100kb or something, i get charged $5. I don't wanna disable data through koodo cause then i wont get to uses my unlimited picture text. So is there a way to completely disable data via the phone settings? The problem is that sometimes when i put my phone in my pocket, it will enable certain features including data. Maybe there's an app that can help me? I heard 3G Watchdog might but i don't see a disabling option. Any help would be greatly appreciated.

    Advertisement
  2. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    I don't have a data plan so I'll try my best to help you, but I can't guarantee anything. ;)

    I'm using a Gingerbread custom ROM, so it might not be the same for you, but you should go in the settings, wireless & network, Mobile networks and then you should untick "Data Enabled".

    You might have to enable it again to send/receive MMS messages, I'm not sure.
  3. vipul619

    vipul619 Well-Known Member

    yep, its the same for all..
    just goto settings>wireless & networks>and disable data/roaming and all.. :)
    if i remember correctly you even have a switch to turn it off when u drop down ur notifications.. its the one with 2 arrows (most usually)..
    tap to disable, tap to enable :D
  4. NatKcohil

    NatKcohil New Member

    Beside disabling the data access etc, I create a dummy APN.
    than delete the APN from your telco.

    But ..... don't under estimate the power of the Telco, they have ability to restore their APN setup and set it as the default APN.

    If the telco allows, you may want to ask them to disable GPRS on your number. but I think that will impact receivind MMS too.
  5. LJWilde

    LJWilde New Member

    just goto settings>wireless & networks>and disable data/roaming and all.. :)



    This works for a while but something is turning the data enable back on and I can't find out what. The text to speech won't work on messaging unless I'm in wifi so if it starts to work out of a wifi, I check the data enable and sure enough it's back on. no idea how. any wise one know whats starting it up again. I can't send picture messages with it off, but if i leave it on all the stupid background updates use up data and I don't have a plan (and don't want one) so the background stuff cost me $20 already this month.
  6. viral1991

    viral1991 Active Member

    Go to settings>wireless & networks>wifi>push menu hardware button>Advanced>set wifi sleep policy to Never. That's it! :)

Share This Page