1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

How to disable visible sms text notificationGeneral


Last Updated:

  1. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    Hi, I have just got a new HTC Desire HD after years of being loyal to Nokia. One aspect is troubling me. I want to receive a sound notification and icon when I receive a new text message but I do not want the content of my received message displayed on the screen for everyone to read. Is there a way of receiving a sound and icon notification without also having the text scrolling on the home screen and also displayed on the Notifications page? Many thanks for any suggestions.
     

    Advertisement
  2. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    It depends which SMS app you use. I use handcent, and I have mine set up to display the icon but not display the text in notifications.
     
    Cal M likes this.
  3. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    Thanks for your reply. I had been using the pre installed Desire HD message notifications and customised them in Message Settings. I will try downloading Handcent if that gives the option of not displaying the text.
     
  4. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    Hi. I have installed Handscent but I am still receiving a preview of received sms's on the phone screen. I have disabled Popups in Handscent. I think I might need to disable Notifications in the stock Messaging app but I am not sure how to do this. I have tried Menu>Settings but can't see a menu on that for diasbling Notifications. Any advice? Thanks.
     
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    Yeah, it's done from within the stock app itself. Open the app, hit Menu -> Settings -> Uncheck Received Notifications.
     
    Cal M likes this.
  6. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    Rather than going to the main android settings, you need to go the SMS app and then hit menu >> settings. The option to disable notifications is in there.

    In handcent, if you do the same and go tto menu >> settings >> notification settings, you'll see 'notification settings' and 'popup settings'. Inside both those menus is a privacy mode option, that stops the message being displayed in popups/notifications.
     
    Cal M likes this.
  7. DCTEN

    DCTEN Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    184
    Likes Received:
    4
    But when you do that it means the sound notification is 'greyed out' meaning that you don't get the sound notification :mad:
     
  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    If you have a 3rd Party app for messaging or something like SMS Popup installed, that will handle it. I suspect that's what the option is designed for.
     
  9. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    Yeah, all you can do with the stock SMS app is turn them off entirely. That's why I recommended handcent, which provides it's own notifications but lets you stop the message being displayed on screen :)

    EDIT: Why is everybody ninjaing me today? :p
     
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    Because you're old (maybe) and slow? :p
     
  11. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    Hey, back in my day people had more respect for their elders.




    (Note, I am actually 20 :p)
     
  12. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    Apologies :eek:
     
  13. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
  14. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    lol, spolier tags would've been better. :)
     
  15. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    Many thanks for your advice. I can now get my messages without the content being shown on screen. Brilliant! One last (I hope) question. I am not receiving delivery reports for messages I send and it is always good to know the status of your message. In the Receive Messages screen I have checked the box for Delivery Reports (rather than the Handcent Delivery report box.) Is this right or should I be doing something else? Many thanks.
     
  16. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    I don't use delivery reports, but I would have expected the option to be in the sending messages option. I'll have a look and see what I can find...
     
    Cal M likes this.
  17. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    Thanks so much. I really appreciate your assistance. I am thrilled that I can now get my messages without the content on display!
     
  18. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,745
    Likes Received:
    8,830
    What if you go to Settings >> Notification Settings >> Sent Message Notifications and pick 'Notify when message is recieved'?

    It says your mobile network needs to support the feature, so it may or may not work for you.
     
    Cal M likes this.
  19. DCTEN

    DCTEN Well-Known Member

    Joined:
    Nov 29, 2010
    Messages:
    184
    Likes Received:
    4
    Just got Go SMS and it's solved the problem like you and the above people has said. Cheers :)
     
  20. Cal M

    Cal M Member This Topic's Starter

    Joined:
    May 3, 2011
    Messages:
    6
    Likes Received:
    1
    You are an absolute star. All working just as I want it now. Thanks a million.
     
    Xyro likes this.
  21. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Joined:
    Jan 3, 2011
    Messages:
    30,529
    Likes Received:
    21,348
    No probs!
     

Share This Page

Loading...