[How to] DOWNGRADE & ROOT


  1. smith058

    smith058 Guides Guide

    This is not my work... just bringing it to AF from XDA :D

    --------

    For users who mistakenly upgraded to .26 or received .26 from the beginning.
    This method - guide works: [​IMG] .
    .


    a) downgrad from .26 firmware to .17 by doing the following:
    ONE CLICK Downgrade, using Wolf's method and root tool (thanks to viperboy)
    http://forum.xda-developers.com/show...4&postcount=52
    Just put the BLOB file of FW (aprox 750mb+ file with no extension, extract it from the zip)
    http://dl.dropbox.com/u/53726414/US_...teLauncher.zip
    (Asus pulled the files off the web site so I got the BLOB file from http://forum.xda-developers.com/show....php?t=1642614)
    Then put the BLOB file on the root of your tf300 internal memory (I also placed it a copy of it in the root root of SD card - just in case), then make sure that usb debugging is enabled, also make sure you have the asus drivers installed in your windows machine: I got the drivers by installing:
    ASUS Pad PC Suite (PC version V1.0.41)
    from http://support.asus.com/Download.asp...300T&p=20&s=16

    Then you can run option 1 on the modded vipermods tool (via windows machine) : viperMOD Primer Tool v4.5 - Modded by bpear_v3.exe
    exe from :
    Download:
    https://docs.google.com/uc?id=0B8gHy...xport=download

    viperMOD Primer Tool v4.5 - Modded by bpear_v3.zip

    Dev-Host - The Ultimate Free File Hosting / File Sharing Service

    b) Then apply ROOT to .17 FW with SparkyRoot
    It is a one click root app:
    SparkyRoot.apk - (1.09 MB, 9403 views)
    from
    http://forum.xda-developers.com/show....php?t=1526487

    c) Once root is done, get Voodoo root keeper app from android/play market and save full root.
    https://play.google.com/store/search?q=ota rootkeeper

    d) Update the firmware to .26 via OTA/wifi works perfectly. Then restore root with Voodoo root keeper app, and install your apps: Droidwall, Titanium Backup, Rom Manager etc.. Thanks for all the help from other devs and tips from users [​IMG]

    Originally Posted By anduzer
    --------


    VERY IMPORTANT, ACTUALLY MOST IMPORTANT THING TO DO:

    As soon as you're rooted, get Voodoo OTA rootkeeper. its free from the marketplace. then open that app up and Save and backup your root. REPEAT, SAVE & BACKUP YOUR ROOT. you will kick yourself in da a$$ if you don't..lol. then now you can update to the latest firmware for 300, which is .26 or whatever. Once you update, you will initially lose root. but no worries. you just open up the voodoo app and restore your root. Now you are rooted again on latest firmware. you will use this method from now one to restore root after a firmware update. there has already been confirmation of a 300 owner rooting on.17, then using voodoo to save/backup his root, then update to .26. then using voodoo to restore root. now he is rooted on latest .26 firmware for 300.
    Originally Posted By demandarin

    .

    Advertisement
    :
    darbc, jericko and enomele like this.
  2. enomele

    enomele Member

    Thanks for the post! I'm having problems with adb not detecting the transformer pad though. Every time I boot up adb and do adb devices the line where it says the device is blank.

    I've tried the drivers from Asus Sync and the drivers from Android SDK, making it is the Composite ADB as the tutorials say and no dice. Even used my laptop thinking it was my desktop being racist or something. Bugging the heck out of me. If anyone has any insight that would be most appreciated!
    Edit; and I do have debugging enabled,
  3. smith058

    smith058 Guides Guide

    Lets narrow down the problem... Asus drivers or adb... drivers: plug usb into pad and computer, does your computer recognize your pad? Can you transfer files? If not redownload and install asus drivers... if drivers work then its adb. Try testing on another device and/or redownload and install and/or check computer permissions.
  4. enomele

    enomele Member

    Well I tried a few different set of drivers, first was the the ones that come with Asus sync. Then the ones from the sdk from Google. Retried both a few times. I even tried using the pc program Droid explorer to see if the sdk was corrupted.

    I can see, it in explorer and can put files on it and everything. My next step is to see if my computer recognizes my Droid Inc. I connected it to the same computer yesterday and Droid explorer auto recognized and booted up but hasn't done that for my pad yet.
  5. smith058

    smith058 Guides Guide

  6. enomele

    enomele Member

    The one I used was just the sync from the Asus site under the software category for the 300. I'll try installing the Suite when I get back home.
  7. worknman

    worknman Well-Known Member

    UPDATE: A friend of mine, who just got a TF300, let me know that it's now possible to obtain root without downgrading:

    http://forum.xda-developers.com/showthread.php?t=1704209

    (Original post)
    Thanks to the original poster for the guide. I have modified his original info a bit and am posting the instructions I followed to root the TF-300 using Windows 7, and firmware build .29 on the 300. I take no responsibility if anything bad happens as a result of you following these instructions :) Apologies if there are any errors in this post. Mods, feel free to edit as needed.

    1. On your TF-300, go to Settings -> About Tablet and check the build number of your ROM. If the build number ends with .17, you can skip to step 9. If it ends with .26 or .29, you'll have to downgrade to .17 in order to root, using steps 2-8 below.

    2. Download the .17 firmware and unzip the file named 'blob' into the root folder of your tablet's internal storage:

    [GUIDE] TF300 Blob Files, US/WW/TW Updated 5-25-2012 - xda-developers

    3. Download and extract this downgrade tool from ViperMOD to a folder on your Windows PC. This tool was made for the Prime, but will work with the TF-300:

    https://docs.google.com/uc?id=0B8gHy...xport=download
    - or -
    viperMOD Primer Tool v4.5 - Modded by bpear_v3.zip
    - or -
    Dev-Host - The Ultimate Free File Hosting / File Sharing Service

    Install the ASUS Pad PC Suite USB drivers (PC version V1.0.41) on your PC. (On the download page, select 'Android' as the OS, and then look under 'Utilities'):
    ASUSTeK Computer Inc. -Support- Drivers and Download ASUS Transformer Pad TF300T

    After the installation is done, reboot your PC.

    4. Go to Settings -> Developer options on your tablet and turn on USB Debugging. Ignore the warnings that come up.

    5. Plug your tablet into your PC using the USB charge/sync cable that came with the tablet. The PC should properly recognize the tablet.

    6. ** IMPORTANT ** Be sure to kill the Asus 'Splashtop' software on your PC. I was not able to complete this process until I did this.

    7. On your PC, run the downgrade tool: viperMOD Primer Tool v4.5 - Modded by bpear_v3.exe and choose Option 1. It will run through the process by itself, which should take at LEAST 3 minutes. If it finishes in a few seconds, it probably didn't work, so make sure the Splashtop software (see above step) is not running.

    8. After the process finishes and your tablet reboots, check your build number (see Step 1) and make sure you're on .17.

    9. Download this root tool from SparkyRoot and copy it to your tablet's internal storage:
    [TOOL][APK ROOT]SparkyRoot Apk root method - xda-developers

    10. On your tablet, go to Settings -> Security and check 'Unknown sources', then go into the file manager and run the APK, following the instructions in the above link.

    11. After you have root and superuser is installed, download OTA Rootkeeper (free) from the market and run it. In my case, when I first ran it, it took a couple of minutes to come up, only 3 out of the 5 options were checked, and nothing happened when I hit the 'Protect root' button. Then I went to the menu and hit refresh, which triggered the superuser access request. That lit up a 4th option, which then allowed the 'Protect root' button to do what it is supposed to. After you are through with this process, all 5 options should be checked.

    12. Install the latest Asus firmware (.29 as of this writing), which should be waiting for you in your notification tray. After you have installed .29, run Rootkeeper again to restore root.

    13. ENJOY! :)
    darbc likes this.
  8. fescko

    fescko New Member

    Wat do?

    I'm really new to this tablet, I've had it for 3 days at most, so I'm not familiar with everything on it... However I've worked with rooting my phone before, for quite a while, so I do (at the very least) have minimal knowledge of what to do. Anyway...

    Does my device need to be unlocked for this? I don't know whether or not if it is unlocked or locked. Can somebody tell me how I can tell this? And assuming it needs to be one or the other. How do I lock/unlock the tablet?

    Everything went smoothly up until using ViperMOD. Nothing bad happened afterwards, but my device stayed on .29 FW. Splashtop was killed, the US .17 blob file was (and is) in the root of the internal storage. USB Debugging was on. However, it only took a few seconds to reboot and when it was finished it was on .29...

    I'm not quite sure why it didn't work, but that's why I'm wondering about whether or not it needs to be locked, ideas anybody?
  9. worknman

    worknman Well-Known Member

    Mine was never unlocked. I chose not to unlock mine because I heard you can't get official updates from Asus anymore if you unlock. I had the same problem as you with the .29 firmware not downgrading. If killing the Splashtop app didn't work, then I don't know what the issue is. Sorry :(
  10. NYCHitman1

    NYCHitman1 Gun for Hire Developer

    Unlocking the bootloader makes the root process 110% more simplistic. At that point, it's just flash a recovery, and then flash a root.zip in recovery. Voila!
  11. hollywoods14

    hollywoods14 Well-Known Member

    Fantastic, i love this forum! Just bought my 32gb device and caught root before the update. Thanks guys!!!
  12. MrB206

    MrB206 Well-Known Member

    My build is .30... still possible to downgrade to root?
  13. hollywoods14

    hollywoods14 Well-Known Member

    I posted on rootz asking mrb. I dont see why it wouldnt. Are you just wanting to root or are wanting to flash roms too?
  14. MrB206

    MrB206 Well-Known Member

    I'm not sure yet. I saw someone say unlocking the bootloader will prevent any future otas, which I'm not sure I want to do... The bootloader app looks like the easiest way to root without having to downgrade. There's a ton of roms for this thing so I'd be remiss if I didn't flash one ;)

    Do you have cwm flashed? I saw something about not using rm to reboot into recovery (unless I read wrong)... That seems a bit of a pain.
  15. hollywoods14

    hollywoods14 Well-Known Member

    Im just rooted for now. Im holding off on unlocking the bootloader for now. One thing i have been reading is cwm is really buggy and not working correctly. Seems like most people are using TWRP2. You should check rootz, lots of activity there. I do believe there is a jelly bean rom in the works too.
  16. MrB206

    MrB206 Well-Known Member

    I'm a little confused here. This post and the xda post keep referring to .17, but the Viper program refers to .15:

    [​IMG]

    I used the 'US_epad-user-9.4.2.15' blob, but it didn't downgrade me... I'm still on .30
  17. MrB206

    MrB206 Well-Known Member

    ... and now I'm getting a device not found error:

    [​IMG]

    I've got the Asus drivers installed (bunch of bloat and garbage in them too) and tried the ptp connection (camera) under USB settings, to see if that would work, but it didn't.


    So there's the .15/.17 discrepancy and question about downgrading from .30.
  18. hollywoods14

    hollywoods14 Well-Known Member

    the tool is baed off the Prime, thats what im reading. I think you may have used to the wrong blob. you may try this one https://docs.google.com/file/d/0B1ReSMcHudEDODl3SlZaVldoVms/edit?pli=1 ... on post 7 in this thread there are a couple more links. I have also read that the blob may require extracting a couple times. .. myabe check out post #7 is you havent. Hope somthing here helps, like i said i was able to root right out of the box while it was still on .17. I can tell you for a fact everything after the downgrade works flawlessly.
  19. MrB206

    MrB206 Well-Known Member

    Weird. The blob was a 7z file and I found the blob.blob file inside the first container, but maybe it was the source I downloaded from. The file name was "US_epad-user-9.4.2.15.7z". I'm downloading that link you posted and will see what's what.

    Still... they need to update that program to say '.17' and not '.15'; it's confusing.
  20. MrB206

    MrB206 Well-Known Member

    Oh wow, that new link you gave is 200mb larger than the one I had... I bet I had a bad blob.
  21. MrB206

    MrB206 Well-Known Member

    I found the issue....

    He wasn't kidding. VERY important. I killed that program and it's running fine now.
  22. hollywoods14

    hollywoods14 Well-Known Member

    excellent, i was gonna copy and paste that but decided not to. Instead i refered you to post #7. Wasnt sure if you saw it or not, i didnt want to insult you if you had taken that step already.

    Glad you got it going man!
  23. MrB206

    MrB206 Well-Known Member

    Yea good stuff. I had to install SuperSU from chainfire to be able to freeze, but it's sorted now.
  24. hollywoods14

    hollywoods14 Well-Known Member

    SU installed for me when i installed sparky root
  25. MrB206

    MrB206 Well-Known Member

    SU installed with the Viper method, but for some reason, it didn't fully allow root functions, like freezing apps; everything else seemed to work. I Loaded SuperSU and all is well. Not sure what that app does, but it did it.

    Oddly enough, I couldn't get Sparky to recognize the vulnerability. Are you supposed to root with Viper, THEN use Sparky?
Loading...

Share This Page