How to downgrade S4 from 4.4.2 to 4.3 without root?Support

Last Updated:

  1. DionysDean

    DionysDean New Member

    My Samsung S4 (Model SGH-I337M) has recently been updated from 4.3 to 4.4.2, and everything has gone to sh*t since; my battery life has decreased significantly, basic apps such as the camera lag, even just trying to turn on the screen sometimes takes several tries and my phone freezes. Overall everything runs slower.

    Is there a simple way to downgrade back to the previous version of the OS without rooting my phone and/or voiding the warranty?

    What I was running before:
    Android Version: 4.3
    Kernel version: 3.4.0-2142508
    Build number: JSS15J.I337MVLUEMK6

    What I'm running now:
    Android Version: 4.4.2
    Kernel version: 3.4.0-880525
    Build number: KOT49H.I337MVLUFNC1


  2. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Short answer: You can't
    At this point, especially since non-rooted, about the best you can do is clear the various caches (+ clear data on the lagging/freezing apps) and reboot. Start by powering off and then doing a Recovery boot (you can find YouTube videos for how to do this and what to expect). Once in Recovery, "Wipe cache partition" and reboot (using the recovery menu). If that doesn't get you where you want to be, clear cache on the troublesome apps, as well as Google Play Services and Google Services Framework. You access this menu from Settings > Manage apps ("All" tab). Reboot and check again. If still problems, go into Manage apps again and try clearing data on the troublesome apps (but DO NOT clear data on Google Services Framework). Note that clearing data will rest an customizations or options you have set for the app (including game history, scores, etc
    DionysDean likes this.
  3. DionysDean

    DionysDean New Member

    Thanks Mr. Lucky, I've now wiped the cache and tried clearing data. I might even try uninstalling some apps I don't use often. We'll see if it improves anything (especially battery life).

    But the lag appears to be with the OS itself rather than any particular app. I use my phone mainly for browsing, G+, FB and music. I'm not a gamer, and I use my Google account to backup my contacts and personal data, so I'm not too concerned with wiping everything.

    Could a Factory Reset potentially help?

    If there's no simple way to load 4.3 again, I'll most likely go with rooting.
  4. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    Kind of drastic, but yes… if you are willing, it could very well help.
  5. lotus49

    lotus49 Well-Known Member

    It is my understanding that you can roll back to any Knox enabled firmware. Perhaps we need Ironass to chip in at this point as he knows more about this than I do.

    Whether you are rooted doesn't have any bearing on which ROM you can install either as you can use Odin whether you are rooted or not.
  6. dynomot

    dynomot Well-Known Member

    Nope, 4.4.2 has a new bootloader, Knox is academic in this case. You cannot go back whether rooted, stock or whatever. For those that are rooted even a Nandroid backup from 4.3 is useless when you flash 4.4.2.

    Personally if I were having issues with any upgrade I'd take a deep breath, factory reset and rebuild the phone from scratch. See here :
  7. ironass

    ironass Well-Known Member

    Like you lotus49, I did not flash the stock firmware with locked bootloader and Knox security and am running on KitKat without these and you'll forgive me if I don't rush to try that out personally. I know for sure that you cannot go from Knox'd, Android 4.3, back to non Knox, Android 4.2.2.

    I am also given to understand that the locked bootloader has also changed between 4.3, Jelly Bean, and 4.4.2, KitKat, and prevents downgrading. I have not found anyone yet that has done so successfully.
  8. dynomot

    dynomot Well-Known Member

    I forgot the exception to the rule. Now why would I forget that? (Double face palm moment - a) for forgetting and b) giving Mrs. dyno my SGS4 to play with with lovely pre Knox firmware and she "helpfully" Installing an OTA update (yes - we are still married).
  9. cocokasper

    cocokasper Well-Known Member

    F*** KNOX...... and screw the damn Efuses it uses...
    I've been off AF for a few months, I know knox is rootable... but has anyone found a way to remove knox? so if I tomoble "jump" to the GS5 will I be stuck with a locked bootloader?
  10. ironass

    ironass Well-Known Member

    No, they have not. Yes, you will.

    See, Knox Security & locked bootloader on new firmwares
  11. CafeKampuchia

    CafeKampuchia Well-Known Member

    There are a number of custom ROMs that have Knox removed, and if you haven't already upgraded to 4.3 or later, they don't update the bootloader either. My i9500 still has the 4.2.2 non-Knox bootloader and is running a Knox-free, rooted TouchWiz 4.4.2 ROM, except when I'm running CyanogenMod 11 on it.

    If you move to an S5, you will have a Knox-enabled bootloader and firmware from point of purchase, one of the main reasons I'm sticking with my S4.
  12. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    I have successfully removed all traces of Knox on my AT&T S4, running 4.3.
    Follow these instructions in the order specified: xda-developers - View Single Post - [Q] knox is spying on you!! How to completely remove it. Video inside
    Next, remove any Knox remnants that remain as per this page: I9505 Ultimate BLOATWARE (remove) List deBLOAT Android 4.3 OFFICIAL (ROOT required!) - xda-developers
    Additionally, I found a Knox service running that needs to be disabled - TimaService (within Android System, AKA I used the Disable Service app for this purpose. If you also find "IQService" active there (like I did), disable that as well - it is Carrier IQ spyware.

    Not all files listed in the first two links will be found in all S4 models. Just move on to the next one in the list if it's not on your phone. If you choose to backup everything instead of just deleting it, be aware that the items in /data/data are symlinks, so you won't be able to copy or delete them without first unlinking. I chose to just rename them with .bak appended (they don't take up much room). HTH!
  13. amexpc2012

    amexpc2012 Member

    There is a solution to this, Switch back to iPhone.
  14. lotus49

    lotus49 Well-Known Member

    So your recommendation to avoid manufacturer imposed limitations on one phone is to move to another that is even more restricted?

    No thanks.

    This is precisely why I moved from iPhone to Android several years ago.
    jj14x likes this.
  15. amexpc2012

    amexpc2012 Member

    It's not really that restricted. Now that the Samsung Galaxy Series have KNOX, they are just as restrictive and in some cases even MORE RESTRICTIVE than the iPhone. Not to open up a war or anything but I've been experiencing the very same issues as he has: slow performance and draining battery. I can't even browse the web without the battery draining 1% per minute. Now I am not trying to bash Android, but this system needs to be worked upon and I mean it dead seriously.

    I'm afraid there is no way of downgrading the Galaxy S4 without tripping KNOX (which is Samsung's warranty void bit). You trip it, say goodbye to your warranty.

    With Apple, you can just restore the phone to factory and they won't know that you have rooted or jailbroken the phone at all.
  16. Marc_G

    Marc_G Well-Known Member

    I experienced significant lag and battery drain due to a version of the Google Play Services... but my eventual solution was to root the phone (an I337 with 4.4.2 NC1 firmware) with TowelRoot, install SuperSU and install SafeStrap, then flash it with the GoldenEye custom ROM. The phone now idles (with wifi/cell on) at about < 0.5% of battery drain per hour.

    I wish the bootloader were unloackable so a greater variety of ROMs would be available, but as it is the phone is quite usable. It's not worth selling it and buying an unlocked T-Mobile version, to me.

  17. sntaylor

    sntaylor Well-Known Member Contributor

    Except Knox is only to do with providing a secure work zone for those that use their phone and need it to be encrypted etc, this warranty will be void and you will never get Knox to work, however actual warranty has not been blown and may most likely still be accepted!

    However, when rooting, you just accept that you no longer have warranty!

    With Knox, you are certainly not more restricted than having an iPhone, you can still root, flash custom software, sideload apps etc etc compared to an iPhone that you can't even change keyboard on until recently....
  18. lotus49

    lotus49 Well-Known Member

    Try getting the source code for IOS from Apple and then decide how restrictive the Apple ecosystem is.

    It's true that, for some users (I am not one of the lucky ones as I flashed a 3rd party ROM before Knox-enabled firmwares were rolled out) Knox may (or may not - it still isn't crystal clear) result in the loss of the warranty if you flash a 3rd party ROM. That is the only area where any Android phone is more restricted than iPhones. Otherwise you can do almost anything you like with an Android phone including changing the source code and recompiling yourself. Try that with an iPhone.
  19. dacorsa

    dacorsa New Member

    hi Mr.Lucky!
    can u help me to disable timaservice on Samsung galaxy ?? how can u did it?
  20. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    As I said, I used the Disable Service app to disable it. If you are rooted, just install it from the Play store. Usage is self-explanatory. If you are using Xposed, there might be modules available that can do the same thing.
  21. dacorsa

    dacorsa New Member

    Ok but where is in disable services ?


    Attached Files:

  22. dacorsa

    dacorsa New Member

    Ok but where is in disable services ?


    View attachment 78094
  23. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    As I said in my earlier thread, which you quoted:
    IOW, just install the app and search for Android System under the "System" tab. They are in alphabetic order, so it shouldn't be difficult. Once you find it, press on the title; it will reveal another screen with all the running services for that selection. Pressing FULL/SHORT will toggle between the "friendly" name and the full name as found under /system. I'd include a screen-shot, but I no longer own that phone.
  24. dacorsa

    dacorsa New Member

    Ok thanks,

    As you can see on my screenshot in my last answer, there isn't anymore timaservice in the android system.

    What module do you use in xposed ?

  25. Mr. Lucky

    Mr. Lucky Well-Known Member Contributor

    In that case, your carrier didn't install it (I was with AT&T at the time). Don't worry about it.

Share This Page