How to enable email sync on Samsung Galaxy S3Support

Last Updated:

  1. paraspy

    paraspy New Member

    Hello all,

    Ok - this is really mind boggling and as such I decided to make an account and ask all you experts about it.

    I used to have an HTC Thunderbold and with its very poor battery, I had set my 5 emails to synch manually. So, whenever I felt like it, I would just go to settings and click on sync all.

    Yesterday I got my Galaxy S3. I rooted it right away, and then plugged in all my email accounts. 5 accounts - 3 gmail, 1 yahoo, and 1 private. I set them up all under the stock app, because I don't like the gmail app and I don't want to download any other apps. That's how I had them set up with my Thunderbolt too.

    Now, with the Galaxy S3, the battery is better, so I have set it to check for new emails/sync every few minutes during peak hours and every hour during off-peak hours. But I am just wasting time here - let me just get to the problem:

    If I go to Settings -> Email (under Accounts), then all my email accounts are there but the little "loading circles" are greyed out and they all say "Sync disabled". I have a screenshot that I wanted to post but as a new user I am not allowed. So, the button at the bottom of that screen that reads "Sync all" simply doesn't do anything. I click it and it stops loading in a split second.

    If I click on each individual account out of that list, then the only option I have is to Sync or Delete the account. If I go to the settings of each email account, then I see that "Sync Email" is checked on all of them, and I have edited the sync schedule for each of them too.... So... how is it that they all say "Sync disabled"??

    Moreover, and most importantly, how can I change it so that when I click on Sync all, ALL my email accounts are actually synced?

    Any help would be greatly appreciated!!


  2. SUroot

    SUroot Well-Known Member Developer

    If you go to the accounts section in android settings (not email app) make sure sync is enabled for each there
  3. paraspy

    paraspy New Member

    Under the accounts section, in the settings, i can go to emails, google, ms exchange or add a new account.. is there a different account section where I could enable sync?
  4. XplosiV

    XplosiV Master X is Watching You VIP Member

    Depending on your firmware,

    For ICS goto settings > accounts and sync

    And your accounts are listed there just turn sync now on at the top to sync them all

    For JB goto settings and there is a sub heading for accounts with your accounts listed right on that page, go into desired account and sync there.

    The sync disabled shows if you have not enabled sync from the pull down notifications area, if you tap on sync there and it shows up green, then any peak/off peak sync settings should apply.
  5. annebrooks64

    annebrooks64 Well-Known Member

    Try going into the email app then click on each account and click the left menu button inside each separate account and it should pop up another settings menu with sync frequency options.
  6. fabricioph

    fabricioph Member

    First you have to had enabled Auto Data Sync

    Settings -> Data usage -> push menu button -> Check "Auto sync data"
    abumekal, bcull, AzCoronaDog and 3 others like this.
  7. JWStealey

    JWStealey New Member

    Thanks Muchly! That worked on my Galaxy Note II!

    Very frustrating for sync not to be on and having to click on the sync at the top of email and it taking forever to get done!

    Wild Bill Stealey
    Chairman IENT
  8. sernee49

    sernee49 New Member

    To enable ALL EMAIL ACCOUNTS GO TO gmail icon> menu button> settings> select gmail account> under DATA USAGE turn Gmail sync on. This will enable syncing with all emails on ur Galaxy Note 2
  9. lovelydama

    lovelydama New Member

    Okay, so I'm new to Android. I set up my 2 yahoo and 2 hotmail accounts with the default email app. I have pop3 for the yahoo accounts. I want to delete or do as I please on my PHONE, but not have it affect the emails on the server. So when I delete an email on my phone I can still have the original email on I'm unsure what the sync settings do for the email accounts. My problem is that I set the peak times to every 15 minutes but it seems to only update sporadically when I open the app or I refresh it myself.

    When I go to my email, go to settings: under the options for Data usage: Sync Email: there is a check mark.

    But from the home screen I go to settings and under accounts I go to Email. There all the accounts say sync disabled.

    Not understanding what's going on. Someone please help. It's very frustrating.
  10. GTWalling

    GTWalling Well-Known Member

    The OP states he is not using the G-Mail app. This will not help him.

    That said he may try dropping the Notification window and make sure Sync it turned on.
  11. radio_flyer_04

    radio_flyer_04 New Member

    I had the same problem as the original post, and could not find an answer anywhere till I read this! I had sync set for every 15 minutes, regardless of peak time or not, and everywhere I looked had sync enabled. I never would have thought to check under data usage, let alone for a menu under that scree. Thank you!
  12. rgt10

    rgt10 Member

    I've been looking for 2 days on how to get the sync back on my S3. Thanks for the great tip. Much appreciated!! :D:D
  13. bcull

    bcull New Member

    Thanks Fabri this worked for me! :)
  14. abumekal

    abumekal New Member

    thank you..:)

Share This Page