How to Enable Sideloading of Apps on CaptivateTips


  1. maerlim

    maerlim Well-Known Member

    That's the exact same thing I did, except I spelled it out. Seems to be a problem though, which I'm investigating.
  2. Tobal

    Tobal Member

    You know at first I thought I was stuck in debug, I couldn't bring up settings at all, I was about to hit the factory reset and thenwent into settings and it was all there. Turned off USB debug seems to be fine.
  3. Duck Tales LOL

    Duck Tales LOL Well-Known Member

    So I went the other route and edited the .db file on my PC. Changed Install Non Market Apps to 1, rebooted, and it still doesn't work. :(
  4. Duck Tales LOL

    Duck Tales LOL Well-Known Member

    And after I rebooted again, my phone is freezing on the Galaxy S bootup screen, and then shutting off. When I try to hold down the volume button down, and the power button to do a hard restore, it doesn't work..


    Sucks to be me.
  5. YellowGT0

    YellowGT0 Well-Known Member

    Don't factory reset. There is just a step missing I fixed it
  6. YellowGT0

    YellowGT0 Well-Known Member

    Connect USB to phone with USB Debugging ON
    Command prompt
    cd to SDK install directory
    cd tools
    adb shell
    su
    chmod 777 /dbdata/databases/com.android.providers.settings/settings.db

    That will fix your phone 100%.
    maerlim likes this.
  7. Zilch

    Zilch New Member

    I just wanted to post that I followed the instructions from the OP *with* the additions from YellowGT0 and I'm not having any problems leaving USB Debug mode.

    Also for anyone trying this it's:
    chmod 777 /dbdata/databases/com.android.providers.settings/settings.db
    ^
    Needs the space between chmod and 777 :)

    * Also I used the app linked in the OP as well and had no problems installing it, so mission: accomplished I'd say
  8. YellowGT0

    YellowGT0 Well-Known Member

    Ugh duh good cetch
  9. psolk

    psolk New Member

    Is there something else you need to do after the chmod 777 /dbdata/databases/com.android.providers.settings/settings.db?

    Everything else worked fine, got root, installing non-market apps but still stuck in debug mode... Don't want to reset after I spent all day configuring her...
    Thanks in advance!


    Sorry for the confusion... Followed the steps a couple more times and it took. I look to be good to go.
    Thanks to Maerlim! and to Yellow and Zilch for rounding it out...
  10. Zilch

    Zilch New Member

    ^^ Haha looks like you figured it out while I was typing the response :)

    I'd imagine you'd have to restart the phone after the chmod step in order for it to see the change, though I'm no expert.
  11. maerlim

    maerlim Well-Known Member

    I have a feeling one of my problems was changing USB debugging on and off so much in the original procedure, which got the settings.db confused while it was being copied and edited. I'm going to try to simplify and see what happens.

    Edit: The chmod 777 was the trick. I'm updating the original post. Thanks YellowGT0!
  12. Duck Tales LOL

    Duck Tales LOL Well-Known Member

    Simpler way is to use Root Explorer and just edit the file on PC and transfer it back. :)


    Even though after I did that, I can't get my phone to power on now... Lovely.
  13. maerlim

    maerlim Well-Known Member

    Yeah, how's that Root Explorer method working for ya? ;)
  14. YellowGT0

    YellowGT0 Well-Known Member

    Yeah I've run into this issue before. I think it has to do with windows when you copy a file it puts permissions as read only. Only works for some files though. Database files might be one of them. Im using Windows7 anyone with XP or before have this issue?
  15. t-readyroc

    t-readyroc Well-Known Member

    sticky requested.
  16. YellowGT0

    YellowGT0 Well-Known Member

    Just and update. I've been using it since the 17th and with the chmod trick I have no issues at all.;)
  17. derek4484

    derek4484 Member

    I used root explorer and followed the method listed on xda-developers and it worked perfectly fine for me. Took less than a minute.

    I used root explorer to copy the settings.db file from the original folder to the sdcard. Then plugged phone into computer via usb. Mounted the sdcard. Used sqlitestudio to modify the one value. Unmounted and disconnected the phone from the computer. Used root explorer to copy or move that modified settings.db file from the sdcard back in to its original folder. Root explorer asked if I wanted to overwrite the existing file, said yes. Done. Rebooted phone and it worked. Tested by downloading some cheesy free game .apk from slideme.org. It installed and played perfectly.
  18. YellowGT0

    YellowGT0 Well-Known Member

    Yeah but root explorer cost money.
  19. dsjr2006

    dsjr2006 Well-Known Member

    Worked great for me on my Mac. No need to install drivers though. Anyone with Mac issues let me know. I may be able to help.

    This also works well for SQL on Mac:
    SQLite Database Browser Download - Softpedia

    I can install non-market apps now, but is there any way to just get the setting back too?
  20. mjgunn

    mjgunn Active Member

    Stuck at "cp: not found". Downloaded busy box from the marketplace, opened it. It said "Status: Waiting...", so I hit install. Now it says "Status: Done!" Below that it says "Your phone is rooted. Busybox was found here: /system/xbin". Seems like it's installed? But still getting "cp: not found"

    Edit: Uninstalled busybox, redownloaded it, opened it and hit install again, and "cp" was working fine, not sure what the problem was the first time. Got it all working and sideloading with ease.
  21. YellowGT0

    YellowGT0 Well-Known Member

    Your doing this through CMD on your PC right?

    Are you talking about putting it back to stock?
  22. dsjr2006

    dsjr2006 Well-Known Member

    Nope, well kinda. Most Android devices have an option in settings to allow or disallow non-market apps. I have non-market apps working and installable, but I'm just wondering if there is a way to get the setting to show up.
  23. YellowGT0

    YellowGT0 Well-Known Member

    Not yet I don't think. You can always set the flag back to 0 on the settings. Once we get a rom with an EU base it should be int he settings again.
  24. agent007ppk

    agent007ppk New Member

    Macbook-2:tools Alee$ ./adb shell
    $ su
    # cp /dbdata/databases/com.android.providers.settings/settings.db /sdcard/settings.db
    cp: can't create '/sdcard/settings.db': Read-only file system

    I get this error. Anyone have any thoughts? My phone is rooted, and has Busybox installed.
  25. YellowGT0

    YellowGT0 Well-Known Member

    Try doing the CHMOD 777 step 1st. That should make the file more then read only.
Loading...

Share This Page