How to Enable Sideloading of Apps on CaptivateTips


Last Updated:

  1. maerlim

    maerlim Well-Known Member This Topic's Starter

    Joined:
    Mar 9, 2010
    Messages:
    490
    Likes Received:
    121
    It almost seems like you have your phone set up for USB Mass Storage, which locks the SD cards for use only by the computer. You need to make sure you haven't mounted the SD cards to your computer and that USB Debugging is turned on.
     

    Advertisement
    rnj79 likes this.
  2. Pinetree09

    Pinetree09 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    40
    Likes Received:
    4
    This is probably a stupid question, but when I type in adb shell and hit enter, it says device offline, how do I make it "online"?
     
  3. maerlim

    maerlim Well-Known Member This Topic's Starter

    Joined:
    Mar 9, 2010
    Messages:
    490
    Likes Received:
    121
    Make sure you have the USB drivers installed for your PC, and turn on USB Debugging on the phone.
     
  4. Pinetree09

    Pinetree09 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    40
    Likes Received:
    4
    I've done both of those, but I still get "device offline"
     
  5. YellowGT0

    YellowGT0 Well-Known Member

    Joined:
    Jul 17, 2010
    Messages:
    114
    Likes Received:
    22
    I think hes doing it on a Mac. Does that change anything? You don't have PC or Bootcamp?
     
  6. Pinetree09

    Pinetree09 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    40
    Likes Received:
    4
    Are you implying I own a Mac? That offends me :(

    Anyways, nah, I'm using a PC, win7, etc.
     
  7. lilo

    lilo Well-Known Member

    Joined:
    Jul 19, 2010
    Messages:
    60
    Likes Received:
    2
    Here is how Samsung support site tells to do this:

    1. Download and install the latest Android SDK from the Android Developer or click here. (For easy of access, it is recommend to extract to local host root (C:))
    2. Download and install the Java Developer Kit (JDK) from Sun or click here.
    3. Download and install the latest Android Developer Bridge (ADB) driver located click here.
    4. Enable USB Debugging under Settings>Applications>Development
    5. The installation file should have an extension of .APK, if properly compiled. Place the application in the tools directory, i.e. (C:\android\tools)
    6. Using the command prompt, go to the tools the folder (i.e cd\android\tools)
    7. Type in ADB Install .APK
    8. The ADB tool should now report the application to be installed. To verify, tap on Applications on the device and locate the name of the application.

    URL: How Do I Side Load Applications On My SGH-i897 (Captivate) Phone Using The Android Debugging Bridge (ADB)?
     
  8. YellowGT0

    YellowGT0 Well-Known Member

    Joined:
    Jul 17, 2010
    Messages:
    114
    Likes Received:
    22
    Hahaha sorry, I thought you were the same guy I was talking to before. I would be Offended also.
     
  9. Darkeligos

    Darkeligos Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    134
    Likes Received:
    7
    Nevermind, getting it.
     
  10. dsjr2006

    dsjr2006 Well-Known Member

    Joined:
    Mar 25, 2009
    Messages:
    378
    Likes Received:
    14
    Make sure SD card is mounted to phone, not computer. In notification bar make sure you dismount SD card from comp before trying this.
     
  11. mjgunn

    mjgunn Active Member

    Joined:
    Jul 19, 2010
    Messages:
    26
    Likes Received:
    3
    Anyone?

    Edit: Got it working
     
  12. Pinetree09

    Pinetree09 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    40
    Likes Received:
    4
    hmm, now I get "error: more than one device and emulator" when i type in adb shell and hit enter

    edit: did adb devices and it shows the phone twice, both offline :/
     
  13. YellowGT0

    YellowGT0 Well-Known Member

    Joined:
    Jul 17, 2010
    Messages:
    114
    Likes Received:
    22
    Are you going down to the windows tray and right click and disconnecting your Galaxy S before you unplug it?
     
  14. Pinetree09

    Pinetree09 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    40
    Likes Received:
    4
    Nah, but now it's just saying device offline...again
     
  15. Drazzamatazz

    Drazzamatazz Active Member

    Joined:
    May 28, 2010
    Messages:
    25
    Likes Received:
    1
    Noob and Mac user.....do I just follow the directions entering everything into Terminal? Nothing seems to happen when I do that, is there some special script I need or some step I'm missing?
    Thanks for the help.
     
  16. Drazzamatazz

    Drazzamatazz Active Member

    Joined:
    May 28, 2010
    Messages:
    25
    Likes Received:
    1
    Logging on to a PC, upon entering "cd to SDK install directory" I get "The system cannot find the path specificed."
    I know I have SDK as its open....but did I somehow install it wrong?
     
  17. Darkeligos

    Darkeligos Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    134
    Likes Received:
    7
    For anyone having trouble with devices being offline or not working, try running this first and then retry your command.

    Code (Text):
    1. adb kill-server

    You have to learn how to use the cd command if you are typing that out word for word. Supposed my tools folder is in C:\users\Darkeligos\SDK\tools -- I could either do one of the two:

    Code (Text):
    1. cd C:\users\Darkeligos\SDK\tools
    2.  
    3. or
    4.  
    5. cd \
    6. cd users
    7. cd Darkeligos
    8. cd SDK
    9. cd tools
     
  18. Bedub

    Bedub New Member

    Joined:
    Jul 20, 2010
    Messages:
    1
    Likes Received:
    0
    My phone is doing this too. I can get to the recovery console, but no matter the case it seems to stop loading at the point where the Galaxy S logo is displayed.

    When I try the adb shell it now tells me I have no devices attached.

    Any ideas on how to get it going again?
     
  19. sonicanatidae

    sonicanatidae Well-Known Member

    Joined:
    Jul 16, 2010
    Messages:
    87
    Likes Received:
    14
  20. kbarsi

    kbarsi New Member

    Joined:
    Jul 20, 2010
    Messages:
    4
    Likes Received:
    0
    I've got to be missing something. I can't find:

    "Scroll down to ID 6, "install_non_market_apps". Double-click."

    I don't see anything called ID 6 under Tables/secure. I only see _id, name, and value. Am I in the wrong section?
     
  21. kbarsi

    kbarsi New Member

    Joined:
    Jul 20, 2010
    Messages:
    4
    Likes Received:
    0
    Never mind. I didn't see the tabs.
     
  22. Tadi

    Tadi New Member

    Joined:
    Jul 20, 2010
    Messages:
    1
    Likes Received:
    0
    I have tried reinstalling BusyBox numerous times and I am still receiving "cp: not found". Does anyone have a fix or maybe an alternative?

    Edit: My phone is in debug mode
     
  23. maerlim

    maerlim Well-Known Member This Topic's Starter

    Joined:
    Mar 9, 2010
    Messages:
    490
    Likes Received:
    121
    Maybe if you copy-paste what you're doing into a post it'll help us help you. Start with where you cd into your android sdk tools directory and copy-paste everything in the cmd window.
     
  24. YellowGT0

    YellowGT0 Well-Known Member

    Joined:
    Jul 17, 2010
    Messages:
    114
    Likes Received:
    22
    You have to install it on the phone not on the computer. That was the mistake I made.
     
  25. coldkiller

    coldkiller Member

    Joined:
    Jul 20, 2010
    Messages:
    5
    Likes Received:
    0
    Ok.... got the phone rooted and db set to 1. No how do i install a app for example a game. I downloaded a zip file. Do I put in on the SD card and run a app to install? Which app???

    Thanks for all who have contributed to these fourms!!!!!
     

Share This Page

Loading...