Tips How to Enable Sideloading of Apps on Captivate

Discussion in 'Android Devices' started by maerlim, Jul 17, 2010.

  1. sdelliott31

    sdelliott31 Active Member
    16

    Jul 18, 2010
    37
    3
    16
    Computer Repair
    Bradley, Illinois
    Ok, I'll be the idiot, but otherwise I won't learn. I have the drivers for samsung installed, am rooted, installed busy box with restated I am rooted. I am linked as mounted mas storage device from phone to pc. I, on my pc, have my cmd open and pointed to the tools directory. I am in the c: command prompt by the way. I typed in adb shell and it came up with device not found. I entered su after this and it stated not a recognizable command. So, I'm stuck I don't understand the complete premise of what we are trying to change to get the third party software to load, so I am asking for help. I'm surprised I have gotten this far but want to finish. Thanks,
     

    Advertisement

  2. narcoden

    narcoden Member
    16

    Jul 19, 2010
    17
    2
    16
    sdelliott31 and beertha like this.
  3. gwaki

    gwaki New Member
    5

    Jul 19, 2010
    2
    0
    5
  4. sdelliott31

    sdelliott31 Active Member
    16

    Jul 18, 2010
    37
    3
    16
    Computer Repair
    Bradley, Illinois
    Ok, I used the Sideload wonder machine and picked my.apk file and this worked perfectly. Not the most convenient, but it installed and ran like a Flash. Thank You for this.
     
  5. rajendra82

    rajendra82 Well-Known Member
    38

    Jul 16, 2010
    172
    20
    38
    Civil Engineer
    Atlanta, Georgia
    I am on Windows XP SP3 32 bit, and this command:

    adb pull /sdcard/settings.db %userprofile%\desktop

    does nothing. All I get with that is the ADB help output. The settings.db file that was created never gets pulled to desktop.

    So I also changed it to:
    adb pull /sdcard/settings.db

    and the file gets successfully pulled to the sdk tools directory. I think it's because on my OS:
    %userprofile% = C:\Documents and Settings\<username>
    and the command adb can't handle the spaces in the variable.

    Therefore I also changed this:
    adb push %userprofile%\desktop\settings.db /sdcard
    to this:
    adb push settings.db /sdcard

    Everything is fine so far, except Firefox wont let go of the stupid settings.db file in the sdk tools directory for me to delete it.

    P.S. - The SDK install asked me to append %path% with the sdk/tools location as part of the installation. If you followed that step, there is no need to do change directories to there first or to worry about %userprofile% containing spaces. It'd be better to change directories over to your preferred location to store settings.db and invoke adb from there.
     
    beertha likes this.
  6. Does AT&T block certain apps in the Android Market?
     
  7. beertha

    beertha Active Member
    16

    Jul 10, 2010
    38
    6
    16
    Thanks for your info because I had the same problem!
     
  8. sdelliott31

    sdelliott31 Active Member
    16

    Jul 18, 2010
    37
    3
    16
    Computer Repair
    Bradley, Illinois
    Hi, I have solved my problem for the most part. I was just curious, when you read the original instructions there is a part that says download sql lite and go to firefox tools and change settings. Is this on the PC, or through android and then tools on firefox Captivate. If it is this, I cannot find tools for firefox in the browser. I'm sure something else is wrong. Can someone help? Thanks,
     
  9. Pinetree09

    Pinetree09 Active Member
    16

    Jul 18, 2010
    40
    4
    16
    Texas
    I tried using it but I still got "device offline" :(
     
  10. acandia007

    acandia007 Member
    15

    Jul 16, 2010
    14
    0
    15
    it worked for me!!!
     
  11. Pinetree09

    Pinetree09 Active Member
    16

    Jul 18, 2010
    40
    4
    16
    Texas
    Edit: nevermind
     
  12. rajendra82

    rajendra82 Well-Known Member
    38

    Jul 16, 2010
    172
    20
    38
    Civil Engineer
    Atlanta, Georgia
    When you load the phone with USB debugging on, a red triangle should show up in the notification bar, and if you installed the right drivers, the SDK tools should find the device when invoked. Other than the red triangle icon on the phone, nothing else typically happens unless you run a command on the computer.
     
  13. Pinetree09

    Pinetree09 Active Member
    16

    Jul 18, 2010
    40
    4
    16
    Texas
    Yay, I finally got it to work...on another computer, lol


    I guess I didn't install something right on my computer, oh well, I'll figure it out eventually
     
  14. aperture

    aperture New Member
    5

    Jul 22, 2010
    4
    0
    5
    Nevermind. I'm not as stupid as I thought I was.
     
  15. tman42

    tman42 Member
    15

    Jul 14, 2010
    20
    0
    15
    Thank you Maerlin for taking the time to figure this out. I am now free to download as I please, and the first program was kind of a cool text while seeing what's in front of you program called RoadSMS the first of many to come thanks again maerlin. I just wanted to add that after you have your phone rooted, you can do all of this from your phone. I purchased two very good apps, Root Explorer and SQLite Editor (Edit, make sure to give them both superuser permission). I used Root explorer and followed your directions above and copied the file to my sd card(just paste to main card directory). Now I had a few issues with not seeing anything on my card at first but I went through everything a couple times and then it showed up. Then I opened up SQLite on my phone and click your settings on your phone and it gives you the option to browse SD card, I scrolled all the way to the bottom and found the settings.db file (which I renamed the original and placed on my SD card as setting-back.db), select the file you are going to edit. Then select "Secure" and and press and hold line 6 (install_non_market_apps) and choose "Edit Record" simple replace the value "0" with "1" and hit save. Now go back to your Root Explorer program on your phone and go into the original directory and if you haven't renamed the original file you may want to, then move it to your SD card or wherever you choose. Now move the newly edited file from your SD card to that same directory you just moved the original from. Reboot (shut off and turn back on phone) and viola You should have what you want. Thanks again for posting the original instructions and I hope I didn't dumb it up too much for you technical guys, I know I am new to the Android and I just wanted to make it as simple as possible for others. Hope this helped anyone needing another simple way to do this.
     
  16. sonicanatidae

    sonicanatidae Well-Known Member
    18

    Jul 16, 2010
    87
    14
    18
    From: Workaround for Fixing 'Unsupported Sources' - Page 2 - xda-developers


    Additional Information and why you shouldnt download and install someone else's settings.db.




     
  17. sonicanatidae

    sonicanatidae Well-Known Member
    18

    Jul 16, 2010
    87
    14
    18
    Question about the method 1st posted:

    I get so far, then it tells me permission denied when I su, but
    the phone is rooted.. I have superuser on it and 3 apps that require root.
    After I type su.. I wait about 10 secs and it returns:

    Permission Denied


    What did I miss?

    Root method was using the update.zip file..
     
  18. Pinetree09

    Pinetree09 Active Member
    16

    Jul 18, 2010
    40
    4
    16
    Texas
    There will be a Superuser permissions popup on your phone, you'll need to hit allow
     
  19. sonicanatidae

    sonicanatidae Well-Known Member
    18

    Jul 16, 2010
    87
    14
    18
    Yup.. that was it..

    Another +1 for this method working..
     
  20. YellowGT0

    YellowGT0 Well-Known Member
    38

    Jul 17, 2010
    114
    22
    38
    Ok I read over on XDA that

    chown system.sdcard_rw /sdcard/settings.db /dbdata/databases/com.andorid.providers.settings

    Is better then CHmod because it leaves settings.db a little more secure I have not tried it but if anyone is worried about settings.db being any less secure you can try it.
     
  21. Aerimus

    Aerimus Well-Known Member
    56

    Nov 6, 2009
    166
    7
    56
    Upstate NY
    This may seem obvious, but this is my first android experience and I did not realize that I had to cancel usb storage in the notification area, and not sure I could have figured it out without this post. It might be a good idea to add this to the main guide at the beginning of the thread. Thanks a lot for the hard work on this.
     
  22. martincarroll84

    6

    Jul 23, 2010
    7
    1
    6
    I was having issues getting the USB driver to work so SDK was not recognizing the Device. However i was able to get this accomplished in a different way. Here's what I did to get rid of the gay message saying i could only install market apps:

    First I rooted my device by downloading the captivate recovery file and renaming it to update.zip and coppied it to my removalble storage card and booted into the recovery and selected
     
  23. tman42

    tman42 Member
    15

    Jul 14, 2010
    20
    0
    15
    That's exactly what I did, tried to explain it above but checked it today and saw that it was very late when I wrote it LOL. You just saved me from going back over it and making it easier to read. I was amazed at how easy this was to do and like you mentioned for the price of only $6 bucks.
     
  24. kbrown17

    kbrown17 Active Member
    16

    Jul 22, 2010
    33
    3
    16
    I keep getting a error message saying FAILURE [INSTALL_FAILED_ALREADY_EXISTS]

    what am i doing wrong
     

Share This Page

Loading...