How to Flash 5.9.905 GB, 6.7.246 ICS or 98.72.22 JB with Rsdlite


  1. OutOfPhase

    OutOfPhase Premium Member Guide

    MAKE SURE YOUR BATTERY IS AT LEAST 50% BEFORE TRYING THIS.



    This will wipe everything but your external sd-card.

    If you are on GB or a ICS leak 6.7.232 or less you can flash any file in this thread. If you are on ICS 6.7.246 or any leak from 6.7.235 to 6.7.247 you can only flash 6.7.246, the modified 6.7.246, 98.72.22, or the modified 98.72.22. If you are on JB 98.72.22 you can only flash 98.72.22 or the modified 98.72.22 files

    Downloads

    Moto Helper device manager

    Motorola USB drivers v5.7.0- 32bit

    Motorola USB drivers v5.7.0- 64bit

    RSDLite v5.7

    5.9.905 GB (Full Version) (md5 sum 860ddf17ac34d0103a99ff42eed2c050)

    Modified 5.9.905 GB (md5 sum f7c66ab368f1be30a1b77ba157b96347) This will remove root but you will have to uninstall Super user app before flashing. This will keep your data

    6.7.246 FXZ ICS (Full Version)(md5 sum A72C1C1AB6D5717611FE12D63723E9C4)

    Modified 6.7.246 FXZ ICS(md5 sum 02CAC34F9FE419E4D5ED0C018A1B4741)This will remove root but you will have to uninstall Super user app before flashing. This will keep your data

    98.72.22 FXZ JB (Full Version)(md5 sum 1481AC6035682B732F76A621A36A9153)

    Modified 98.72.22 FXZ JB(md5 sum 4723af4ba2e5d0710f091f2279b62927) This will remove root but you will have to uninstall Super user app before flashing. This will keep your data.

    If you tried the 98.72.22 fxz and received a OEM_fb_mode error use this file here it is the full 98.72.22 with the 2 fb_mode lines removed.

    Thank you Timmy10Shoes for the modified xml.

    Free md5 sum checker

    Use the back USB ports on a desktop. On a laptop it does not matter. Use usb 2.0 ports as there are issues with usb 3.0 and rsdlite.


    Everything you download will be to your computer desktop.
    1. Download one of the FXZ files. Use the md5 sum checker to make sure the sums match and the file is not corrupt.
    2. Download Motorola drivers to your desktop or use Moto helper device manager.
    3. When it is done downloading click on it and install
    4. download RSDLite 5.7 to your desktop.
    5. When it is done downloading click on it and install
    6. start RSDLite 5.7 picture
    7. turn phone off
    8. press and hold the volume down and power button at the same time on the phone. The fastboot menu will appear.
    9. plug your bionic into your computer with the cable that came with the phone.
    10. Click on RSDLite, you should see your phone listed. picture
    11. click on your phone to highlight.
    12. click on "..." symbol. picture
    13. navigate to the 5.9.905 or 6.7.246 file location and select that file. picture
    14. on the next pop up select uncompress and start flashing. picture
    15. let the program run until your phone reboots. rsdlite screen will say 22/22 complete.
    16. when the green android is up you are done.
    17. click on the green man and log in with your google account.

    Some time RSDLite does not say complete but the android will show up on your phone. It is complete don't worry about the warnings.

    Good Luck

    Make sure your laptop battery is charged or you have a backup power supply for your desktop. Just to be safe.


    If RSDLite is giving you issues there is a manual way to flash the files using fastboot.

    download this file and unzip. moto-fastboot

    unzip your 5.9.905, 6.7.246 or 98.72.22 fxz file (the one you downloaded from above) to the same location as moto-fastboot

    Put your phone into fastboot mode by press and hold the volume down and power button at the same time on the phone. The fastboot menu will appear. plug your phone into your computer.

    navigate in windows to the location you have everything unzipped to. click on the file symbol in the top left corner and when the bar becomes highlighted type cmd and enter if you have win 7. A comand prompt will come up. If not go to start and type cmd and hit enter. when the prompt comes up type cd c:\location of file with moto-fastboot and fxz file unziped

    type and hit enter after each step

    moto-fastboot flash mbm allow-mbmloader-flashing-mbm.bin
    moto-fastboot reboot-bootloader
    moto-fastboot flash mbmloader mbmloader.bin
    moto-fastboot flash mbm mbm.bin
    moto-fastboot reboot-bootloader
    moto-fastboot flash cdt.bin cdt.bin
    moto-fastboot erase cache
    moto-fastboot erase userdata
    moto-fastboot flash lbl lbl
    moto-fastboot flash ebr ebr
    moto-fastboot flash mbr mbr
    moto-fastboot flash devtree device_tree.bin
    moto-fastboot flash system system.img
    moto-fastboot flash boot boot.img
    moto-fastboot flash recovery recovery.img
    moto-fastboot flash cdrom cdrom
    moto-fastboot flash preinstall preinstall.img
    moto-fastboot flash webtop grfs.img (skip this step if you are using a JB fxz)
    moto-fastboot flash radio radio.img
    moto-fastboot reboot

    you should be on 5.9.905, 6.7.246 or 98.72.22
    all your data except on your sd-ext will be erased. If you want to keep your data skip the step for erase userdata.

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I'm assuming that you plan to edit this with pictures and links, right? :p
  3. OutOfPhase

    OutOfPhase Premium Member Guide


    The links for the pictures are not showing up? They do for me. I will fix this when I get to my laptop.

    Add all links for downloads.
  4. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    When I first typed a reply there were 0 links.
  5. marine one

    marine one Well-Known Member

    Does this method wipe apps &/or data from the device?
  6. OutOfPhase

    OutOfPhase Premium Member Guide

    Yes. It wipes everything but your external sd card. if you backup with TIBU or something similar you can be back up in running fairly quick.

    when your are done you can root using tehsusenoh modified releashed and forever root file here. R3l3AS3DRoot_Windows_V2.1 - modded zergRush - Minus.com Option 2, root and forever root.
    This works with 5.5.893
  7. zoxxo

    zoxxo Well-Known Member

    The link to RSD Lite appears to be set to private. Is there another source available?
  8. tehsusenoh

    tehsusenoh Well-Known Member

    That's johnlgalt's link, I'll PM him.
    twj498 likes this.
  9. Neslot35

    Neslot35 Active Member

    zoxxo likes this.
  10. tehsusenoh

    tehsusenoh Well-Known Member

    I'll add it in.

    The reasons the link is down is because the hosting was being paid for in full by johnlgalt.

    So far, from all of the files he's hosted, he's accumulated 700GB of download in total. That's how much his links have been downloaded not only here, but everywhere else too. Pretty much every other guide out there is pulled from the links him and I used in the original guides.
  11. Neslot35

    Neslot35 Active Member

    followed the instructions, when it rebooted to go to the green droid setup, it went back into the flash recovery boot. I rebooted it and chose normal boot. It came back up with the Eclipse boot logo thing (the whole reason I tried this was to remove the ROM), and got stuck in a boot loop. Rebooted and did the recovery boot, formatted data/cache, formatted cache, rebooted and now i'm on the fastboot screen again.


    figured it out, have to extract the files with RSD Lite then click the start button to run the flash, i'm a RSD Lite noob ;)
  12. OutOfPhase

    OutOfPhase Premium Member Guide

    Added steps for coming from 5.9.901
  13. al23

    al23 Well-Known Member

    These have not worked for me. I'm on 5.9.901. Phone bricked. RSD lite with the edit for 901 has not worked. I think I have to bite the bullet and get another bionic. I wonder what the selling price is on ebay for a bricked phone.....
  14. OutOfPhase

    OutOfPhase Premium Member Guide

    al23 likes this.
  15. al23

    al23 Well-Known Member


    DUDE!!!!! I was thisclose to buying another bionic! I tried the first option on rootzwiki. It worked! It helped that rsd lite started recognizing the phone in fastboot (it wasn't doing so for most of yesterday). I was skeptical throughout the process. With each step, I thought "okay that worked, but it will fail at the next step." Even as the phone rebooted, I thought "I froze here yesterday, it will today." Can you tell yesterday was a long day :)?

    Thanks so much. As for me. Lesson learnt. I won't be bricking this baby again. I will root again. But no custom roms for me...There 's nothing wrong with roms, I just think I screwed up trying to go back to the stock motoblur from eclipse.
  16. al23

    al23 Well-Known Member

    Daamnit damnit damnit. I tried to take the update to 5.5.886 and i am back to the bricked phone. damnit!
  17. OutOfPhase

    OutOfPhase Premium Member Guide

    Are you using a desktop or laptop with rsdlite?
  18. al23

    al23 Well-Known Member


    Laptop. But problem solved. I had received a cdt error and the phone was in fastboot after I took the 5.5.893 update. But i downloaded a cdt fix and extracted. I was then able to boot up without a problem. all my aps were there and the 893 update took.

    For the time being I will do nothing to the phone. No root. nothing. Let the phone settle for a bit after all I put it (and myself) through. The only thing I wonder is, am I going to have this problem each time I update the phone?
  19. OutOfPhase

    OutOfPhase Premium Member Guide

    You hopefully should not.
  20. Thom

    Thom Premium Guide Member Guide

    No you're not.

    Everyone has their head handed to them and they learn something very important from it. Assume it is going to screw up before you do it and have the recovery worked out. If it then does screw up you're ready.

    Great going ... you made it back.

    ... Thom
  21. al23

    al23 Well-Known Member

    Thanks. I have had my head handed to me enough. That's a good tip: assume things will be screwed up and prepare for that.
  22. envy5000

    envy5000 Member

    ... coming from the leaked .901 the fxd wiped my MEID/IMEI what do I do?
    Got 'Failed Flashing process. 6/22 cdt.bin -> phone returned fail.
  23. OutOfPhase

    OutOfPhase Premium Member Guide


    Where are you are now
  24. Jeffery

    Jeffery Well-Known Member


    I am having the same issue and I am stuck too. Anyone???

    EDIT: I have safestrap installed and was able to get back into Eclipse 2.1RC1.

    1. Could safestrap have anything to do with this issue?
    2. I am getting my phone exchanged (phone speaker is broke), so I need to get back to stock quickly.
    3. Should I just unroot and leave the .901 radio?
  25. OutOfPhase

    OutOfPhase Premium Member Guide

    Go here and follow the steps. unbrick your bionic

    I would try and at least get back to stock either 5.5.893 or 5.5.901
    Jeffery likes this.

Share This Page