How to Flash 5.9.905 GB, 6.7.246 ICS or 98.72.22 JB with Rsdlite


Last Updated:

  1. SFWB

    SFWB Well-Known Member

    Worked like a charm for me to go from 5.7.893 to 5.9.902. Much appreciated.

    Advertisement
  2. OutOfPhase

    OutOfPhase Premium Member Guide

    Any of the Mods or guides want to sticky this so users have this at the top and don't create extra threads about looking for files or how to use rsdlite.
  3. OutOfPhase

    OutOfPhase Premium Member Guide

    Links are down for 24 hours. 250gb downloaded in one day again so they froze all my links.
  4. nstallion

    nstallion Well-Known Member

    Anyone got a mirror link for 5.9.902? My headphone jack just broke and I was going to Verizon later today anyway.

    EDIT:

    Also, I am on a 5.7.894 based ROM. Can I just flash the 5.9.902 FXZ or am I gonna have to do something else first? I've looked around (xda, rootzwiki) and there's no clear information on where to go from 5.7.894. I have MotoRooter but I don't want to try any of those options right now without knowing if my phone will still be functional after.
  5. OutOfPhase

    OutOfPhase Premium Member Guide


    Yes you can flash 5.9.902 right over 5.7.894.
  6. bink1r

    bink1r New Member

    Does anyone have the following error? "Please check input file. Either ml format is wrong or image files associated with it are missing". I get with every package that I try to unzip in RSD Lite.

    Anyone?
  7. mevans336

    mevans336 Member

    Yes, I am having this exact same problem also. I can't find an answer for it anywhere on the internet.
  8. OutOfPhase

    OutOfPhase Premium Member Guide

    What file are you downloading and from where? Are you using rsdlite to unzip it?
  9. mevans336

    mevans336 Member

    I've tried 4 different versions of the full .902 FXZ file. Each one verified with the MD5.

    I'm using RSD Lite 5.7 on Windows 7 x64 with the latest Moto 64-bit drivers installed.

    That error pops up every time RSD tries to start the flash. For kicks, I tried an .893 FXZ and it failed with the exact same error.

    I did a power button + volume up/down factory restore and tried again, same error. I also tried in APRestore mode. :confused:
  10. eyedea

    eyedea Well-Known Member

    I don't think you have the 902 fxz unzipped. Also, all 18 files need to be in 1 folder on your desktop.
    In addition, use the back USB ports on your pc.

    If you continue to have issues, PM me. I can help you further if needed.
  11. mevans336

    mevans336 Member

    RSD Lite unzips it for you, however, I did unzip it and manually choose the .xml file. Same error. It fails right after "verifying" system.img and trying to start the flash.

    It was in the back USB ports, using the Motorola official cable, etc.

    I think it has something to do with the fact I used Bionic Recovery Bootstrap at one point in the past to flash an ICS ROM. I've restored this same Bionic with an FXZ file before and that is the only major thing I can think of that I've done since that might cause this error.

    I have a Macbook I can try it on, but my primary goal was just to do a factory restore (the phone hangs at "Unmounting internal storage" when trying to do it from within the OS) which I was able to do by using the Power + Volume Up/Down method.

    I do appreciate your willingness to help however!
  12. OutOfPhase

    OutOfPhase Premium Member Guide

    Using bootstrap or safestrap does not matter when it comes to flashing with rsdlite it just looks at the kernel and radio and makes sure that you are not downgrading. I would remove your current RSDLite and download the newest version which is 5.7 and try it again.
  13. eyedea

    eyedea Well-Known Member

    Rsdlite does not unzip the fxz. Use this method to unzip: Microsoft Corporation
    Rsdlite will only work on a mac if you are using windows.
    Having use bootstrap or safestrap does not matter.
    Put the unzipped 902 fxz on desktop in 1 folder. The 1 folder should have 18 unzipped files.
  14. OutOfPhase

    OutOfPhase Premium Member Guide

    I am not trying to be rude but is this not RSDLite unzipping (uncompressing) the file?
    Image
  15. eyedea

    eyedea Well-Known Member

    Why..yes it is. I always unzip first then use start button, but your method works too. Thanks!
  16. OutOfPhase

    OutOfPhase Premium Member Guide

    Added stock modified 5.9.902 fxz and custom rom modified 5.9.902 fxz files
  17. tamivroma

    tamivroma Well-Known Member

    I was about to give up....but read this whole thread and very impressed with dfib and Thom something....makes me dare to ask.

    I rooted my Droid Bionic using this Method I left stock Rom-only wanted to use hot spot. It was first time ever rooting a phone and its worked fine. :) I didn't know to do a back-up that I read about here.

    Now I want to un-root to sell it. I tried using this Method Which was to down load RSDlite but I immediately got stuck because I couldn't get the drivers to show up in device manager. I think its because I downloaded the wrong drivers. My bionic system version is 5.5.893 and I can't find those drivers. I thought I was onto something in the beginning of this thread because it said drivers for 5.5.893 but the link didn't work.

    I am using a laptop running windows 7, 64 bit.

    I am a complete noob on this but want to learn.

    Thanks so much!
  18. OutOfPhase

    OutOfPhase Premium Member Guide

  19. tamivroma

    tamivroma Well-Known Member

    This is going to show you what a noob I am ..... what does it mean to flash it? Is there a thread you can reference with complete noob instructions.

    Thank you, thank you!!!!!


    Ha--found the answer thanks to moderator Scary Alien "Flashing is the process of over-writing your internal memory (with things like alternate Android operating systems)."

    I love AndroidForums.com ..... incredibly knowledgeable people that are nice to noobs!!!
  20. tamivroma

    tamivroma Well-Known Member


    Says I need to login in or sign up - did sign up-said it was sending confirmation email -- must take a while to send because I haven't gotten it. Will check in am to see if it is there.
  21. eyedea

    eyedea Well-Known Member

  22. OutOfPhase

    OutOfPhase Premium Member Guide

    flashing is the process described in the beginning of this thread
  23. OutOfPhase

    OutOfPhase Premium Member Guide

    all links are back up with a new server.
  24. tamivroma

    tamivroma Well-Known Member

    Thanks so much! You rock! I got it!!!!! Worked perfectly!
  25. coyoteloco55

    coyoteloco55 New Member

    dfib thank you for the post with instructions and links. Timmy10Shoes, I bow down to your genius! I had turned my droid into a skipping stone until I found your post. Was getting ready to let her fly and buy a new one.


    --------------------------------------------------------------------------

    Life is Great! It's just the people in it that screw it up!

Share This Page