How to Flash the Huawei Ascend to Stock


Last Updated:

  1. Tokenpoke

    Tokenpoke Well-Known Member

    Joined:
    Feb 10, 2011
    Messages:
    3,110
    Likes Received:
    1,155
    look for an application that opens .7z files... i'm trying it on my mac.

    hold on.

    ok, got it... yeah, you need a new unzipper. hold on again...

    use this. i just put it on my pc, works. http://www.7-zip.org/
     

    Advertisement
  2. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    I see the screen but it says update failed.....

    Its flashing and and it says Firmware Update Step 1/2 unpacking

    then a triangle saying update failed
     
  3. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Okay I put the 5 files on my sd card. I booted into clockwork mod and I pressed back and restore but there is no option for "nand restore". So I pressed "restore" and it says no files are found.

    ?????
     
  4. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Im having the same problem.

    I copy and pasted that folder name but it doesnt let you post slashes.

    so i just named it nandroid and still nothing happened.

    :confused::mad:
     
  5. nuttmeg

    nuttmeg Well-Known Member

    Joined:
    Feb 9, 2011
    Messages:
    7,331
    Likes Received:
    2,525
    use this method instead and after you finish you will have to install CWM again.

    Fastboot Method
    (Note:This method will work even if the phone will not start or go into recovery)



    Download the Following Package:
    MetroPCSStock Recovery Package with Scripts
    678041208774eab0aed1005f287d71ab MetroStockRecover.7z

    1)Attach phone to USB
    2)Power Phone Off
    3)Enter Fastboot (End Call + Volume Down - while phone turns on)
    4)Run script relevant to your OS
    metroPCSStock-linux.sh
    metroPCSStock-mac.sh
    metroPCSStock-windows.bat
    5) Your phone will automatically reboot
     
  6. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Thx for trying to help nutmeg. When the black screen flashes on my comp does that mean I ran the file correctly?
     
  7. nuttmeg

    nuttmeg Well-Known Member

    Joined:
    Feb 9, 2011
    Messages:
    7,331
    Likes Received:
    2,525

    yes, did you click metroPCSStock-windows.bat? btw are you running windows or mac?
     
  8. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Yeah thats the one I clicked. Im running windows.
     
  9. nuttmeg

    nuttmeg Well-Known Member

    Joined:
    Feb 9, 2011
    Messages:
    7,331
    Likes Received:
    2,525

    did you get it to work?
     
  10. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Been sitting at this white screen still.
     
  11. nuttmeg

    nuttmeg Well-Known Member

    Joined:
    Feb 9, 2011
    Messages:
    7,331
    Likes Received:
    2,525
    is the black screen still on?
     
  12. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Naw it flashed and dissapeared.
     
  13. nuttmeg

    nuttmeg Well-Known Member

    Joined:
    Feb 9, 2011
    Messages:
    7,331
    Likes Received:
    2,525

    pull your battery for 10 sec put battery back in and connect the usb cable and run metroPCSStock-windows. did extract the whole folder to your desktop?

    if you have yahoo, add nutt0606@yahoo.com
     
  14. Burner

    Burner Well-Known Member

    Joined:
    Jan 7, 2011
    Messages:
    51
    Likes Received:
    5
    Yes I extracted it and clicked it again from the desktop. It blinked the black screen.

    Just added you.
     
  15. AndroidFan420

    AndroidFan420 Well-Known Member

    Joined:
    Feb 19, 2011
    Messages:
    160
    Likes Received:
    11
    i was trying to see what v of clockwork i had after flashing back to stock from Icarus so i can try 2.2 it came up with a screen at the top it says android system recovery <2e> on a black background with blue letters
    then android system recovery utility

    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition
    is this normal?

    and no matter what i click on it goes right back to reboot system now

    and the other 3 buttons go to a screen that says firmware update 1/2

    status bar

    and update failed whats happening?
     
  16. Tokenpoke

    Tokenpoke Well-Known Member

    Joined:
    Feb 10, 2011
    Messages:
    3,110
    Likes Received:
    1,155
    you didn't flash cwm 2.1.5.8 right. it should be a black and green theme with Clokwork Mod 2.1.5.8 at the top and bottom in white text.
     
  17. twstde

    twstde Member

    Joined:
    Mar 6, 2011
    Messages:
    20
    Likes Received:
    3
    When I try to flash back to stock
    from the zip file, I always get that the process is aborted. I am running cwm 3.x, should I be running the 2.x cwm? If so, I can't figure out how to successfully flash back to the older cwm. I have Cricket by the way. Thanks!
     
  18. Anduiril

    Anduiril Well-Known Member

    Joined:
    Feb 18, 2011
    Messages:
    426
    Likes Received:
    157
    Try downloading the zip again. You may have gotten a corrupted download.
     
  19. twstde

    twstde Member

    Joined:
    Mar 6, 2011
    Messages:
    20
    Likes Received:
    3

    Ok, I have downloaded two different zip files & it happens on both, but I will re-download, thanks.
     
  20. CuzzinRed

    CuzzinRed New Member

    Joined:
    Mar 30, 2011
    Messages:
    1
    Likes Received:
    0
    I tried the anim mod and my phone kept trying to reboot. I thought my sugar turned to sh*t. I almost took it to Crickets store but reading your guide saved my phone & sanity. Muchos Gracias!!



    ps stay away from Anim mod! you heard it here first like MTV..
     
  21. ladlr23

    ladlr23 Active Member

    Joined:
    Mar 30, 2011
    Messages:
    41
    Likes Received:
    15
    Hi, I was just wondering if I diside to flash back to stock, do I need to unroot the phone?
    Thanks.
     
  22. londonstylz

    londonstylz Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    74
    Likes Received:
    3

    whenever i download the file and try to unzip it says "is not a valid file"
     
  23. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Joined:
    Jan 28, 2011
    Messages:
    8,109
    Likes Received:
    4,938
    Where does it say to unzip it ;)
     
  24. londonstylz

    londonstylz Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    74
    Likes Received:
    3
    it rells you to run the file that corresponds to your o.s. but the files are zipped into one file. has anyone else had this problem.
     
  25. PlayfulGod

    PlayfulGod Well-Known Member Developer

    Joined:
    Jan 28, 2011
    Messages:
    8,109
    Likes Received:
    4,938
    ahh, I've not done the icarus mod, just cm 6 n 7 both from the fone itself.

    If I recall correctly theres a .bat file to run if your on windows.
     

Share This Page

Loading...