How to force install apps to SD card without ROOT!!! A70Tips


Last Updated:

  1. droidxtreme

    droidxtreme Member

    I am trying to port the tutorial to A70. This will not root your phone. Please give feedback if you're successful in doing this.

    This can't & won't harm your phone in any way possible. At the most, the tutorial simply won't work.

    Getting Ready:
    1. First you have to enable USB debugging on your Android device from Settings > Applications > Development > USB debugging.
    2. You need to download and install the latest Android SDK on your computer from http://developer.android.com/sdk/.
    3. Install the latest java SDk if you don't already have one.

    Tutorial:
    1. Extract the package to the folder of your choice [Let's say- C:/android-sdk-windows/], run SDK Manager.exe

    2. Close the command / windows command prompt window that opens.

    3. In the new window, click on Available Packages to the left. Untick all options you are prompted to download except the USB driver option & Android sdk tools revisionx(13 as of now) & android sdk platform-tools revision x(7 as of now) if they are there.
    (Note-If you get an error message at this point, enable “Force https://…” in the Settings. From the list of available packages, select “Usb Driver package”, click on the Install Selected button in the bottom right corner and follow the prompts. )

    4. Connect your phone to your computer with a USB-cable. Your OS will prompt you to install new drivers. Choose to install them from the android-sdk-windows/extras/google/usb_driver folder. Do not mount your device; you only need to plug-in the cable.
    (If you don't see this prompt, download the drivers using this thread
    5. Run command prompt in administrator.
    Type in the following after the ">" at each step (without quotations,and including spaces and capital letters)

    "cd C:\android-sdk-windows\platform-tools"
    "adb devices"
    "adb shell"
    A $ sign should pop up
    "pm setInstallLocation 2"
    Another $ should pop up

    And your done. Close everything, disconnect phone, turn off phone and then turn it back on again

    Note:Now the phone will be set to install all apps you install onto the SD card. However, current apps on phone will mostly still be stored on the internal memory. This process doesn't move these apps for you, it adds the ability. So you must now manually move those already installed on the phone. Install some apps like app2sd etc.

    It’s preferable to install certain apps to the main memory, since it will take a while before the SD card becomes available when you start your phone. Applications installed on the memory card will also be unavailable to the system each time you mount your phone as a disk drive.

    In general, apps that integrate with the Android OS and that often run in the background is better to install on the internal storage, while games and most other applications will have no problem chilling outside on your SD.

    Widgets should essentially be installed on phone memory.

    Update:
    From what I have come to understand (correct me if I am wrong), Each app will store some .odex files on phone memory to speed up the boot process.
    So don't complain that phone memory is getting lesser after each install. Though if you could've installed 40 apps before now maybe 150+ and still have 30-40 mb left. (depends on what kind of apps you install).

    Darktremor's a2sd scripts deodex the apps and COMPLETELY move the apps and cache to sd card but you will need to root and run the scripts.
    Credits: Praky without whose help this tutorial wasn't possible.

    Advertisement
    chestersudha and mastermind1024 like this.
  2. droidxtreme

    droidxtreme Member

    70+ views & nobody tested it??
  3. rahules

    rahules Well-Known Member

    that's because a lot of ppl have rooted their phone..and there are apps in the market that changes the default install location( I saw the option in rom toolbox)....and for non-rooted phones, well maybe they just have not got the adb working....anyways, great find...
  4. sunil90

    sunil90 Well-Known Member

    I use Titanium backup pro to move apps to SD card, although I think there is a way in stock 2.2 to move apps to sd

    Go to Settings->Applications->Manage Applications-> Click on App u want to move -> Select Move to SD

    Simplicity :)
  5. rahules

    rahules Well-Known Member

    not all apps allow to be moved using the default way....the method is for those apps...
  6. sunil90

    sunil90 Well-Known Member

    Yeah but some apps are meant to be installed on phone memory like Launcher pro...
    If you move it to SD and mount ur SD card to ur PC...then Bam!! u gotta restart ur phone to restore LP back ...

    Same with beautiful widgets and some other things
  7. droidxtreme

    droidxtreme Member

    No. there are still some apps that will install on phone memory like some music players & some games. Using this method you can move those apps to sd card. Though if you are rooted, you don't need this method then. Titanium & other apps can't & won't move ALL apps unless you are rooted.
  8. praky

    praky Well-Known Member

    I think people are preferring to root over this method since A70 is easily rootable. This method is a hit on Galaxy Ace forum.
  9. insane_subro

    insane_subro Well-Known Member

  10. droidxtreme

    droidxtreme Member

    If you have adb installed , i won't consider 3 lines in cmd difficult. To each, his own.
  11. mastermind1024

    mastermind1024 Well-Known Member

    Done this before coming to here. Its working great. Now I have lots of internal memory along with many apps....its pretty easy to do n even don't require root...
  12. akshaybz

    akshaybz Well-Known Member

    I was just about to post this tut.
    It help us to set default install location to SD card for apps which means apps by default install to SD card.

    Recommended for sticky!
  13. ajbegley

    ajbegley New Member

    Will this move the Facebook app to the sd card?
  14. 4msumit

    4msumit New Member

    hey i tried every thing i installed z4root it get install on my a70 but i dont know wht the hell is happening i cant move apps to sd kindly suggest i had lost hopes now i think i tried everything available on net
    ?????????????????????????????????????????????????????????????????????:(
  15. varun.chitre15

    varun.chitre15 Well-Known Member Developer


    Use move2sd enabler from market.
    or link2sd if u have partitioned ur card.
    Hit thanks if helped!!!
  16. 4msumit

    4msumit New Member

    Thanks
    It Helped Thanks a lot, :D
    now only thing is that every one knows A70 Has only 160 mb of phone memory so the apps which is installed be default by the company dose`nt move at all even yahoo mail and like inbuilt mail by android dosnt move and these run all time they take lot of space and make my phone slow.
  17. varun.chitre15

    varun.chitre15 Well-Known Member Developer


    hit thanks button if I helped.
    If you want to move those also then use link2sd but you should have partitioned your card for that.ok!!!
    4msumit likes this.
  18. 4msumit

    4msumit New Member

    wil try that :)
  19. chestersudha

    chestersudha New Member

    Thanks so much for the clean step by step instructions..
    Worked perfectly !!
  20. nregati

    nregati New Member

    I tried it on samsung galaxy mini it really works...
    Just follow the steps and you will get what you want...
    Thank a lot...!
  21. i m nt able to do this..pls help..!!!


    C:\Windows\system32>cd C:\android-sdk-windows\platform-

    C:\android-sdk-windows\platform-tools>adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached


    C:\android-sdk-windows\platform-tools>adb devices
    List of devices attached
  22. akshaybz

    akshaybz Well-Known Member

    Setup ADB first (check my signature)
  23. i followed all the steps. still my device is not in the list
  24. m using windows 7 32 bit OS
    is der any problem regarding OS..???
  25. akshaybz

    akshaybz Well-Known Member

    I've tested in that OS, have you turned USB debugging on in your phone?
    Else, you haven't setup correctly

Share This Page