[How-To] Force the Official Android 2.2 Froyo Update for the Motrola Droid (FRG01B | Update 1 of 2)

Last Updated:

  1. RukusRazor

    RukusRazor Member

    I strongly suggest everyone do this using a computer and not try to do this from your droid.

    As far as I've read, Astro won't allow you to move the file to your root SD card directory. I'd find the "from your phone" tutorial on page one of this thread and follow it very closely.

    madness1004 likes this.
  2. bluboy

    bluboy Member

    I followed the instructions listed at the beginning of this thread. Downloaded, did all the required steps in Astro, powered phone off, powered on holding "x" on physical keyboard, exclamation point appeared, volume up/camera button, DOS menu appears, scroll with D pad button to update zip, pressed gold button in D pad, script starts scrolling, finishes, back to DOS menu, highlight "reboot", press gold button in D pad, phone reboots, old system reappears.
  3. RgnKjnVA

    RgnKjnVA Active Member

    First gripe with 2.2 (Verizon's greed re: tethering notwithstanding), when in Car Dock the screen dims after a minute (or configured time) just like it would normally. That's not so cool when you use your Droid as a radio in the car particularly during the day. Also once you're in Car Dock mode you're restricted to the applications they present, hitting Home key takes you back to the Car Home app instead of your Home screen(s). The Car Home Settings should be called Car Home SettING because there's only one actual setting, whether to display the annoying "Don't use your device while driving" warning.
  4. RgnKjnVA

    RgnKjnVA Active Member

    I was able to do this easily with EStrongs File Explorer also Free and they have a good task manager with handy widget as well. Highly recommend
    madness1004 likes this.
  5. kratos

    kratos Back on my throne!!! VIP Member

    Does EStrongs have an app manager? Astro has an app manager that can backup all of your apps (non-private) and I use that more than anything else.

  6. RukusRazor

    RukusRazor Member

    Interesting. Was the "update.zip" file you used approx. 45.2 MB? I know the first time I did it, I had the same result and found that the download I had was only 10.2, and that was why. I'd suggest redownloading using a new source.

    Did you use phone or computer method?
  7. RgnKjnVA

    RgnKjnVA Active Member

    They do! They have quite a full-featured suite of apps. They also have a Security app but I run Lookout so I don't want to muddy the water there.
  8. madness1004

    madness1004 New Member

    I downloaded the Estrongs...same thing. Maybe I have a bad download. It will not let me paste. I am to copy it from the Download folder on my SD card and paste it to the Root Directory correct? I don't have my USB with me to do the computer upload.
  9. RukusRazor

    RukusRazor Member

    Man, I dunno. The 'mounted' USB way was so simple. I'd wait til you've got your USB cable and go that route.
  10. forevermoore

    forevermoore Member

    My Droid seems to be fine after installing the update. I thank you.
  11. bluboy

    bluboy Member

    The file was 45.2 MB. I guess I can try one of the other download sites, although I'm not too optimistic. I used the phone method. I'm going to try the computer method when I get home later. Something's got to work.
  12. YDG

    YDG New Member

    How can I uninstall this?It's making my phone run slow and I can't download Adobe Flash Player 10.1 which is the main reason I downloaded this.
  13. MDboy

    MDboy New Member

    How long should your phone be at the motorola logo screen after installation?? mine has been for about 10 mins and hasnt changed
  14. darkstaff

    darkstaff Member

    Trident, simply awesome. Couldn't wait anymore, not ready to root yet, perfect.
    Probably the most painless update of any device ever, and so far operating flawlessly!
  15. ian.alex

    ian.alex Member

    FYI, I fixed my wifi issues by switching my router out of mixed mode .11b, g,n to mixed mode .11g, n. That fixed the problem of losing wifi (but still being connected) at home. I tried a wifi at my gym that used to work but it drops connection. If anyone else is experiencing the wifi being more finicky in 2.2, that's something to try.
  16. RgnKjnVA

    RgnKjnVA Active Member

    ..of the SD card not the device, correct
    madness1004 likes this.
  17. jrw21221

    jrw21221 New Member

    :confused: Does using this update void any agreement with Verizon? I've read that some updates will void the warrenty. Thanks for any idea you can share.
  18. Dog1

    Dog1 Member

    No it does not. This is an update of the Operating System.
  19. madness1004

    madness1004 New Member

    That was the problem. Wrong root.
  20. bluboy

    bluboy Member

    I think I may have found the problem. It doesn't look like the file is getting to the root directory. I checked Astro after I supposedly loaded the zip file into the root directory. Went to "Home" screen which was labeled "(file folder icon)/sdcard", pressed the "up" button. That took me to a screen labeled "(file folder icon)/" which had a folder named "root". I opened that folder and it took me to a screen labeled "(file folder icon)/root", and on that screen was a message saying "(Directory is empty)". I tried 3 different downloads, same story. Time to try the computer method.
  21. Josefius

    Josefius Member

    Root of the directory does not mean create a folder called root, but to place the .zip file in the base of SD card outside of all folders. i.e the root of C:\

    In computer file systems, the root directory is the first or top-most directory in a hierarchy. It can be likened to the root of a tree — the starting point where all branches originate.

    I think this is were people are getting confused.
  22. 4DAIVI PAI2K5

    4DAIVI PAI2K5 Well-Known Member

    So I just DL the 2.2 updated, I have been running Helix Launcher as my home program. It kept force closing on me, I just so happened to DL launcherPro the other day while i was bored just to see how it was. So I switched to that just now since Helix kept force closing on me.... Now I check the market place an cant find Helix Launcher nor is it on my phone any longer. Hard a co=work check is phone an Helix Launcher was no his market place (He is still running 2.1)... My only thougth was maybe Helix Launcher isnt set up for 2.2 yet an thats why I couldnt find it? Any thoughts?

    Also I cant get flash player 10.1 :(
  23. derekpop

    derekpop New Member


    Not sure if this is covered but I downloaded 2.2 and installed it but I can' use any sites with flash.

    Can anyone help?

  24. k9cop

    k9cop Active Member

    Make sure you have "Unknown Sources" (allow installation of non-market applications) checked and install from your downloads on your SD.
    derekpop likes this.

Share This Page