[How-To] Force the Official Android 2.2 Froyo Update for the Motrola Droid (FRG01B | Update 1 of 2)


Last Updated:

  1. fedrich519

    fedrich519 Active Member

    Amazing!

    Car Dock is finally worth keeping. Goodbye CCH.

    Chrome to Phone blows my mind!!

    Camera has some amazing upgrades.

    Much faster switching between pages and apps.

    Auto update in market saves a lot of time.

    Voice search is improved, still learning some new tricks.

    WOW! WOW! WOW!

    Advertisement
    DarthDefault likes this.
  2. wee_ag

    wee_ag Member

    *sigh* so this isn't working... I've tried downloading the 2.0.1 file it seems like it hangs around 20%. Is there another way to get back to 2.0.1 or 2.1?
  3. skyscraper38

    skyscraper38 Active Member

    Sorry, I didn't know that. I assumed you meant custom ROM

    Firmware Version- 2.1-update1
    Baseband Version- C-01.3E.03P
    Kernel Version- 2.6.29-omap1-g7fa8788
    android-build@apa26 #1
    Build Number- ESE81
  4. vinny3299

    vinny3299 New Member

    will this update work on the Droid x???
  5. Trident

    Trident VIP Member VIP Member

    NO! Do not attempt to flash this to your Droid X!
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Deleting the update.zip won't do you any good, as it is only used when in recovery to put the ROM on your phone.

    It sounds like you are definitely missing an OS right now.

    Yes, ADB reboot recovery works on the DROID - I have used it 100s of times on my phone as I like to use ADB to control my phonewhen doing things like this.

    If you can get into recovery, see if you have a backup you can load (you did make a backup, right?) Also, were you rooted before or not, have you ever useed recovery before or not?

    I highly recommend that you do nto turn on autoupdate for all your apps - b/c you never know when an app will try to autoupdate and get stuck / the phone powers off in the middle of it and you're hosed.

    Update ALL, though, rocks.
    rcaine likes this.
  7. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    That is the right version you should be using to get to 2.2

    Are you rooted at all? How did you get SPRecovery on the phone? Which version of SPRecovery are you using?
  8. ovenman

    ovenman Active Member

    I guess my droid just wont get Froyo :(

    I have downloaded off each server, still get an error each time.

    SPRecovery. 2.1 Rooted - no custom rom.
  9. Sveks

    Sveks Member


    Sadly no i did not make a backup because I was only going to upgrade from 2.1 to 2.2. also my phone was not rooted i was running stock 2.1 can i still use ADB?
  10. skyscraper38

    skyscraper38 Active Member

    I don't remember, I believe I used RSD Lite a while back to root, and then installed custom roms and got tired of it, and went back to stock 2.0.1 updated to 2.1 OTA and I assumed I was fully stock.

    On SPRecovery it says:
    Android System recovery <2e>
    Patched by SirPsychoS (0.99.3b)

    I go to install it and i get an assert failed: apply_patch_check....then a long list of numbers and Error Status (7)
    Installation Aborted
  11. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Umm, try reverting to a stock 2.1 unrooted.

    You may not be able to, it depends upon what is loaded in hte background.

    If you don't already have ADB, at least try the manual method to get into recovery and see if that works. If it does not, you'll need to get RSDLite and an SBF file to put on there.
  12. ovenman

    ovenman Active Member

    Just recovered to my non rooted set up.

    Still get the same error, it's the same error skyscraper gets.
  13. Sveks

    Sveks Member

    If i cant get into the phone OS at all would it be ok to just factory reset? All of my important files are backed up including contacts and photos. My main concern is not bricking my phone.
  14. dragonking37

    dragonking37 Member

    Did the download with the cord and it was much faster than the 3g. So far so good. Everything is looking Froyolicious! Thanks again.:D
    Trident likes this.
  15. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Skyscraper and ovenman, what version of SPR are you running, and how did you get it?

    If either of you have ROM Manager, could you flash to ClockworMod, then in settings allow to erase recovery before installing, then flash back to SPRecovery?
  16. fedrich519

    fedrich519 Active Member


    Excellent point, thanks for the tip. ;)
  17. skyscraper38

    skyscraper38 Active Member

    My guess is we're screwed, and cant get it.
  18. 23skidoo

    23skidoo Member

    This is the same way I upgraded to 2.1 (without incident). This update has proven equally trouble-free.

    Notes:

    + Took ~150 seconds to reboot the first time (to get to the lock screen).
    + Took another ~120 seconds for everything to settle down (widgets to come up, etc.).
    + Settings/About shows Android Version 2.2; Build Number FRG01B.
    + WiFi radio was clearly hamstrung. Showed no bars; connection was SLOWWWW. Disabled and re-enabled WiFi, and it seemed fine.

    - REBOOTED AGAIN -

    + Took ~35 seconds to get to the lock screen.
    + Took ~30 seconds for everything to settle down.
    + WiFi connected just fine.

    Yes, all data was preserved, including my FolderOganizer "labels" (didn't have to re-add any FO icons or anything). All settings seem to have been preserved as well (sync accounts; WiFi connections; brightness; I've checked everything I can think of).

    Now I'm off to test voice quality and download Flash.

    Don't freak; just follow the instructions at the beginning of this thread! :)
  19. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    If you cannot get in, how are you going to do the reset?

    If there is no working OS, you'll need RSDLite to put a working OS on there.
  20. Trident

    Trident VIP Member VIP Member

    Well folks, after hours behind the monitor for the Froyo update, I'm off to cut the grass. I'll be back it a bit.

    Don't break anything while I'm gone.. :p
    rcaine and johnlgalt like this.
  21. alz06

    alz06 Member

    For anyone getting "E:signtature verification failed" it is the result of a bad download. Just discard it and re-download. The good file should be about 45megs. My first download was only 15megs but I didn't know any better and could not understand why it wasn't working. Hope this helps someone.
  22. skyscraper38

    skyscraper38 Active Member

    I downloaded Rom Manager and clicked flash ClockworkMod Recovery and it says "An error occured while attempting to run privileged commands!"

    edit: i have 0.99.3b
  23. BerpaOrcha

    BerpaOrcha Member

    Just wanted to toss this out there and see what you guys think.

    1. Have a MacBookPro.

    2. Box stock un-rooted Droid with 2.1.

    3. Followed Trident's instructions to down load the update.

    4. First used Safari and turned off the preferences to open the download as per Trident's instructions. Then I used Google Chrome for the downloads.

    5. I have since downloaded the update.zip from each of the recommended download sites and I get " E:signtature verification failed, ". I have done multiple downloads from some of the sites but still I can't get past the E:signtature verification failed, message.

    6. May in no way be related to the issue above, but every time I mount the Droid it opens the photo album, wazup wit dat? Could this have anything to do with it....... I don't think so but I don't know.

    Thanks for any help.
  24. Sveks

    Sveks Member

    Sorry I'm new to this, all i can get too is the Android system recovery screen.
    with the 4 options I've tried rebooting the system and i let it sit for almost an hour but it stayed on the white M screen.
  25. Powers9040

    Powers9040 Member

    Thanks so much. Just finished installing and seems to work fine.

Share This Page