1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[How-To] Force the Official Android 2.2 Froyo Update for the Motrola Droid (FRG22D | Update 2 of 2)


  1. StrifeJester

    StrifeJester Well-Known Member

  2. StrifeJester

    StrifeJester Well-Known Member

    I have a rooted phone using easy root. I will be installing the update in a few minutes and will post back what happens.
  3. coach4094

    coach4094 New Member

    Installed without a problem, but Flash does not show up in the marketplace for download.

    Edit: Never mind.... a restart got it to work.
  4. StrifeJester

    StrifeJester Well-Known Member

    The install completed with no errors on the phone. After it rebooted I wanted to test root by launching the Barnacle Wifi Tether. Granted I had to wait about 5 minutes for the phone to boot after the update. This happens every time i get an upgrade my phone takes forever and I have to do a battery pull. Once I was finally into the phone which you can see from the last posts has been over 10 minutes. Barnacle worked, Easy Root said I was still rooted so all looks good. Fired up the terminal app i have and created a new file on the phone root without a hitch.
  5. StrifeJester

    StrifeJester Well-Known Member

    So i have been playing with the phone for a whole 10 minutes since i forced the update and its nice on mine at least the launcher speed seems fixed and all aroudn the phone seems to be performing better. I noticed the market I don't have the long waits to update apps if i am just doing a few and not all of them. And flash is showing up in the market for me. All I did was search for Adobe.
    daveroid and Poloki like this.
  6. Poloki

    Poloki Well-Known Member Contributor

    I had skipped the astro step because I use File Manager, I didn't realize that FM could not handle the zip while astro can. As soon as I nstalled astro, was able to DL and update with no problem.
    I was able to see Flash in Market, just searched for Adobe like StrifeJester said.
  7. StrifeJester

    StrifeJester Well-Known Member

    OK this is interesting I have drocap2, it failed to execute and then I went back to try barnacle and it failed this time. It looks like it does break EasyRoot and unroots. Inside of EasyRoot if you have it when you press menu you can choose force re-root.

    The FRG22D OTA going out for the Droid 1 now will remove your root. We are working on adding support at this time, but it may take a few days, so…if you can wait. If you can’t, you will loss root until then.

    That is from EasyRoots website. Looks like I can't tether again for a few days... Also after a force it was unsuccesful so until they get fix out back to stock.
  8. PARick

    PARick Well-Known Member

    I have tried it about 10 times, after getting the error message ESignature-aborted. I delete the file, redownload it. The first update I sailed right through. Guess I'll try later or waid for the OTA.
  9. StrifeJester

    StrifeJester Well-Known Member

    Did you try the link I posted. I uploaded the file from my computer and then used my phone to download it so I could verify it was all good. There were a few other people who had issues last time too though that no matter what they couldn't get the signature to verify.
  10. Byf619

    Byf619 Member

    I just did the update with no issues. I was able to find the flash player in the market right away. Thanks.
  11. PARick

    PARick Well-Known Member

    11th time is a charm!:) Went right through. Can't wait to see if it helps!
  12. Seven Dogs

    Seven Dogs Well-Known Member

    Awesome instructions everything worked great. Thanks.
  13. hecate

    hecate Member

    FRG22D OTA also broke root on my phone. I ran through this process which worked perfectly, and I'm rooted again.

    It also cured my problem where the recovery partition kept getting overwritten by the stock image.
    publicanimal likes this.
  14. MMAFF1

    MMAFF1 New Member

    Just updated, works perfectly thank you!!!!
    Found flashplayer 10.1 : )
  15. Dog1

    Dog1 Member

    I have done it twice now and when I check the version number, it's still the 02 one.

    I don't know what I'm doing wrong. I'm doing it the same way I did the first one.

    Disregard..3rd time was the charm.
  16. lumba21

    lumba21 New Member

    you guys are awesome thanks again
  17. EZE336

    EZE336 Active Member

    It did not fix the wifi issue for me, but who knows since so many people have many similar and different issues that it might work for you. Just all about chance.
    ian.alex likes this.
  18. huff825

    huff825 Member

    Just like the other manual install, this one also worked flawlessly. Now have Adobe Flash from the market. I have not noticed much else yet though. Generally I am pretty underwhelmed with FROYO. : ( May have been expecting too much. Seems as though the responsiveness of the screen is not as good, speed does not seem that much faster.
  19. Dog1

    Dog1 Member

    My WiFi works fine..as for the battery use, I cannot report on that yet.
  20. publicanimal

    publicanimal Well-Known Member

    +1 Thanks hecate.

    I had originally rooted through easy root but used this method to re-root after losing root with FRG22D update and it worked perfectly.
  21. stormwarz

    stormwarz Member

    odd, my first force update went perfect, this one keeps saying file not found, but i see it on the root and the file update.zip is right under reboot, it keeps failing, tried 11 times since that seemed to be one persons magic number, I downloaded the file on my computer serveral times. Not a rookie here, mine is not rooted, just will not take this update. But I have flash allready, and evertyhing works perfect, and from what everyone says it really added nothing so I guess I will just leave it be. Everything works perfect on the FRg01b
  22. Without this update, any app can gain root access without your permission and without you knowing.
  23. dalinga

    dalinga New Member

    I used to be able to call out using my Jawbone with FG01B. Since I manually updated to FG22D yesterday, the bluetooth call out feature doesnt work. Does anyone else have this problem?:(
  24. motodroid 1

    motodroid 1 New Member

    flash isn't in the market for me either. i tried restarting my phone but it still doesnt appear.
  25. Byf619

    Byf619 Member

    I was experiencing the same thing on my wife's droid after the upgrade. When I opened the market, I hit back until it completely closed the market. After doing this, flash was available on the market.I think on some phones, it will take some time to recognize that you have the update.
Loading...

Share This Page