[HOW TO](gaining root)unlock,downgrade,and achieve s-off with htcDev


  1. scotty85

    scotty85 Guides Guide

  2. mefnj

    mefnj Member

    Scotty,

    again, thanks for your patience.

    hopefully these are the last clarifications i will need for a while

    when i was looking at the online photos of the recovery menu, i didn't see a data/factory reset option at first, only on the hboot screen. my bad.

    i think i will just restore the backup of the stock, unrooted rom, the one i made in Step 3 of your OP

    Q1) when i do hboot>recovery and make a backup of my CURRENT rooted rom, is it going to make a new backup, or overwrite the one i made in Step 3. if it makes a second backup, i assume i will be able to tell them apart so i can restore the one from Step 3

    Q2) my phone continues to give me the alert that the OTA update is ready and will be installed upon restart. i keep pushing the "install later" button. is this process of restoring the Step 3 backup going to trigger the OTA install to try to move forward as the phone resets/restarts? if it will trigger the update, how do i prevent it?

    Q3) will the upgrade i made to the hboot and radio in Step 8 of you OP (using this file PB31IMG-4.08.605.15-hboot-1.07.zip) be intact, or is the restore of the backup going to overwrite them? i think i know the drill if they need to be re-flashed from hboot>recovery...

    Q4) after i (hopefully) successfully restore to my unrooted backup from Step 3 and reboot, all i have to do is one more hboot>recovery and re-flash the superuser.zip that is still on my sd card from the original root process and i will have my root access back, correct?

    a thousand blessings upon your household ;-)
    -m
  3. scotty85

    scotty85 Guides Guide

    hope that helps :)
  4. dreamtomorrow

    dreamtomorrow Member

    I'm having trouble with this first step! argh! I downloaded it, saved the name. I am running Windows 7 HP and if I understood you correctly, it unzips stuff automatically? either away I opened the mini file elsewhere and copied the individual files onto local disk C: but when I type cd c:\miniadb_inc in command prompt an error message comes up The system cannot find path specified.
    Can you tell what I am doing wrong from the message? Thanks!
  5. sdrawkcab25

    sdrawkcab25 Guides Guide

    If you copied the individual files you won't have a c:\miniadb_inc ; right click on an empty space in your c:\ folder, select "new" select "folder" and name it miniadb_inc and move the files there....
    dreamtomorrow likes this.
  6. dreamtomorrow

    dreamtomorrow Member

    This is my command window:
    c:\miniadb_inc>adb devices
    List of devices attached
    HT06THJ01405 device

    c:\miniadb_inc>md5sums mtd0.img

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\miniadb_inc\]
    mtd0.img 34307be744275f1db1dd16af04c37839

    c:\miniadb_inc>md5sums flash_image

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\miniadb_inc\]
    flash_image 0098a7dd6600b55fac34fc6645be5d7a

    c:\miniadb_inc>md5sums PB31IMG.zip

    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - PC-Tools.Net: Tools and utilities for Windows, Unix/Linux, DOS
    Type md5sums -h for help

    [Path] / filename MD5 sum
    -------------------------------------------------------------------------------
    [c:\miniadb_inc\]
    PB31IMG.zip 100% 31bb1611a0fa8197d447c0438426717e

    c:\miniadb_inc>adb push flash_image /data/local/
    728 KB/s (76044 bytes in 0.102s)

    c:\miniadb_inc>adb push mtd0.img /sdcard/
    1155 KB/s (655360 bytes in 0.554s)

    c:\miniadb_inc>adb shell
    $ su
    su
    # cd /data/local
    cd /data/local
    # chmod 0755 /data/local/flash_image
    chmod 0755 /data/local/flash_image
    # cd /data/local
    cd /data/local
    # ./flash_image misc /sdcard/mtd0.img
    ./flash_image misc /sdcard/mtd0.img
    # exit
    exit
    $

    I haven't put CM7 or any other ROM, just straight from the directions on this thread. But the patch was aborted...let me know if you need more details on what I did. Thanks for your help!!:eek:
  7. dreamtomorrow

    dreamtomorrow Member

    I tried this to fix the unsupported radio, but when I tried installing the forever zip from sd card in recover it aborted
  8. mefnj

    mefnj Member

    I successfully restored my backup from Step 3 of OP, and am now with GB 2.3.4

    i also re-installed the superuser.zip. odd, though, i then re-downloaded and installed wifi tether from Google Play and it is not working as well as before i did the restore to GB... not sure if it is just bad 3G (wifi signal detected by ipad from phone is only -5 to -10) or something else...that would be very upsetting, as wifi tether is the main reason i rooted...:(

    i guess i only flashed the PB31IMG-4.08.605.15-hboot-1.07.zip file in Step 8, and did not update radio. the info in Settings>Phone Info>Software is

    Android
    2.3.4
    Baseband
    2.15.00.07.28
    Kernal
    2.6.35.13-g22d3486 etc...
    Build
    4.08.605.15 CL389630
    Software
    4.08.605.15 71ORD

    [assume that is enough info to tell if the radio update is needed]

    so should i also move the PB31IMG-4.08.605.15-radio.zip to the miniadb_inc folder and push it to phone using the procedure in Step 8

    OR

    do i place zip on SD card and used hboot>recovery to flash it? if using recovery, do i need to rename it?

    you have been a great help. look for a little cha-ching in your device fund!

    -m
  9. scotty85

    scotty85 Guides Guide

    looks like you only completed thru step 4. you need to downgrade to run the forever patch.

    was your downgrade successful? are you in 2.2?

    you are quite welcome,glad to help :)
  10. dreamtomorrow

    dreamtomorrow Member

    Yes, except when it rebooted it had factory reset my phone. No biggie, I check to make sure it was software 2.2, it was then I turn off the phone and tried to go to to recovery to flash the forever patch and instead of the recover menu I have a phone with a red triangle with exclamation mark. :-O what happened to my recover menu?? Why mee?

    Also it lost root X_X
  11. mefnj

    mefnj Member

    NOTE: the link to radio zip in my previous post gave me a file that did not have the correct md5 sum... go back to the OP to get the radio, do not use what the link above downloads...


    [You and others have made it very clear that a bad flash of a radio can brick a phone, so i wanted to be very clear about what to do. i pulled this together from multiple Steps in OP... hopefully some other noobs will find this helpful, if it is correct]


    my miniadb_inc process to install new radio will be:


    download PB31IMG-4.08.605.15-radio.zip from OP >> CHECK md5 >> place in C:\miniadb_inc folder

    check that USB debugging is on, hook up phone by usb, charge only

    open command window from windows Start menu

    at C:\Users\your name> prompt type

    cd c:\miniadb_inc-get to minadb_inc directory, should now be at c:\miniadb_inc> prompt

    adb devices-should return serial number of your phone

    adb reboot bootloader boot to fastboot

    fastboot devices check connectivity should return serial number

    fastboot erase cache

    fastboot oem rebootRUU

    fsatboot flash zip zipname.zip
    where zipname.zip will be PB31IMG-4.08.605.15-radio.zip

    fastboot reboot-bootloader

    fastboot reboot
    dreamtomorrow likes this.
  12. dreamtomorrow

    dreamtomorrow Member

    Ok fixed most everything, last steps:
    Was this a typo? In the last step fsatboot flash zip zipname.zip and in the zip name do we paste the code you provided? such as
    fsatboot (or fastboot if that's a typo) flash zip PB31IMG-4.08.605.15-hboot-1.07.zip
    if we used the -4.08.605.15 radio and 1.07 hboot: link you provided.
    We use on or the other right, not both. And it's all done with the command window, not flashing the radio/hboot through recovery on the phone?
  13. scotty85

    scotty85 Guides Guide

    you simply need to follow the steps closely. they will explain how to re-unlock,re-install recovery,and reflash superuser so you can flash the forever patch. at this point,you have only done theu step 4. you must complete steps 5-8 to complete the process.

    what you have experienced is exactly what should have heppened. the downgrade ruu will wipe your data,and replace your recovery with the stock one(the red triangle and ! are what represent the stock recovery).
  14. scotty85

    scotty85 Guides Guide

    yes fsatboot was a typo.

    the zipname is whatever name you chose to use for the zipfile that you put into the miniadb_inc folder.

    you can install thru the command window,or flash in hboot. either is fine,its completely up to you.

    the radio and hboot are different things,so you can(should) choose to update them both :)
  15. scotty85

    scotty85 Guides Guide

    yup,you got it :cool:

    if you want you can use the cmd window to verify the md5 with:
    md5sums filename.extension
    in the case of the radio useing the above filename,
    md5 sums PB31IMG-4.08.605.15-radio.zip

    it should return that same value that your md5sum checker reports.

    last and not least,you do not have to install the radio in this manner. you can rename to PB31IMG and install in hboot if that is easier for you. i personally prefer to install with fastboot as described above,but either way is safe :)
  16. dreamtomorrow

    dreamtomorrow Member

    SO, rooted, s-off and now playing with cm7.1 on my Dinc unless you suggest a different ROM/MOD whatever it's called. Thank you for your help/time to lead the clueless. I wish I'd done this a year ago but fear of the unknown is a great deter-er.
    scotty85 likes this.
  17. scotty85

    scotty85 Guides Guide

    glad you got it! playing with a rooted phone is great fun! :smokingsomb:

    im pretty out of touch with inc roms,but cm7 is a great choice,very stable and fast after this much development. there are cm9 roms out now also,just depends what sort of functionality you need or can live without,as they are in the early stage of development :)
  18. crazy101

    crazy101 New Member

    Killer guide. Just recently decided to root my phone again and if someone can't get it right with this. There is 0 hope. Made account specifically to thank you and 5 star it!!! Think I might be a new member among everyone.
    scotty85 and sdrawkcab25 like this.
  19. scotty85

    scotty85 Guides Guide

    awsome! glad it worked out for you and we will look forward to your input in the forum :cool:
  20. Hi scotty,

    I got this phone here in Germany and didn't know it won't work

    so my collegue tried basically everything here in this thread with different recovery bootloader, different roms, various versions of Radio and HBoot

    but if won't boot. It plays the cyanogen 7 animation but doesn't do anything.

    Do you have any idea what to do?
  21. sdrawkcab25

    sdrawkcab25 Guides Guide


    If it is bootlooping (playing the boot animation over again) it's a sign of a bad ROM flash. Usually doing a complete factory reset and flashing the ROM over again should fix it. Doesn't matter what hboot or radio is being used ( as long as they are relatively recent). There is a small chance of it being hardware related though.
  22. thanks,

    apparently the factory reset (wipe cache etc.) doesn't really work well.
    We also tried various recovery mods.
    Do you think it's a hardware problem?
  23. scotty85

    scotty85 Guides Guide

    i would try and run an ruu. what is the info on your hboot screen?
  24. INCREDIBLE XD SHIP S-OFF
    HBOOT-0.92.0000
    MICROP-0417
    TOUCH PANEL-ATMELC03_16ac
    RADIO-2.15.00.07.28
    Jul 23 2010, 18:06:51
  25. sdrawkcab25

    sdrawkcab25 Guides Guide


    Are you getting errors when doing a factory reset?

Share This Page