[HOW TO](gaining root)unlock,downgrade,and achieve s-off with htcDev


  1. Wiping data...
    Formatting DATADATA:...
    Formatting DATA:...
    Formatting CACHE:...

    Data wipe comlete.
  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    davaidosvidany likes this.
  3. synths

    synths New Member

    Hello,

    I've been following your guide and have finished step 3 and achieved root successfully. I tried following step 4 to downgrade to froyo but started receiving some errors and it was only then that I realised this guide is for an original 'incredible' rather than the 'incredible s' that I've got.

    So my question is - will the guide and attached/linked files work on an incredible s (vivo)?

    The specific errors I'm encountering are..

    Code (Text):
    1. C:\downgrade>adb push flash_image /data/local/
    2. failed to copy 'flash_image' to '/data/local//flash_image': Permission denied
    This I managed to get around by copying it to the sdcard and then using a root file explorer to copy the file to /data/local/ which worked fine.

    and

    Code (Text):
    1. shell@android:/data/local # ./flash_image misc /sdcard/mtd0.img
    2. ./flash_image misc /sdcard/mtd0.img
    3. Segmentation fault
    I'm not sure if I should proceed now? Segmentation fault sounds quite fatal?

    Thanks in advance,

    Dave
  4. INCREDIBLE XD SHIP S-OFF
    HBOOT-0.92.0000
    MICROP-0417
    TOUCH PANEL-ATMELC03_16ac
    RADIO-2.15.10.07.07
  5. scotty85

    scotty85 Guides Guide

    this guide will NOT work for inc s. flash_image is specifically for mtd devices,not emmc.

    a quick search at xda reveals you may want to use this:
    http://forum.xda-developers.com/showthread.php?t=1373697

    or there may be other solutions there as well.

    try a factory reset in hboot,now that the stock recovery is in place. give it as long as 10-15 minutes to finish booting,if you havent been.
    davaidosvidany likes this.
  6. yey!! it boots! wow!!

    but now it gives me error messages

    the process com.htc.bg has stopped unexpectedly. Please try again.
    The process com.google.process.gapps has stopped...
    The process android.process.acore ..
    The application Google Services Framework...

    I can't access the menu or anything
    scotty85 likes this.
  7. now, after a few reboots it doesn't boot anymore. after the DROID sound it just reboots again and again..
    scotty85 likes this.
  8. sdrawkcab25

    sdrawkcab25 Guides Guide


    Doesn't sound good... could definitely be hardware related... the original Incredible I had ended up with similar issues and had to end up getting it replaced.
    scotty85 likes this.
  9. scotty85

    scotty85 Guides Guide

    yup- as sdraw said,it sounds like a hardware issue,or possibly damaged partitions that an ruu is not able to fix :(
  10. danshawna

    danshawna Member

    I have followed directions on my refurb I just got with the latest OTA update. My phone is unlocked, trying to flash superuser, but recovery just sticks at hat with orange circle then i push power button to go back to menu. Recovery does nothing, how to i flash super user with this problem?

    Thanks
  11. scotty85

    scotty85 Guides Guide

    sounds like you are trying to select with the power button.

    from step 3 of the original post:
    ;)
    sdrawkcab25 likes this.
  12. danshawna

    danshawna Member


    You are exactly right!, i was using the wrong button. Thanks. I will continue from this point and keep you posted.
  13. okay thank you anyways.

    too bad here in germany nobody will fix a droid incredible
  14. I have the impression the phone does not completely delete everything.

    for example, after I installed the RUU I got messages like

    Sorry! The application Mp3 Music download (process great.app.luck) has stopped working

    and also also the same for amazon and ARD (a German tv channel)

    not pre-installed apps on a verizon I believe:)


    Is there a way to completely wipe the Droid besides the factory reset in the boot menu??

    That might help to solve the problem.
  15. Loats

    Loats New Member

    I got to step four where you start to push the flash image (adb push flash_image /data/local/) and it comes back with failed to copy 'flash_image' to '/data/local/': is a directory.
    That and if I try to mount /data/ it comes back with mount: mounting /dev/block/mmcblk0p1 on /data failed: Invalid argument.
  16. Loats

    Loats New Member

    nevermind just used an adb explorer and created local under the data folder on my phone to fix it
  17. scotty85

    scotty85 Guides Guide

    flashing the ruu,and doing a factory reset in hboot with the stock recovery in place should both completely wipe the phone. you may have bad blocks or damaged partitions that are preventing data from being properly wiped.

    are you not on a stock rom? not sure why you had to create a local folder and mount data...

    were you successful at the downgrade/s-off?
  18. thanks, I tried that many times.

    is there a way to repair the partitions then?
  19. scotty85

    scotty85 Guides Guide

    depends on if the prollem is hardware related,or just bad blocks in flash memory. bad blocks are fixable,an eris user came up with a zipfile to find and fix bad blocks on the eris handset,wich is also an mtd device. unfortunately,i have no idea how youd determine what your real issue is,and go about finding a way to repair them. :(
  20. funkpod

    funkpod Well-Known Member

    hey guys, any help i can get for the Mac counterpart for the adb part? i can look up the commands, i think, but i don't quite "get" what to do and if i need a different set of files?
  21. danshawna

    danshawna Member

    s-off
    hboot 0.92.000
    radio -2.15.00.07.28

    nothing i flash works, then i get the 3 vibrate bircked phone, i flash recovery back to this. I cant get anything to work. I want rooted gingerbread. How do i get there. Please help.


    Thanks
  22. danshawna

    danshawna Member

    I keep trying and get to white boot screen and it gets stuck. then i have to flash recovery again. cant get gingerbread.
  23. scotty85

    scotty85 Guides Guide

    let me see what i can find out...
    are you trying to get to recovery via power and vol up?
  24. scotty85

    scotty85 Guides Guide

    the files will for the most part be the same. to make adb and fastboot work on a mac,youll need different files,but the exploits and such for the phone are the same.

    this from post #629 of the original root guide:

    i also found this,on xda:
    http://forum.xda-developers.com/showthread.php?t=1917237

    looks like you can use his download instead of the sdk,and then follow his directions and then,basically follow this threads original post steps and commands to htcdev unlock,etc.

    hope that helps :)
Loading...

Share This Page