[HOW TO](gaining root)unlock,downgrade,and achieve s-off with htcDev


Last Updated: 2014-09-29 01:40:16
  1. danshawna

    danshawna Member

    s-off
    hboot 0.92.000
    radio -2.15.00.07.28

    Nothing i flash works, when I try I get the 3 vibrate bricked phone or it gets stuck at white boot screen, i flash recovery back to this. I cant get anything to work. I want rooted gingerbread. How do i get there. Please help.


    Thanks

    Advertisement
  2. scotty85

    scotty85 Guides Guide

    well,since you did not answer this:
    then i am going to assume that you are,as 3 vibes are the result of holding volume UP and power. it puts the processor into some sort of diagnostic mode.

    you are not trying to access hboot correctly. i assume your phone has an issue that is preventing it from booting fully,you may need to run an ruu prior to trying to flash a rom.

    what you need to do is pull the battery for a few seconds,then hold volume DOWN and power.(holding vol down slightly first)

    you can then select recovery from the hboot menu.

    what i would suggest doing,since your phone will not boot,is to run an ruu. download it from here:
    http://pvillecomp.com/wp/wp-content/uploads/Images/Gingerbread-Stock_PB31IMG.zip make sure its md5= 25ec451e08cd98c9495971bcb37e6582

    place on sd card,rename PB31IMG,flash in hboot.

    assuming it works,and your phone will now boot,you can install recovery in hboot,and then either install superuser,or flash a rooted rom. there are links in the original post for a rooted stock rom,and the newest hboot and radios,if you desire to update those as well. (finishing up section)
  3. Tanimator

    Tanimator New Member

    Hey Scotty! Thanks a ton man for putting up such a well detailed guide! I've got Desire S with hboot 2.02.0002 and I couldn't root using revolutionary-0.4pre4.

    Basically I followed your steps by unlocking first using htcdev and then flash recovery.

    I got stuck on 3rd process, after I copied superuser 3.07 onto the root of sd card I go on to bootloader but soon as I select recovery and hit the power button it goes to my network (Three) logo and hangs..

    Is there anything that I could do?

    If I restart without using the bootloader I can go back to my phone and everything is fine. I've tried factory reset as well but it goes back to the main logo and freeze..

    Need some urgent help please!!
  4. scotty85

    scotty85 Guides Guide

    your recovery is not starting if you used the links from this thread,becasue it is for the original droid incredible. you have replaced your stock recovery for one that is NOT designed to work with your phone. hopefully this action has not damaged your phones file system beyond repair(the fact that it still boots is a good sign).

    here is the desire s "sticky" on xda:http://forum.xda-developers.com/showthread.php?t=1146601

    and here is a recovery for touch 4ext recovery you can flash in fastboot using these same directions(fastboot flash recovery recoveryname.img): http://www.4ext.net/ddl/saga/recovery.zip

    as long as it successfully flashes,and you can boot to it,you can use the same superuser files to root.

    however...

    DO NOT follow the rest of the guide,it is incredible specific.

    you need to downgrade to a build containing 0.98.0000 or 0.98.0002. there are a couple different guides in the thread i linked above,but looks like you could use this one,since youve allread htcdev unlocked: http://forum.xda-developers.com/showthread.php?t=1318919

    the idea is the same as what is going on here,with exception of its using as misc version tool instead of flashing a modified misc image.

    once youve dowgraded,you can run revolutionary to achieve s-off: Revolutionary

    if youd like further assistance,lets start a thread in the desire s forum,and id be happy to help you there :)
  5. louiev

    louiev Member

    tyvm for step by stp worked great.
    scotty85 likes this.
  6. funkpod

    funkpod Well-Known Member

    So... i'm stuck.

    I am trying to do this on a Mac (insert joke here), and i finally am confident enough translating the Code and typing the code into Terminal, using the Mac version of the commands, and not using the miniadb_inc, but the Mac Version of the Android SDK.

    However, I get stuck at the HTCDEV part, about unlocking my bootloader.

    it's asking me to download a new RUU in order to unlock

    "Verizon WWE 4.08.605.2 PB3120000"

    however, the RUU it's asking for is .exe, which means my mac can't run it.

    any suggestions?

    i just want to root, my phone is still

    software number
    4.08.605.2

    baseband version
    2.15.10.07.07

    build number
    4.08.605.2 CL 185897 release-keys

    and it keeps asking me to update to this one...

    4.08.605.15

    DROID INCREDIBLE by HTC - Verizon - Support for HTC Cell Phones

    I believe that is the update that breaks this method, right?

    So i can probably still use 3.22 unrevoked and root, and use titanium backup to freeze the ota from happening, right?


    in which case if i don't get a windows computer or a mac way to use htcdev right away, i can root the old way and then do this method to get s-off after i get access to windows?
  7. sdrawkcab25

    sdrawkcab25 Guides Guide

    What is your hboot version?
    scotty85 likes this.
  8. scotty85

    scotty85 Guides Guide

    i would not recomend messing with unrevoked. it is finicky,at best,and i beleive you will casue yourself more fustration in the long run.

    that is one of the benefits of htcdev- it is solid,and as long as htc continues unlock support this guide will work,period. you just need to get the unlock compatible hboot onto your phone.
    yes. as long as your answer to the following is .92:
    if youre on hboot .92 you can simply flash the htcdev hboot(the .exe ruu it wants you to download) in hboot,by placing on your sd card,rename PB31IMG,boot to hboot,etc.

    if you have a handle on flashing an ruu from fastboot on your mac,then you can flash it that way as well(fastboot oem rebootRUU, fasboot flash zip,etc)

    this is the signed by htc "rom.zip" from the 1.02 ruu utility that you cant run,so it will flash overtop of .92 hboot with s-on.

    signed 1.02 hboot
    md5: PB31IMG-hboot-1.02.000.zip 37767b7a68285aa72c7ddbcd4ee18cd6

    your phone is useless without a bootloader,so please double and triple check that md5!

    hopefully that gets you started :smokingsomb:

    edit: you actually can just allow the update if you wish,it will likely install htcdev compatible 1.07 hboot in the process.
  9. do you know where I can find that zip file?
  10. scotty85

    scotty85 Guides Guide

    it does not exist for the incredible. it is specific to the droid eris handset. someone with a more extensive knowledge of android/linux/unix would have to make one up.
  11. funkpod

    funkpod Well-Known Member

    thanks!
    okay, so, yes, hboot is .92,

    so, i put the .exe ruu on my sd card and change the name, and then... what?
    how do i boot to hboot?

    or is what what the htcdev directions are telling me?

    no... i'm afraid i don't have a handle on it... yet... ;)


    i will make sure to md5 like 4 times to do this stuff, i guess that's the appeal of unrevoked, in that i don't have to do these little steps, but i guess it can be unreliable.

    so the OTA update will probably bypass the step that htcdev wants me to do, right? but it doesn't matter, cuz i can still root and all that using this method, right? i need one of them youtube videos on this... the mac version, at least, lol.

    thanks for your suggestions!
  12. scotty85

    scotty85 Guides Guide

    correct. letting the phne OTA should install the 1.07 hboot,wich is htcdev compatible. you will be able to root with this method,no matter how new the firmware gets,or what explits get patched,so long as htc continues unlock support for new hboots. the OTA will not hinder your ability to use this method in any way :)

    once you have 1.02 or 1.07 AND a big,pink locked at the top of your hboot screen,you can skip over the "install this ruu" step.
  13. danshawna

    danshawna Member



    Thanks so much. Your advice was perfect. I needed an RUU. Great guide. Excellent!!!
    scotty85 likes this.
  14. scotty85

    scotty85 Guides Guide

    awsome! glad it worked out for you :smokingsomb:
  15. antonizoon

    antonizoon New Member

    Sup, scotty? I would like to tell you about a guide derived from yours in a project called the Android Development Codex. It has heavily reorganized your stuff, so you might want to check it out, add to it, or just pull the improvements back into your original.

    Owing to XDA's messy evolution, the guides for most devices on the forums are, (quite honestly, no offense), outdated and disorganized, divided among tons of guides and maintained by OPs who may or may not be active. The reality is, forums are great for development and asking questions, but they are bad for constantly fluctuating guides that demand community support. The result is the status quo on XDA; newbies constantly asking "obvious" questions about methods and issues long since solved.

    To rectify this situation, I have been creating a complete, monolithic, and community editable guide to the Droid Incredible. In it's current state, nearly all of it is sourced from scotty's grand ol' guide, but I have made some big edits and reorganized it top to bottom.

    https: //github. com/bibanon/android-development-codex/wiki/HTC-Droid-Incredible

    This guide is part of the Android Development Codex, an initative to create a customized and functionally complete modding guide for every device we can get our hands on.The entire thing is stored on Github Wiki, so you can edit it if you have a github account.

    ## The Android Development Codex is not finished! Why are you releasing it now?

    Originally, I was going to keep the Android Development Codex an anniversary secret until all the guides for the devices I owned were complete. However, a new project called "XDA University" is being started, so I am prematurely releasing my work to the community and awaiting further developments.
  16. darthtintu

    darthtintu Member

    Hi Scotty,
    Thanks for the detailed guide.
    However, I seem to have screwed up the phone. Before attempting this guide, my phone would reboot when it got hot (I think) when I used gps or played music. So I wanted to try rooting and reducing the cpu frequency. Also sometimes it would get into the reboot loop where it only showed the 1st screen and wait few seconds and then again the 1st screen. This would sometimes be fixed by removing the battery.

    So I tried the guide and was able to complete step 3. After that when the phone rebooted it went into the 1st screen reboot for quite a while. I tried reinserting battery few times but it didn't work. After an unknown number of times, it booted completely and then again rebooted a bunch of times and then finally came up with android.

    Then I tried step 4 and at this point adb push mtd0.img /sdcard/, it gave an error. So I rebooted it again and when I checked the storage options I don't see any sdcard mounted. First of all I don't think there is a separate sdcard because I don't see it. However I think this has 8GB of space and it was formatted as an sdcard or something because it used to show that before. Now it didn't. Showed few MB - I forget how much. I had checked all md5sums.

    I rebooted into recovery and tried to mount /sdcard and that failed as well. I don't remember what I did after that, I think I tried factory reset from hboot.
    Anyway long story short, it is forever stuck in 1st screen reboot loop.

    I'm able to get to hboot and fastboot but cannot get to recovery either. When I try recovery, it goes into the reboot loop. I've left it for several hours and also tried battery multiple times to no avail.

    Is there any way to fix this in fastboot? I'm not able to get to recovery.

    Thanks,
    Darth.
    scotty85 likes this.
  17. sdrawkcab25

    sdrawkcab25 Guides Guide

    Does your hboot say you're unlocked?
  18. darthtintu

    darthtintu Member

    scotty85 likes this.
  19. sdrawkcab25

    sdrawkcab25 Guides Guide

    scotty85 likes this.
  20. darthtintu

    darthtintu Member

    scotty85 likes this.
  21. sdrawkcab25

    sdrawkcab25 Guides Guide

    Take off the battery cover, there is a sd card slot on the side. Can't complete the process without an sd card.

    If there is an sd card in there, you will need to remove it and use a card reader to format it.... If there is no card, you will need to get one and format it :)
    scotty85 likes this.
  22. darthtintu

    darthtintu Member

    On the side! I was checking under the battery - doh! I will check tonight as I don't have the phone with me right now.
    Thanks.
  23. sdrawkcab25

    sdrawkcab25 Guides Guide

    No problem, keep us posted.
  24. scotty85

    scotty85 Guides Guide

    you also might try,if you havent,a "factory reset" in hboot,with the stock recovery in place. do this before you reinstall a custom recovery.

    see if that helps your bootloop situation.

    you can then use fastboot to flash a recovery without an sd card present,following the directions here for step 2. since you arent in the booted OS,you cant do the first couple steps,so pick up the directions at: fastboot devices

    with the recovery in place,if CW has an option to flash from the emmc,you can try that to flash superuser,assuming the emmc is accessible and not corrupt.

    but as sdraw said,it prolly is easier for you to have an sd card to complete the procedure.

    we may have to run an ruu to get you up and running again. do you know what build number you are on?
  25. darthtintu

    darthtintu Member

    Ok, let me try the sd card method first. I must be on the latest build because it wasnt showing any updates last I checked. I was getting some update notifications few weeks back but when I tried to install it would never reboot to install. Then the notifications stopped.

Share This Page