1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

[HOW TO](gaining root)unlock,downgrade,and achieve s-off with htcDev


  1. darthtintu

    darthtintu Member

  2. sdrawkcab25

    sdrawkcab25 Guides Guide

    Once you take off the battery cover, it's on the bottom left hand side.

    Says "micro sd" on the slot (kind of hard to see)

    Can see it being removed below :

    [​IMG]
    scotty85 likes this.
  3. darthtintu

    darthtintu Member

    Thanks for the pic, now I know where to look.
    Btw I don't have a card reader but I do have an android tablet that takes microsd card. Can I format it on that?
  4. sdrawkcab25

    sdrawkcab25 Guides Guide

    Yeah, should be able to format it using any device that takes a microsd that can also be mounted to a computer.

    Ps... I updated with a better pic above.
    scotty85 likes this.
  5. darthtintu

    darthtintu Member

    Awesome, thanks for all the help. I hope this works!
  6. darthtintu

    darthtintu Member

    I did what you guys said. I took the sd card formatted it and put the files on it. The hboot does not seem to find it. I thought maybe it has to be .zip extension, so tried that as well. But still it doesn't find the PB31IMG.
    Also tried fastboot flash recovery clock-recovery.5.0.20-inc.img but same result. :(
    It doesn't find the img file and doesn't prompt to install.

    [Edit] I also tried RUU PB3120000_Incredible_C_hboot_1.02.0000_4.08.605.2.exe that I found in one of the threads here. If I'm in hboot it does not detect the phone. So I went into fastboot. There it was able to detect the phone and go to the next step where it says "waiting for bootloader" and times out. At that time the phone is frozen in fastboot and I can't reboot bootloader and so the RUU times out.
  7. scotty85

    scotty85 Guides Guide

    the ruu that you mention is only the hboot,so if you ahve thaT HBoot,or a the most recent ota,that ruu will not run.

    what PB31IMG did you try to install?

    it may have been that your main version is too new,but you usually recieve an error in that situation. the phone should still find and check the file.

    there are only 2 reason an uncorrupt, correct,signed by htc file is not found on the sd card:
    1)sd card is not FAT32
    2)file is not named correctly

    how did you format the sd?

    it may be helpful for us to know your main version. you can find that out by following these directions:
  8. darthtintu

    darthtintu Member

    It's giving some error

    INFOversion: 0.5
    INFOversion-bootloader: 1.07.0000
    INFOversion-baseband: 2.15.10.12.20
    INFOversion-cpld: None
    INFOversion-microp: 0417
    getvar:all FAILED (status read failed (Too many links))
    finished. total time: 0.016s
  9. darthtintu

    darthtintu Member

  10. c0nn13

    c0nn13 Member

    Sorry got it myself
  11. scotty85

    scotty85 Guides Guide

    -make sure that you are in fastboot,not hboot.
    -make sure that you do not have htc sync,pda net,easy tether,or any other programs capable of comunicating with the phone running(or even temporarily uninstalled or disabled)
    -try different usb cables and ports


    the phone is likely not finding the file(or,rather purposely ignoring it) becasue you are still s-on,and the main version on your phone is higher than the main version in the android info text document inside PB31IMG. this is a big reaSON that htcdev is a PITA. you are better off not trying to install a PB31IMG with an s-on phone,as a couple factors have to be right,and it leads to fustration.

    to get a recovery on the phone,you can then use fastboot,following the directions here for step 2. since you arent in the booted OS,you cant do the first couple steps,so pick up the directions at: fastboot devices

    did you try a factory reset with the stock recovery still in place? you definately want to try this before you install clockwork,and i dont see any mention of it.
  12. darthtintu

    darthtintu Member

    I am in fastboot. I'll try removing htc sync.
    I tried fastboot recovery step but I got the same result. It doesn't see the file.

    By factory reset with stock recovery I assume you mean by flashing recovery.img? Where can I find the image file? If this is not it, what exactly do I do for factory reset with stock?
    I don't think stock recovery is still in place. The clockwork recovery was coming up for a few times before it started doing the 1st screen reboot loop. Doesn't this erase the stock recovery?
  13. scotty85

    scotty85 Guides Guide

    what errors do you get in your cmd window?

    htc sync and other phone programs really can wreak havoc with entering commands and getting the correct responses from the phone.

    actually,i just mean,selecting "factory reset" in the hboot menu,while the stock recovery is on the phone still.

    what happens if you select recovery from the hboot menu?
  14. darthtintu

    darthtintu Member

    The only error I see is during the getvars command and I've pasted that.
    Previously I was running linux and there were no errors with flashing to the phone but still the only thing the phone does is 1st screen reboot loop. I only booted into windows to run the ruu exe but as you said that won't work.

    Factory reset and recovery options in hboot just go back to the reboot loop.

    Sorry, I'm a bit confused about stock recovery. I guess I'm not explaining it well. I don't know if stock recovery is on the phone. As I said, I flashed this phone with clockwork recovery successfully and I was able to enter the menus. But later it went into the reboot loop state and now even that is not working.
  15. darthtintu

    darthtintu Member

  16. scotty85

    scotty85 Guides Guide

    sounds like you do not have any recovery on the phone,as:
    -factory reset should show some green status bars and a couple different screens as the stock recovery does some things,if the stock recovery were present.
    -factory reset would take you to clockwork recovery,if it was installed.
    -recovery should take you to cw if it were installed,wich would be the menus youve seen
    -recovery would take you to a red triangle and ! if the stock recovery was in place.

    heres what we will try:

    you are still unlocked,correct? if not,you will have to re-unlock with your original token.

    download this: http://www.mediafire.com/?c0b3q4vg4n39onu

    -place the whole,zipped folder into miniadb_inc(dont change the name)
    -charge the phone to 100%,if possible
    -place phone in fastboot
    -open a cmd window
    -enter the following commands:
    cd c:\miniadb_inc (assuming you were following the first post directions and are using the miniadb_inc directory)

    fastboot devices (should return serail number)

    fsatboot erase cache

    fastboot oem rebootRUU (should put the phone in black screen with silver htc letters)

    fastboot flash zip PB31IMG-4.08.605.2-mini.zip
    *you should now see it flashing things. do not for any reason interupt it during this process. when its finished:

    fastboot reboot-bootloader

    now select bootloader from the fastboot menu,then select factory reset in hboot. hopefully this time,it will do some things,then reboot fully
  17. edcotech

    edcotech New Member

    just a note if planning on using dinc on another network the htcdev hboot upgrade to 1.07.0000 seems to lock the radio to verizon network even though it is fully ulocked and s-off... so stay with .92 and use unrevoked3 to unlock and dont forget to modify the build.prop. As for the guide, it works like a charm if instructions are followed. Thanks
  18. edcotech

    edcotech New Member

    Also I did the upgrade and found out about the locked radio the hard way but was able to downgrade it by putting the PB31IMG for froyo: PB31IMG.zip from page one's "go ahead and download list" of this thread on my sdcard and booting into recovery. Ran automatically and asked if i wanted to update, i clicked yes and it actually downgraded from 1.07.0000 back to 0.92. then I rooted using unrevoked3.
  19. darthtintu

    darthtintu Member

    Scotty,
    No luck. :(
    All the steps went through without errors, but when I do factory reset its the same reboot loop.

    On the other site, someone mentioned corrupt partitions? Could this be the reason?
    I tried flashing mtd0.img using fastboot flash misc mtd0.img but got a signature error.
    scotty85 likes this.
  20. darthtintu

    darthtintu Member

    Btw the phone is definitely seeing the card but I dont know why it's not seeing the files. In the microsd card I see new files like .android_secure, .quickoffice etc.
  21. scotty85

    scotty85 Guides Guide

    just wanted to point out unrevoked is not needed once you are s-off. you are easily rooted by:
    -install recovery in hboot
    -flash superuser in recovery

    you prolly have some sort of hardware failure,or enuff bad blocks in one or more partitions that the rom is not properly installing(i.e. no longer fits in the partition)

    as a last ditch effort,you can install recovery,and enter the commands to change the misc image with the phone in recovery. if whatever is causeing the bootloops is fixable,when you flash the downgrade ruu, it should repair the corrupt partitions and the phone will boot into froyo.

    go back to the OP,and follow all the directions carefully. you can skip the actual unlocking,since you are currently unlocked

    follow step 2 to install recovery with the fastboot flash command

    step 3 to install superuser root files.

    when you do step 4,since you are in recovery youll have to mount data,so after the commands checking the md5s,and prior to adb push flash_image /data/local/,you will enter this command:

    adb shell mount /data

    then procede with the rest of the commands.

    your cmd window when running the commands should look like this(red are my inputs):
    Code:
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\Users\Scott>[COLOR="Red"]cd c:\miniadb_inc[/COLOR]
    
    c:\miniadb_inc>
    
    c:\mini-adb_inc>[COLOR="Red"]adb devices[/COLOR]
    List of devices attached
    HT117HJ00242    recovery
    
    
    c:\mini-adb_inc>[COLOR="red"]md5sums mtd0.img[/COLOR]
    
    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    Type md5sums -h for help
    
    [Path] / filename                              MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    mtd0.img                                       34307be744275f1db1dd16af04c37839
    
    c:\mini-adb_inc>[COLOR="red"]md5sums flash_image[/COLOR]
    
    MD5sums 1.2 freeware for Win9x/ME/NT/2000/XP+
    Copyright (C) 2001-2005 Jem Berkes - http://www.pc-tools.net/
    Type md5sums -h for help
    
    [Path] / filename                              MD5 sum
    -------------------------------------------------------------------------------
    [c:\mini-adb_inc\]
    flash_image                                    0098a7dd6600b55fac34fc6645be5d7a
    c:\mini-adb_inc>[COLOR="red"]adb shell mount /data[/COLOR]
    
    c:\mini-adb_inc>[COLOR="red"]adb push flash_image /data/local/[/COLOR]
    1485 KB/s (76044 bytes in 0.050s)
    
    c:\mini-adb_inc>[COLOR="red"]adb push mtd0.img /sdcard/[/COLOR]
    1939 KB/s (655360 bytes in 0.330s)
    
    c:\mini-adb_inc>[COLOR="red"]adb shell[/COLOR]
    / # [COLOR="red"]cd /data/local[/COLOR]
    cd /data/local
    /data/local # [COLOR="red"]chmod 0755 /data/local/flash_image[/COLOR]
    chmod 0755 /data/local/flash_image
    /data/local # [COLOR="red"]cd /data/local[/COLOR]
    cd /data/local
    /data/local #[COLOR="red"] ./flash_image misc /sdcard/mtd0.img[/COLOR]
    ./flash_image misc /sdcard/mtd0.img
    /data/local # [COLOR="red"]exit[/COLOR]
    exit
    
    ......
    
    if the fastboot flash commands seem to work to install recovery,yet you cannot get to recovery by selecting it from the hboot menu(i.e. are sent back to your bootloop) then likely recovery is one of the damaged partitions,and i,unfortunately,am out of ideas at that point :(
    edcotech likes this.
  22. c0nn13

    c0nn13 Member

    so. heres what happened. i unlocked, downgraded, & achieved s-off. then tried to flash MIUI 4.1.2.9.7 but didnt take. removed the battery. got into recovery & restored the only back-up i made which was the original backup. so now im @ 2.3.4 with an unlocked bootloader, clockword mod, & s-off. but superuser is gone. what now?
  23. darthtintu

    darthtintu Member

    Scotty,
    Yeah, I wanted to try that. But adb devices does not show anything. And obviously I can't turn on usb debugging from android. Is there a way to turn on usb debugging in hboot?

    I think all the earlier reboot loops may have screwed up the partitions.
  24. edcotech

    edcotech New Member

    Reflash superuser as in step 7 just skip the unrevoked part as you are already s-off
    scotty85 and c0nn13 like this.
  25. sdrawkcab25

    sdrawkcab25 Guides Guide


    Can just flash superuser(step 7) or any rom
    scotty85 and c0nn13 like this.

Share This Page