[HOW TO](gaining root)unlock,downgrade,and achieve s-off with htcDev

Last Updated:

  1. scotty85

    scotty85 Guides Guide

    did you get yourself sorted out?

    what you have just experienced is the main reason i personally avoid rom manager. it does not always install tings correctly,and it is an APP in a working rom,and as such will not always be available for you to use.

    i would pretty strongly reccomend that you avoid rom manager,and use the menus in recovery to manually flash,wipe,backup,etc.

    to fix your boot loop,go to clockwork recovery,
    -wipe data/factoiry reset
    -wipe cache
    -wipe dalvik cache

    now you can either:
    1)restore a working backup


    2)flash a rom

    if you wish to flash cynaogen again,i would download cyanogen to your PC. download and install an md5 sum checker to your PC so you can compare the md5 of your download to the one the cm lists for what you downloaded.

    once you have verified the md5,transfer the download to your sd card so you can flash it in recovery. make sure you have transfered the reccomended gapps to your sd card as well,and flash it immediately after flashing the rom.

  2. altxf4

    altxf4 New Member

    I joined this forum today just so I could say thanks to Scotty85!

    No other method worked for my previously 2.3.4 OTA Incredible.

    I used the HTC super tool in a previous attempt to get my initial unlock done, but other than that is was all by Scotty's instructions!

    Thanks Man!
    scotty85 likes this.
  3. scotty85

    scotty85 Guides Guide

    awsome! glad it was helpful
  4. Poboy

    Poboy Well-Known Member

    I'm stuck on step 7

    when i start in hboot and select recovery, after the HTC splash screen all I get is a image of a phone with a halt triangle/! on it.

    I tried reflashing clockwork mod with no luck. Any ideas? Should i go back a few more steps and repeat?

    Edit: Nevermind, I'm a moron. Had completely skipped step 5
  5. scotty85

    scotty85 Guides Guide

    what youre seeing is the stock recovery,so clockwork isnt getting flashed. double check your command,and that the image name matches,and is in your mini-adb_inc folder.

    a copy and paste of your cmd window may help if you cant get it to work.

    you are re-unlocked on froyo,correct?
  6. JusPal

    JusPal Member

    Scotty this is great thanks! I'm new to all of this so may be a stupid question, but do I want to leave the bootloader unlocked?

    Also I just looked and my phone is doing a system update. how do I stop this?
  7. luteplayers

    luteplayers New Member

    Hi I am trying to downgrade an original incredible that has been updated to 4.08.605.15, and 1.07.0000 hboot. I have the HTC sync installed and the phone does connect. Tried running the RUU from HTC, but it fails every time saying that it cant connect to the phone. using the adb process, I am able to get the unlock_code.bin, but when I try to flash it, it just hangs in the command prompt window and HTC Sync shows the phone disconnected. The phone is showing the hboot screen with Locked at the top and fastboot usb and bootloader highlighted. It is locked up and I have to pull the battery to reset it.

    Any thoughts on why the unlock_code wont flash?

    C:\miniadb_inc>fastboot flash unlocktoken Unlock_code.bin
    sending 'unlocktoken' (0 KB)...
  8. scotty85

    scotty85 Guides Guide

    are you sure your hboot is 1.07? you should have 1.02.0000. if you have this hboot,you should allready have the locked compatible hboot,and dont need to install htcdevs RUU.

    i believe the prollem you are having is due to htc sync running. you need to disable it,along with any other programs that can interact with your phone. make sure usb debugging is checked. after that if you still have connectivity issues,i would try installing the modified drivers from revolutionary(linked in the OP) as the htc sync drivers may not be cutting it for some reason.

    hopefully after shutting down all phone interactive programs,your token will flash successfully. if not,try a factory reset in hboot,then start the process over.
  9. luteplayers

    luteplayers New Member

    Thanks, I do have the 1.07 hboot, I think it was a problem with the computer I was trying it with. Connected to my desktop and it did flash the unlock_code and reboot the phone. moving on now.

    I have flashed clockwork, now when I boot into recovery to flash superuser, using backup/restore of wipe cache, it just hangs with the tophat/orange circle. How long should it take for that?

    NM another one caught by using the power button instead of the trackball.

    Done Froyo, rooted, s-off, now to find a rom. Does there exist a rom with no radio support. I am just going to use the phone as a mini tablet/MP3 player. http://forum.xda-developers.com/showthread.php?t=1217038 Link for wifi-only script.
    scotty85 likes this.
  10. NeekoX

    NeekoX New Member

    I was having the same problem running the RUU. I tried repeatedly. Saddened, I just moved on even with the error and to my surprise, everything went smoothly after that. I believe I was on 1.07 also.

    Also, I wanted to note that I tried using the Unrevoked method for about 2 days, failing miserably. Using this method I was done by the end of my lunch hour. Thanks! :)
    scotty85 likes this.
  11. scotty85

    scotty85 Guides Guide

    can one of ya with a 1.07 hboot take a pic of it for me? i have been looking for an OTA or fimrware for 4.08.605.15 but have been unsuccessful at finding it thus far :(

    nevermind,some prodding on XDA has turned up the radio and 1.07 hboot :)
  12. cFed

    cFed New Member

    Great guide man, I followed it to the end and only got stuck at two points but Jerniganc and Poboy already got stuck at the same points so I followed their advice. (was hitting the power button instead of trackball at recovery screen, then later I had skipped step 5. You might update it at step 6 to say "make sure it doesn't fail when you do the flash".. I dunno, the first time it did for me I didn't notice I had skipped step 5), otherwise, all around great guide! Thanks for taking the time to put it all together, and thanks to all those you thanked. :D

    I did this b/c I was sick of the htc sense ui, but I'm kind of stuck as to what to do next. Can you point me in the direction of another thread that explains how to flash a newer version of android or custom mod?

    FYI, if you get this at step 6... back up and make sure you did step 5 correctly:

    c:\miniadb_inc>fastboot flash recovery recovery-clockwork-
    sending 'recovery' (3064 KB)... OKAY [ 0.430s]
    writing 'recovery'... INFOsignature checking...
    FAILED (remote: signature verify fail)
    finished. total time: 0.853s
    scotty85 likes this.
  13. scotty85

    scotty85 Guides Guide

    yup! not unlocking will definately give you that error! glad you got it figured out and all is well.

    your next step would be to install a rom. there is tons of info on this in the forums,but the basic procedure will be:
    -find one you like
    -transfer it to root of sd
    -boot to recovery
    -backup current rom
    -full wipe
    -install new rom
    -install GAPPS if needed

    you can find roms here:
    Droid Incredible Android Development - xda-developers

    cm7 roms are AOSP based gingerbread
    cm9 roms are AOSP based ice cream sammich
    there is even an alpha jelly bean rom(wish i could get my inc away from the GF,id give it a flash :D)
  14. redefsen

    redefsen New Member

    Scotty, Thanks for writing a great detailed guide.
    scotty85 likes this.
  15. Nickynick

    Nickynick Member

    ok so heres what happened, i rooted my phone following this guide and it went great but when i pasted new camera files over the old ones and rebooted it was stuck on the htc loading screen forever and nothing worked so i pasted the PB31img.zip in the sd and it loaded in hboot and now the phone works, except the camera of course the whole reason im doing this...and besides i like messing things up...

    but now the superuser binary is missing, the clockwork recovery is not functioning and it is not rooted but it is in S-OFF ....and i cannot flash anything in hboot because the phone will not allow it. it does not say locked or unlocked on top of the hboot screen...it just says error remote access not allowed.

    so im stuck it wont even upgrade with the factory upgrade or reset. :mad:
  16. Nickynick

    Nickynick Member

    id also like to add that when i do ADB devices instead of saying H####### device it just says H###### offline
  17. scotty85

    scotty85 Guides Guide

    the froyo PB31IMG that you ran overwrote your unlocked hboot(since your phone is s-off),and all other partitions,leaving you without recovery or root access.

    all you need to do is install clockwork,flash superuser files.

    you cannot use the fastboot flash command with either the normal .92 hboot,nor either of the locked hboots(you must unlock first).

    your best option is to simply install clockwork as a PB31IMG in hboot,just as you installed the ruu that overwrote everything.

    here is clockwork in a PB31IMG file:
    just rename PB31IMG,flash in hboot.

    you can then install a rom,or flash the superuser root files.

    the "offline" error is usually fixed by changing usb cables,ports,or rebooting the pc and/or phone. sometimes you need to turn usb debugging off,then back on,and select disk drive,then charge only mode. also note that adb is not available in the stock recovery,hboot,or fastboot. to use ADB,you must be in the booted OS,with proper drivers installed,and usb debugging enabled.

    last and not least,let this be a lesson to make a backup prior to modifying,deleting,or changing any system files. :)
    Nickynick likes this.
  18. Nickynick

    Nickynick Member

    thanks a ton !! i wouldve never figured it out. im doing a backup as we speak lesson learned :( i want to flash a new Rom so off to do that :smokingsomb:
  19. tubaman300

    tubaman300 New Member

    I recently was given a Droid Incredible from a friend, and was interested in rooting it. The phone is running GB 2.3.4 4.08.605.15. Since there is no direct method for rooting, I have been attempting to downgrade using both Unrevoked and ADB. However neither of these processes work. With ADB I get the error "Hellions with BLUE flames". With the newest version of Unrevoked I get "Error: failed get root. Is your firmware too new?" while using the older version (3.22) I get "Failed to flash recovery image". Help please?
  20. scotty85

    scotty85 Guides Guide

    there is a direct method to rooting. its in the original post ;)

    the hctdev method to unlock and downgrade,then achieve s-off has worked well for those that have used it,and has thus far proven very reliable and predictable.

    the zergRush exploit is now broken,fre3vo does not appear to work,and unrevoked is finicky at best. i believe whatever made the older version work on the original gingerbread builds is now broken as well.

    the method in the original post is all htcdev and does not utilize any other temp root exploits or finicky root tools. give it a go,holler if you have questions. :)
    tubaman300 likes this.
  21. cjoc

    cjoc Member

    I have a droid incredible 2 and used htc dev unlock to unlock the bootloader. I have s on. So i googled the problem and came here. I was following your guide till I got to check md5 sum. Wasn't sure how to check the md5 sum. Found a program and put the file you have in the miniadb_inc.zip and came up with da1e100dc9e7bebb810985e37875de38 does not match. Don't know if that is the file I am suppose to check or not. Also just realized that this is for the OG incredible(my old phone) does this work with the Incredible 2.
  22. scotty85

    scotty85 Guides Guide

    no,sorry,it does not work with the inc 2. a similar process could be used to downgrade the inc 2 to revolutionary-rootable firmware,but this exact guide,im afraid does you no good.

    heres a guide you can check out to downgrade your inc 2:
    [Guide] How To Downgrade 6.01.605.05 and gain S-Off - xda-developers

    heres one here:

    and here is the inc t "all thigns root guide": http://androidforums.com/incredible-2-all-things-root/520738-incredible-2-all-things-root-guide.html

    if you have other questions,start a thread in the inc 2 forum and send me the link. we will help you there :)
    Boggie likes this.
  23. Boggie

    Boggie New Member

    Got everything except S-off:

    E:unsupported radio version
  24. scotty85

    scotty85 Guides Guide

    sounds like your downgrade to froyo was unsuccessful. running the forever patch on GB will get you that error.
  25. sandervitreous

    sandervitreous New Member

    Thanks a bunch. It was a hot day so i decided to root my phone. Tired of the constant rebooting overnight because of carrier updates.

    I following your instructions to the letter and worked great. I have the latest updates (4.08.605.15, and 1.07.0000 hboot) and everything went great. I had to reinstall CM7 twice due to funny things happening on boot with Android guy....(he was in some kind of loop, another post had same issue). i did both installs from recover, not rom manage.

    Currently running and working fine.

    Again, thanks for all your work on this project.
    scotty85 likes this.

Share This Page