How to get Email Notifications silent with LocaleSupport


Last Updated:

  1. mihalich

    mihalich Well-Known Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    425
    Likes Received:
    44
    Hi,

    I'm using Locale and have a bunch of different profiles set up.

    I have vibration turned off in the email app for my email accounts.

    In the profile I'm currently using in Locale I have the volume for notifications turned off, and vibration turned on.

    This is working, but I only want vibration on for notifications like missed calls, or text messages. I want email notifications to be silent.

    Is there a way of achieving this?

    Thanks,
    Joe
     

    Advertisement
  2. crankerchick

    crankerchick Well-Known Member

    Joined:
    Dec 30, 2009
    Messages:
    593
    Likes Received:
    113
    nope.

    email and messaging (and maybe others) have their own settings for sounds and vibrate and locale (or any app that i've found on the market) can't control them. So if you want your email to vibrate or not, you have to turn on/off vibrate in that program. 'Tis annoying if you ask me.
     
  3. mihalich

    mihalich Well-Known Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    425
    Likes Received:
    44
    Vibrate is off in the email program. Yet, it still vibrates when I get an email.

    Joe
     
  4. KeithG

    KeithG Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    103
    Likes Received:
    3
    Locale has no ability to tell what kind of notification it is. The SDK doesn't currently permit intercepting, modifying or reading other notifications (other than its own).

    Its merely changing the current phone settings for global notification / ringer / vibrate. It can't change app specific settings.

    You basically told it.. if the phone wanted to play a notification sound turn it into a vibrate. Which is what it is doing.

    Since the email generated a notification... and would have played a sound ... it was translated into a vibrate even though you told the email notification *not* to vibrate. The email didn't vibrate the phone, the notification service did. Its a subtle difference.

    You could probably turn off all notification in the app settings.. so it doesn't generate any type of notification, which would keep the phone from vibrating. But locale can't do that as it would be an app specific setting.
     
  5. mihalich

    mihalich Well-Known Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    425
    Likes Received:
    44
    Yes, that is what I figured it was doing. Thanks for the clarification.

    I hate the way they architected the whole notification thing. Fundamental smart phone events like incoming calls, sms, emails, missed calls, calendar events, etc should be able to be trapped and dealt with by any application.

    Joe
     
  6. KeithG

    KeithG Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    103
    Likes Received:
    3
    Not going to argue there, other than to say, the current implementation works, and that is better than a non working one :)

    I would like to seem them extend the current api to permit this .. however it may have been done as a security measure .. etc etc.

    Bug fixes and features are always welcome
     
  7. crankerchick

    crankerchick Well-Known Member

    Joined:
    Dec 30, 2009
    Messages:
    593
    Likes Received:
    113
    Mihalich, I don't know if you are using time-based switching or location based switching in Locale, but if you are using time-based, Timerrific is an app that works as you want it to. It does not do anything with application specific notifications, so if you tell it to vibrate, it will only vibrate what normal notifications. It won't vibrate any applications that allow you to set the vibrate behavior independently.
     
  8. crankerchick

    crankerchick Well-Known Member

    Joined:
    Dec 30, 2009
    Messages:
    593
    Likes Received:
    113
    It sounds like Locale might do what I want, which is to force all notifications to vibrate.
     
  9. crankerchick

    crankerchick Well-Known Member

    Joined:
    Dec 30, 2009
    Messages:
    593
    Likes Received:
    113
    And now I think it cannot.

    From the locale website:

    Why can't I get vibrating notifications for SMS?

    As an Android factory default, SMS messages do not have vibrating notifications. To enable this, open the Messaging app, then choose Settings from the menu. At the bottom of the settings is the option to configure vibrating SMS notifications.

    This makes SMS notifications vibrate ALWAYS and not just when the phone is vibrate. The same would apply to email, calendar events, and any other appilcation notification that has a vibrate check box.

    I know 2 things: one, that I'm confused, and two, that I don't know you get a vibrate for email when the vibrate button isn't checked. Android is NOT supposed to act that way. You might try and email your question to the developer.
     
  10. mihalich

    mihalich Well-Known Member This Topic's Starter

    Joined:
    Nov 23, 2009
    Messages:
    425
    Likes Received:
    44
    LOL. Exactly. If its that confusing, something is wrong...not withstanding the security issue mentioned above.
     

Share This Page

Loading...