[How to] get Google play on LT7033


  1. gyro55

    gyro55 New Member

    How I managed to get it to work on windows 7 64 bit, is I went to my device manager, found my device the LT7033. I don't recall where but somewhere it asks you to specify what kind of device it is, just leave it as all devices.
    1) Right click and go to update driver software
    2) browse my computer for driver software
    3) let me pick a destination
    4) locate the driver
    and it should all work
  2. csamuels024

    csamuels024 New Member

    yeah this is the same problem I'm having. mavrikmeercat, how did you get it rooted without those adb drivers? Which drivers did you use, or are you using a win 7 32bit instead?? Whenever I try to use dimitriz method which you said worked, and the links posted by casperischinky the program just says waiting for device and never runs. I suspect this is because I am using wrong drivers and my device is not viewable by adb.
  3. dimitriz

    dimitriz Member

    I just unzipped the drivers and then went into Device Manager found the tabled and told it to look at the drivers in the directory I unzipped to. It immediately recognized and installed.
    Then I ran the casperischinky's program with a batch and it found/rooted my device.

    Ohh, make sure you set Storage > Media Device and
    Developer Options > USB debugging
    otherwise it wont load the driver
  4. dimitriz

    dimitriz Member

    Well, even after rooting:
    Amazon Apps is back to it's black screen even after resetting.
    and
    Play Store is back to giving "Unfortunately. Google Play Store has stopped."
    (In the background on this it shows a Decline/Accept window that starts with "by using")

    :(

    Update: Completely cleared the data and uninstalled Amazon Apps .. reinstalled and it works!
  5. bluecardfish

    bluecardfish Member

    Can someone please help me. I have the drivers installed and I repeatedly try the ways you all have had success. Adb will recognize my rooted evo 4g lte but not this tablet. So the batch just fails.
  6. mavrikmeercat

    mavrikmeercat Well-Known Member

    After I moved market to system/app I factory reset the whole system from settings. Sorry, I forgot to mention that.
  7. mavrikmeercat

    mavrikmeercat Well-Known Member

    that is the exact same way I did it. The drivers installed but when I run the command (adb devices) it doesn't list a model# but the batch did root it just fine. Not really sure what's up with that
  8. bluecardfish

    bluecardfish Member

    when I try that way in the batch only half the things work because it constantly says device not found. did yours do that?
  9. swissklok

    swissklok New Member

    Thanks casperischinky and everyone else who is working on this!

    I've tried mavrikmeercat /system/app method of copying the google play apk over to the folder and restarting the tablet but it won't show up as an app. I might be missing something or i'm doing something wrong. I think the only thing I did different the mavrikmeercat is that I downloaded the apk directly to the tablet ( I don't have a card available at the moment) but I don't think that should have made a difference.

    In regards to the Amazon store. If you got to the settings and Apps and select the appstore and Clear Data you will be able to login again and have access. However if you shut the LT7033 off or reset it will no longer work and you are left with having to clear the data again.
  10. bluecardfish

    bluecardfish Member

    also when I run the batch, it says that Adb server is out of date. killing... did yours have this problem?
  11. mavrikmeercat

    mavrikmeercat Well-Known Member

    no it just worked. you have to enable usb debugging(different driver than when not enabled) and then plug in the usb to PC. then in device manager go to unknown device and -->update driver -->Browse computer--> choose folder for driver --> next and it should install just fine

    that just means adb was running in the background for a long time and needed to restart. not a problem. its supposed to do that
  12. mavrikmeercat

    mavrikmeercat Well-Known Member

    you need a file explorer that browses files as ROOT and have SU permissions it also needs to mount the /system as r/w (read/writable) in order to copy any file to a /system folder. the only two file explorers that i know that do this are Root Explorer(paid app) and ES file explorer(free) ES works nice and you can get it from SlideMe market. after you install it, you have to go into settings and check "browse as root" and "mount system as R/W" then you can copy things over to /system
    SuperNoober, csamuels024 and cammi0 like this.
  13. bluecardfish

    bluecardfish Member

    i will put the steps i do to get it to work. Please tell me what im missing.
    pc: windows 7 64bit

    1. enable usb debugging.
    2. device manager scan for changes.- device shows up under other devices- LT7033.
    3. update driver software.- i go to browse then pick to desktop and pick drivers from adb driver rk29 folder downloaded from earlier post.
    4. windows security - i clink install anyway.
    5.device now shows up as android phone- android composite adb interface.
    6. i run batch tool from root klu curtis tab toolkit and it starts and gives error:

    RK29 Rooting toolkit (v1.2)
    created by SferaDev for our RK Tabs (Based on ICS)
    from the work of DooMLoRD using "andorid emulator" trick
    Credits go to all those involved in making this possible!
    ----------------------------------------------------------------------
    ----------------------------------------------------------------------
    This tool will:
    (1) Root your RK29 tab
    (2) Install Busybox + Stericson's Busybox Free
    (3) Install SU binary (3.1.1) + Superuser.apk
    (4) If there is low free space, the tool will remove Google Maps.
    ----------------------------------------------------------------------
    Make sure you do this:
    (1) Install the drivers of the folder
    (2) Power on your Tab
    (3) Turn Mass Storage OFF
    (4) Enable "USB DEBUGGING" from Developer Options
    (5) Enable "UNKNOWN SOURCES" from Security
    (6) connect USB cable to your Tab and then connect it to PC
    ----------------------------------------------------------------------
    ----------------------------------------------------------------------
    When you finish all above press enter...
    Press any key to continue . . .
    Let's begin with the work.
    Waiting for your device
    ----------------------------------------------------------------------
    adb server is out of date. killing...
    * daemon started successfully *
    ** daemon still not runningerror: cannot connect to daemon
    Creating temp folders
    adb server is out of date. killing...
    * daemon started successfully *
    error: device not found
    Cleaning
    adb server is out of date. killing...
    ADB server didn't ACK
    * failed to start daemon *
    error:
    Symlinking the temp folder
    adb server is out of date. killing...
    ADB server didn't ACK
    * failed to start daemon *
    error:
    adb server is out of date. killing...
    * daemon started successfully *
    error: device not found
    ----------------------------------------------------------------------
    Rebooting
    adb server is out of date. killing...
    ADB server didn't ACK
    * failed to start daemon *
    error:
    ----------------------------------------------------------------------
    Waiting for your device
    PLEASE WAIT, THIS MAY TAKE A WHILE
    adb server is out of date. killing...
    * daemon started successfully *
    LoyaltyAffairs likes this.
  14. bluecardfish

    bluecardfish Member

    hey guys, i got it to work. it was apparently because i had droid explorer installed on my PC. i had to go to task manager, look for adb.exe and open that folder. once i uninstalled it, it worked. Thanks for all the help.
    gregchak likes this.
  15. gregchak

    gregchak Member

    This was my problem too! Wow, you saved me some serious headaches troubleshooting this! Thanks!

    Root worked. Copying of play store worked. Downloaded all of the apps I need from the play store without any issues.
  16. dimitriz

    dimitriz Member

    Awesome. works now. Didnt need to reset. a simple restart worked fine.
    Amazon however is still a hit or miss.

    ok. now that we got rooted and market working, does anyone have a list of apps that are safe to remove? without screwing it up.
  17. nickdalzell

    nickdalzell Well-Known Member Contributor

    FYI for the /system/app trick to work you need to change permissions. Uncheck all but the first two on the top, top middle, second row read only, third row read only. Should show something like rw-r-r

    For bloatware removal install rom toolbox pro (paid) go into app manager, freeze whatever app you want to remove. Exit and see if it still works right. If so you can go back and uninstall them, use automated uninstall root

    Never uninstall email.apk. Camera won't work, don't ask me why.
  18. Xodyaq

    Xodyaq New Member

    Didn't I say that in post #20? C'mon give the X-man a little love here! :D

    -X
    csamuels024 likes this.
  19. Xodyaq

    Xodyaq New Member

    Wow... That sounds a lot like #17! :D

    I'm getting no love today.

    -X
  20. casperischinky

    casperischinky Well-Known Member

    I never had to install any drivers for the tablet, but then again I'm probably 1 of the only a few people still on Vista lol.But either way I'm glad you guys got everything working on your tab.
  21. Suezi723

    Suezi723 New Member


    Hey there, I just bought these for my kids and I really want them to have google play so they will leave my tablet alone lol. I am a noob to code and installing things so is there any way you could tell me what I'm doing wrong?
    -When you say "extract the files" do you mean extract them to the tablet or to my PC? I did both for safe measure.

    -Then I did what the runme.bat says but my computer will not recognize the tablet at all once I do this.

    -Also when you say turn off mass storage, do you mean change the USB input to media device or use mass storage device but turn it off?

    - I hit enter and I get a long list of messages but all of them say "the system cannot find the path specified" but then says "you are root!" and I know I'm really not =( please please help! Thanks everyone!!
  22. enzojrc

    enzojrc New Member

    ok I need some serious help. I have downloaded everything from above posts, other sites concerning the RK29 chipset drivers and I can't get anything to work. My computer recognizes the device in system-other devices-LT7033 but when I go to update drivers manually and choose the folder it constantly says it can't find the drivers needed for the device. WTF? I have been going crazy since last night over how easily others have done this but neither my Windows 7/Vista/XP laptops seem to be able to recognize this device past it's simple USB mass storage option. Can someone please give me some ideas so I can move on with my life? Thanks!! :-(
  23. cadd97

    cadd97 Member

    Similar question here. Purchased the LT7033 (limited funds) for someone on disability only to find the massive limitations without Google Play. Not able to go out and get another so I don't want to brick the thing. I have the pieces of the puzzle (I think) and want to be sure I'm doing it correctly. Caspers files and batch, should it be on the PC or the tablet? And enablng usb debugging, is that done in the device manager? Thanks for all your help, you guys are great!
  24. bluecardfish

    bluecardfish Member

    you need to go to update then browse my computer for drivers, then click let me pick from a list. click show all, then click have disk and go to that fold and click the .inf and try again.
  25. bluecardfish

    bluecardfish Member

    you need to put both files on the pc. try desktop. connect the usb and on the tablet go to setting- development- usb debugging. then also make sure u go to security and allow other apps to be installed.
Loading...

Share This Page