How to go from ICS (4.0.1) to Kitkat (4.4.3) in Galaxy SII GT-I9100General


  1. sokratus

    sokratus Member

    Till few days back I was running and using Kitkat 4.4.3 (SlimRom). But yesterday my phone switched off due to low battery. I didn't realise this and restarted it again. Since then the phone was stuck on 'Samsung Galaxy SII' screen (boot loop I think?). Anyways, so today I formatted it back to stock ICS 4.0.3. I rooted the phone as well. Now I have been trying to install the latest Kitkat roms and I'm unable to do so. I read it somewhere that I require at least CWM 6.0.4.3 to install Kitkat. Then I got CWM 6.0.4.7 on my phone and the phone is stuck again on 'Samsung Galaxy SII' screen. Are there any steps in between that I'm missing? Do I have to go like 4.0 -> 4.3 -> 4.4? Any help would be truly appreciated.

    Currently phone is running on ICS 4.0.3 with CWM 5.0.2.7

    Advertisement
  2. secc123

    secc123 Member

    sokratus likes this.
  3. sokratus

    sokratus Member

  4. secc123

    secc123 Member

    Hi sokratus,
    Yep it will work - i also went from stock to cyanogenmod the first time i did it. I did get the yellow triangle showing at my boot screen but all was well with it. I think there is an app on google play called 'triangle be gone' or something like that which should remove it but i haven't bothered with it yet. It only shows as soon as i switch it on for a second then it all boots fine.
    Just follow the instructions and you should be good.
    I know the download speed sucks but if you want to get the latest nightly build from Cyanogenmod then go here, the speed is MUCH better!:
    CyanogenMod Downloads
    and grab todays - i flashed it today and its great (i also repartitioned my drives so i no longer have to worry about the 'insufficient space' warning when downloading google apps :)

    BTW, Make sure you have the GT-I9100 as thats the link i provided for. If you have the GT-I9100G (or other variant) then look on the link i posted for the nightlies for YOUR model.

    Best of luck

    BTW, make sure you back up your contacts/files first onto your sd card/pc just in case. CWM can create a full image of your phone to your sdcard just in case - so make sure you do this as well.
  5. sokratus

    sokratus Member

    Hey, thank a lot for that! You're the best!! :D I'm downloading from the link you gave me its quite fast! 12 minutes! :D Yes I am on SGS-II GT-I9100. Cheers!

    I'll update here once I'm up and running.
  6. sokratus

    sokratus Member

    Hey, I ran into this now. Do you know what might be causing this?
    (sorry for the hazy image)
    [​IMG]
  7. sokratus

    sokratus Member

  8. secc123

    secc123 Member

    Hi sokratus,
    I had the same thing....status 7 error (sorry i completely forgot that i got that error the first time i tried it - must be my age ;) ).
    It freaked me out a bit but i think it was the version of cwm mentioned on that site, i downloaded a newer version and it went through fine then.
    At the moment i am trying to calibrate my battery so phone is off until fully charged but i am uploading the version i *think* is the newer one i used to multiupload for you. Give me a couple of mins and i will post the link.
  9. secc123

    secc123 Member

    here you go, its on multiple sites so choose whichever one you want. its about 5mb. Just install it using your cwm (install zip from sdcard) and then retry doing the rom update:

    turbobit.nethttp://multiupload.biz/tb_ld87nq7kq3mh
    firedrive.comhttp://multiupload.biz/pl_ld87nq7kq3mh
    netload.in
    http://multiupload.biz/nl_ld87nq7kq3mh
    share-online.biz
    http://multiupload.biz/so_ld87nq7kq3mh
    asfile.com
    http://multiupload.biz/as_ld87nq7kq3mh
    rapidgator.nethttp://multiupload.biz/ra_ld87nq7kq3mh
    bayfiles.com
    http://multiupload.biz/bf_ld87nq7kq3mh
    sendmyway.comhttp://multiupload.biz/sw_ld87nq7kq3mh
    nosupload.comhttp://multiupload.biz/nu_ld87nq7kq3mh

    Any other issues let me know and i will try to help if i can.
    Good luck

    BTW, check your version of CWM beforehand and after you install my version to make sure its newer, if not then let me know and once my phone is charged in about an hour or two i will check my version.
  10. sokratus

    sokratus Member

    Hey SECC123,

    Wow, thanks for all that! Ok, so I'll flash this first and then the rom and update you here.

    Again, thanks a lot.
  11. secc123

    secc123 Member

    Hi sokratus,
    Your very welcome - hopefully it will all go smoothly for you now. Its just after midnight here but luckily i'm a night-owl so i will probably be up for a couple of hours yet, if you have any problems let me know. If i don't answer you quite quickly i may have gone to bed but i will definitely reply to you in the morning (my time).
  12. sokratus

    sokratus Member

    No problems. Its almost 5am here anyways. If something goes wrong I'll bother you in the morning ^_^.
  13. secc123

    secc123 Member

    just post anyway, i will be nervous until i know it went OK for you!


    Just re-read the instructions for flashing, it states that you need to flash cyanogenmod 10.2 first before v11.....I never bothered with that. I just flashed version 11 straight away so maybe you want to skip that step also?
  14. sokratus

    sokratus Member

    Hey, I just successfully installed CyanogenMod. Its CM11, so I guess I did skip a step :p. The phone has started and its 4.4.4. But I'm getting constant popups saying "unfortunately, the process xyz has stopped". Is it because of the GAPPS? Is there anyway I can just reformat the OS and install different set of GAPPS? The ones I installed were for 4.4.3.
  15. secc123

    secc123 Member

  16. sokratus

    sokratus Member

    Yeah I installed the full GAPPS. Got them from here Google Apps - CyanogenMod
    I'll try with the ones you've given me.
  17. sokratus

    sokratus Member

    Wunderbar!! Everything is A-OK now. Without your help it would've been really hard for me. Thanks a million billion times SECC123! Staying up all night paid off. :D I'm off to bed now, cheers! :D
  18. secc123

    secc123 Member

    Hey sokratus,
    You are more than welcome, glad i could help. So pleased you got everything sorted :D

    Enjoy cyanogenmod - i find it really fast and smooth running. My eye's are getting heavy as well so i may turn in myself.
    Best of luck
    Secc
  19. sokratus

    sokratus Member

    Hey one last query, I am unable to see any links in any app. I think they all are white. I can't see numbers in a message of whatsapp, or links in comments of youtube, etc. Check this screenshot: http://i.imgur.com/hs8muwp.png

    Do you have any idea how to change link colours maybe?
  20. secc123

    secc123 Member

    Hi, I haven't experienced that. Which browser are you using for youtube etc? Did you try switching themes in the settings?

    go to settings/themes and then at the top-right you will see 'get more'. There are lots of cheap theme's there but first try switching to one of the free themes then reboot and test. Then you can switch back to the default 'HOLO' theme.
    You can also try the same with settings/fonts and see if that makes a difference.
Loading...

Share This Page