Root [how-to] install kernels with S-ON h-boot 1.15+

Discussion in 'Android Devices' started by Rxpert83, Aug 24, 2012.

  1. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    How to flash kernels with H-boot 1.15+

    With S-ON and H-boot 1.15, you have certain restrictions placed on you by HTC that those with prior H-boots did not have--the recovery cannot write to the boot partition. This is where kernels are installed. This can be a problem if you try to flash an AOSP ROM since they require an AOSP kernel to boot. It can also be an issue if you just want to run a custom kernel. Luckily, our developers have found many workaround to be able to flash kernels to your device.. This post is my attempt to summarize what is available to you.

    If you are going from a sense ROM to an AOSP rom or the other way around the phone will not boot unless you flash the correct kernel. Also, if you are flashing a ROM that is a different base than the one you are currently on you will need to flash the kernel this way.


    Option 1: Fastboot flashing a kernel (RECOMMENDED)
    This looks long, buts its just the initial setup

    If you aren't familiar with doing things from fastboot, chances are the first thing you are going to need to do is properly setup the folders to carry out the fastboot flash command. This setup is going to take the most time and after you have it all set up its very quick to do after that.

    Setting up ADB:
    1) Download the mini-SDK here and move it to something like C:\Android\platform-tools or as instructed here -
    http://androidforums.com/faqs/443072-adb-guide-updated-2013-05-21-a.html#post5389081

    It contains:
    adb.exe - Windows adb utility
    fastboot.exe - Windows fastboot utility
    fastboot-windows.exe - Windows fastboot utility
    AdbWinApi.dll - adb link library for Windows
    AdbWinUsbApi.dll - adb link library for Windows

    These files will be used to push the boot.img (contains the kernel) from a ROM to your phone via fastboot.

    2) Download your ROM and open it, it will look like this:

    [​IMG]

    3) Copy the boot.img from the ROM to the same folder as the mini SDK you've downloaded.
    [​IMG]

    4)Plug your phone into the computer via USB and power the phone off. Then press volume down + Power to get to fastboot

    5)Once there, we need to open up a command prompt in the location where your sdk-tools are. If you are in windows 7 you can just shift+right click to select "open command prompt from here"
    [​IMG]

    If you don't have win 7 you can manually move to the file location with the command cd to change directory.
    [​IMG]

    6)Once you are in the correct directory you just type in
    Code (Text):
    1. fastboot flash boot boot.img
    and hit enter
    [​IMG]

    7)reboot

    Option 2: Flash Image GUI (NOTE:Its an app, so it requires the phone to be booted)
    Flash Image GUI is an app that enables you to flash .img's from within the app.

    To install it simply download the apk from this thread here, place it on your sd card, navigate to it using a file manager program like ES file explorer or Root Explorer and hit install. You may have to change your settings to allow for non-market apps in order for it to install.

    To use the app to install kernels, you open it up, click browse in order to navigate to the kernel you've place on your SD card, wipe dalvik cache & cache & click flash

    There is a video made for the EVO 3D you can watch here:
    Flash Image GUI / EVO3D / Flash Kernels with hboot 1.5!! *ROOT REQUIRED* - YouTube
    As well as picture instructions you can follow here:
    How to Install Kernel/ROM on HBOOT 1.50 for HTC Evo 3D! | HTC Evo 4G Hacks!

    Option 3: HTC Dumlock TeamWin Projects - HTC Dumlock | TeamWin


    Option 4: Developer workarounds
    There is an installer script made by XDA moderator Haus that when incorporated by the developer allows you to flash kernels normally from recovery.

    This is not something the average user can incorporate him/herself, but more information can be found here:S-ON Kernel Installer - xda-developers

    Be sure to read the OP of whatever you are downloading to check and see if this script is installed, it will save you a lot of time :D
     

    Advertisement
    henean, mikejones21, scudder and 11 others like this.
  2. Granite1

    Granite1 Zercron Encrusted Tweezer
    Moderator
    833

    Dec 27, 2010
    7,159
    7,180
    833
    Male
    Highway Construction Inspection
    Pittsburgh, PA
    Dood, this is awesome!!

    Good write up. ;)

    I added this to the guide section of the Root guide proper. :)
     
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Moderator
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    nice rx!!!!!!
    i'm gonna link this in the dummies guide we have going.
     
    Granite1 and Rxpert83 like this.
  4. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    Saw that, appreciate it. I also added it at the top of the kernel list when I added the other kernels we have. I figured that would help catch people before flashing
     
    3vodroid, EarlyMon and Granite1 like this.
  5. Blewis13

    Blewis13 Well-Known Member
    33

    Jun 9, 2010
    67
    51
    33
    I'm not well versed at rooting and kernels but will try to explain my problem. I followed option 1 from above. when i tried to reboot i get stuck on the screen that says htc quietly brilliant.
    I am using the charmeleon rom. I found out that I can replace the boot.img from the charmeleon file in the adk directory on my laptop and then use the "fastboot boot boot.img" instruction in the command prompt and the system reboots perfectly.
    My problem is anytime I try to reboot the phone i get stuck on the screen i mentioned above and need my laptop and have to repeat the command prompt thing.
    Has anyone ran into this? Does anyone even now what I'm trying to say and know how to fix it?
     
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Moderator
    1,823

    May 13, 2010
    23,596
    14,436
    1,823
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    so are you saying that when you boot up you are stuck at the splashscreen (that is what the htc screen is called). and to get unstuck you have to enter the fastboot command to get it to work?

    edit: ok so looks like you created a thread for this. i will post there my question. lets try and keep the conversation to one thread. it makes it easier to get help that way.
     
    Rxpert83 likes this.
  7. laserbeak43

    laserbeak43 Active Member
    16

    Oct 2, 2012
    25
    4
    16
    Thanks for this guide. I used #1. What does it mean when you phone still doesn't get past the boot splash screen?
    Code (Text):
    1. Microsoft Windows [Version 6.1.7601]
    2. Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    3.  
    4. F:\source\Android\android-sdk\platform-tools>fastboot flash boot boot.img
    5. sending 'boot' (1976 KB)...
    6. OKAY [  0.605s]
    7. writing 'boot'...
    8. OKAY [  0.886s]
    9. finished. total time: 1.492s
    10.  
    11. F:\source\Android\android-sdk\platform-tools>
    I've even Re-Flashed the ROM just to be safe. nothing. (update-cm-7.2.0-4FEB2012-VirginMobileMMSFIX)
    I guess i should mention that i've wiped cache/dalvik/userdata aswell. Just pulled out the SD card to eliminate the possibility of that interfering too.
     
    Rxpert83 likes this.
  8. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    Well what phone are you using? This guide was written for s-on EVO 4g LTE users in mind but the Rom you listed isn't one compatible
     
  9. laserbeak43

    laserbeak43 Active Member
    16

    Oct 2, 2012
    25
    4
    16
    Sorry, forgot to mention that I'm using the EVO 4G
     
  10. windsorclarenc

    windsorclarenc Well-Known Member
    163

    Nov 6, 2011
    719
    629
    163
    Male
    Windham, OH
    The OP says you have to fastboot flash the kernel if going from AOSP to Sense or vice versa. But do you have to fastboot flash the kernel if going from one Sense ROM to another with a different Sense kernel?
     
  11. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    Yes, any kernel change requires fastboot flashing. Going from sense to sense will still boot up and work if you don't flash, but you won't have the kernel included in the Rom.

    Also, when changing bases (due to OTA updates) make sure you fastboot flash it
     
    windsorclarenc likes this.
  12. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    The original EVO 4g or the EVO v 4g (which is actually a rebranded EVO 3d)
    Either way, id suggest starting a thread in your devices all thing root forum. I know we still have lots of helpful people over in the EVO 4g forums
     
  13. laserbeak43

    laserbeak43 Active Member
    16

    Oct 2, 2012
    25
    4
    16
    ok, thanks
     
    Rxpert83 likes this.
  14. windsorclarenc

    windsorclarenc Well-Known Member
    163

    Nov 6, 2011
    719
    629
    163
    Male
    Windham, OH

    Ah yeah that makes sense. Cool beans, thanks a bunch.
     
  15. hb17

    hb17 New Member
    6

    Oct 8, 2012
    1
    2
    6
    Male
    Excellent guide! I appreciate the help.
     
    ocnbrze and Rxpert83 like this.
  16. emerilnut

    emerilnut Well-Known Member
    23

    Jun 13, 2012
    63
    30
    23
    What if I have a TWRP backup of the previous Sense ROM and I want to go back to it from CM10. Does the kernel have to be flashed back? So I can't just simply go to TWRP recovery and restore from backup?

    (I'm here because my install of CM10 has not gone smoothly, and I'm using the directions to flash the kernel.)
     
  17. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    Good question!

    Recovery can't write to boot, so your nandroid can't restore the kernel.

    You'll have to fastboot flash it
     
    Granite1 and ocnbrze like this.
  18. bstrizzy

    bstrizzy New Member
    5

    Nov 29, 2012
    2
    0
    5
    Hey guys for some reason I am still getting messed up start up on my cm 10 download. i did everything you did, via linux ubuntu, reflashed boot, then reinstalled cm 10 and still does not work. what else do I do? really dont want a brick phone
     
  19. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN
    Where did you download it from?

    What did you wipe?
     
  20. juanaldo

    juanaldo New Member
    6

    Dec 5, 2012
    1
    1
    6
    forget it! i got it!
    I'm having this same problem on my evo lte... can some one please help?!
     
    Rxpert83 likes this.
  21. Rxpert83

    Rxpert83 Dr. Feelgood
    Moderator
    1,843

    Aug 30, 2011
    17,931
    13,136
    1,843
    Male
    Graduate Student
    MN

    Glad you got it.

    Can you give some details on where you previously messed up so I can see if I need to make improvements on the guide?
     
    ocnbrze likes this.
  22. finalewiz

    finalewiz New Member
    5

    Dec 5, 2012
    4
    0
    5
    Hey all - I have an EVO 4G LTE as well, trying to install CM10 (using TWRP 2.3.1)

    S-On
    Hboot 1.19

    All appears to go well (loaded ROM, Gapps, boot.img), but when I boot, I get stuck on the CyanogenMod animation screen.

    I was able to load MeanROM earlier, but kept running into Google Play and Gmail issues.

    Anyone figure out the problem yet?
     
  23. emerilnut

    emerilnut Well-Known Member
    23

    Jun 13, 2012
    63
    30
    23

    Sounds like the only step you forgot was the one this thread is about. You need to manually flash the kernel (boot.img) using any one of the 4 methods above.
     
    ocnbrze and Rxpert83 like this.
  24. finalewiz

    finalewiz New Member
    5

    Dec 5, 2012
    4
    0
    5
    That's my point - I did that (using method 1 above). Still hanging on the boot animation.
     
  25. windsorclarenc

    windsorclarenc Well-Known Member
    163

    Nov 6, 2011
    719
    629
    163
    Male
    Windham, OH
    Did you do it in this order?
    1. Wipe everything (cache, dalvik cache, system, factory reset, data)
    2. Flash ROM
    3. Flash gapps
    4. Wipe cache/dalvik cache
    5. Flash boot.img in bootloader
     
    ocnbrze likes this.

Share This Page

Loading...