How to install non-Market apps via ADB (solved)


Last Updated: 2012-01-23 14:29:11
  1. james27007

    james27007 Look into my Eye VIP Member

    Yes, they only go away if you uninstall them (menu --> settings --> applications --> manage applications) or you do a factory reset of the phone.

    If you switch motoblur accounts and/or gmail accounts, as long as you do not factory reset the phone, you are ok. However from what I understand, you can swicth gmail accounts without resetting the phone, however you cannot swap motoblur accounts witout resetting the phone.

    Advertisement
  2. ewingr

    ewingr Well-Known Member

    JFYI...I read somewhere that you could take out your SIM card, and just use a file manager and install. I tried that, and it did not work.
  3. handson

    handson New Member

    FWIW,
    copying cmd.exe is bad practice cuz you don't want versions littering your hdd,
    and copying apk to tools is bad practice cuz you don't want "personal data" mingled with installs. I got mine working with the following steps:

    1. install all the stuffs per stock instructions (SDK, USB driver, etc...)
    2. add tools dir to path:
    set path=%path%;c:\android-sdk-windows\tools
    3. go to path where apk lives (hopefully under your docs or downloads).
    4. C:\users\[myusername]\eclipse\HelloWorld\bin>adb install Your.apk

    :cool:
  4. HeatherVela

    HeatherVela New Member

    I can't seem to find the app after all this.
  5. james27007

    james27007 Look into my Eye VIP Member

    Find what app; the app must be in the same folder as adb. This works if you have apps (the file type is apk) that you want to install.
  6. Beach_Head

    Beach_Head Active Member

    If you're on the 2.1 update and you want to install non-market apps straight from your microSD, here's how to do it: Install Non-Market Apps
  7. LightFighter

    LightFighter New Member

    I'm doing something wrong. After I make sure my device is connected, I start ./abd shell, run ls to make sure I'm connected to the phone. When I run abd install xxyy.apk I get this error - abd: permission denied.

    Any suggestions?


    ***** Edit
    I may have a permission issue with my Linux box, but,

    Android Centrals Sideload Wonder worked to get a 3rd party app installed...
  8. james27007

    james27007 Look into my Eye VIP Member

    Welcome to the forums, we are glad to have you :D

    Are you running under linux or windows? HAve you tried other apk files to make sure it is not a android version issue?
  9. BudyIam

    BudyIam New Member

    I have 2.1 on my backflip. I used this method to install google earth 1.0 apk. It installed. It shows up as an app. But will not run.
    Any suggestions?

    Google earth runs fine on my Motorola Charm 2.1
  10. sixtythree

    sixtythree Well-Known Member


    with this same proceedure i can install aps downloaded to my pc and install them to my phone? is that what i am understanding and is it correct?
  11. james27007

    james27007 Look into my Eye VIP Member

    Correct. All android phones except the ones offered by AT&T allow you to install apk files (application install files) from your memory card. There is normally an option called Unkown Sources, AT&T removed this option, so unless you hack your phone, this is one way to do it.
    sixtythree likes this.
  12. sixtythree

    sixtythree Well-Known Member


    I am kinda slow. if you will go thru step by step on installing z4root that is in a file on my computer to the phone.

    #1 is done

    question- i assume #2 unzip the file to this adb folder

    #3 done

    4. Install the downloaded z4root file {need more details on the step}

    Do not understand #5 where did this tools folder come from?C:\adb\tools" folder

    no 4- install the downloaded driver what is this driver you speak of

    android galaxy s t959
  13. sixtythree

    sixtythree Well-Known Member

    android galaxy s t959 vibrant

    it will not work as z4root.zip after extrction is not apk file. also not sure where this usb driver for my phone is located.
    Unless there is a way to get the z4root.apk into my phone i quess i will not beable to reinstall it. since it was rooted with that file will i be able to unroot it needed with another file?
  14. Beach_Head

    Beach_Head Active Member

    I posted an easier way of installing apps from Unknown Sources. Post #31 of this thread. I guess nobody bothered to read it.

    All you have to do is download the zip file and replace two (2) files and you will have the "Unknown Sources" option in Settings->Applications.

    Instructions:

    Note: This is only for the official Motorola 2.1 Update. If you're using j_r0dd's Preclair ROM, you already have this.

    Allow Non-Market Apps for Backflip users with the 2.1 Update: Enable Non-Market Apps 2.1

    Just replace the files on your phone with the ones in the zip file and set the permissions of the files as stated below.

    1. Location: data/data/com.android.providers.settings/databases/
    - Permissions: settings.db: rw-rw----

    2. Location: data/data/com.motorola.android.providers.settings/databases/
    - Permissions: settings.db: rw-rw----
    james27007 likes this.
  15. xdunlapx

    xdunlapx New Member

    Ok did that. Still can't sideload z4root. I used to be able to sideload... I bet AT&T or Motorola updated the Backflip devices to disallow it and rooting. I've been at this for 6 hours now. Nothing I've tried is working.

    I checked. Unless I'm not in the right area, there is no option to enable non-market apps. I checked in settings/applications/debugging. it's not there.
  16. james27007

    james27007 Look into my Eye VIP Member

    To use those steps you need to be rooted. I updated the 1st post on how to do that the semi-easy way. So check it out...
  17. LocalPCGuy

    LocalPCGuy New Member

    I followed these instructions, and while it worked like a charm to get non-market apps, now I have a different problem that seems related.

    The Wifi radio turns off after about 30s, regardless of Wifi-Settings. Any ideas?

    Can I reverse this process so I can make sure that is the cause of the problem?
  18. james27007

    james27007 Look into my Eye VIP Member

    There is nothing that these files do that messes with Wifi. Try the app FXR WiFi Fix and rescue; that works for my captivate.

    To go back you need the original files. My backflip is at home; and I am out of the state. IIf you can wait, I will flash it back to stock next week and upload the files. In the mean time I will work on a quick backup of the originals for others. Sorry I forgot to include that part.
  19. LocalPCGuy

    LocalPCGuy New Member

    I tried FXR WiFi - It said it fixed it, but it continues to do the same thing. I would appreciate the stock files, at the least I can get it back to stock without a hard reset.
  20. skate6566

    skate6566 New Member

    OP confirmed working on Motorola Flipside following exact instructions.

    Upon reboot I was told my sim was locked and I had to reenter my MOTOBLUR info, but other than that this worked perfectly. Now am fully able to use apps like applanet (i know, shame on me).

    Thx j101399j
  21. james27007

    james27007 Look into my Eye VIP Member

    I am now havingthe same issue AND GPS will not tuen off. This is very weird. I will have the stock files up in the next day or so. In the mean time, I am taking the OP down,
  22. james27007

    james27007 Look into my Eye VIP Member

    Ok here are the 5 original files to undo the bad mod (I have no idea what happened, sorry). Just follow the same steps but use these files. Let me know how it works.

    Step 1: Download and extract the five files from the zip at the bottom of this post into your folder with adb

    Step 2: Open the command prompt and navigate to the folder with adb

    Step 3: Type the following:

    Code (Text):
    1.  
    2. adb push settings1.db /data/local/tmp/settings1.db
    3. adb push settings2.db /data/local/tmp/settings2.db
    4. adb push secure.mkitso3 /data/local/tmp/secure.mkitso3
    5. adb push system.mkitso4 /data/local/tmp/system.mkitso4
    6. adb push settings.mkitso5 /data/local/tmp/settings.mkitso5
    7.  
    8. adb shell
    9. su
    10.  
    11. mount -o rw,remount /dev/block/mtdblock1 /system
    12.  
    13. cp /data/local/tmp/settings1.db /data/data/com.android.providers.settings/databases/settings.db
    14. cp /data/local/tmp/settings2.db /data/data/com.motorola.android.providers.settings/databases/settings.db
    15. cp /data/local/tmp/secure.mkitso3 /system/etc/motorola/com.android.providers.settings/secure.mkitso
    16. cp /data/local/tmp/system.mkitso4 /system/etc/motorola/com.android.providers.settings/system.mkitso
    17. cp /data/local/tmp/settings.mkitso5 /system/etc/motorola/com.motorola.android.providers.settings/settings.mkitso
    18.  
    19. chmod 644 /data/data/com.android.providers.settings/databases/settings.db
    20. chmod 644 /data/data/com.motorola.android.providers.settings/databases/settings.db
    21. chmod 644 /system/etc/motorola/com.android.providers.settings/secure.mkitso
    22. chmod 644 /system/etc/motorola/com.android.providers.settings/system.mkitso
    23. chmod 644 /system/etc/motorola/com.motorola.android.providers.settings/settings.mkitso
    24.  
    25. reboot
    26.  

    Attached Files:

  23. LocalPCGuy

    LocalPCGuy New Member

    never mind, cross posted. Thanks for posting these!
  24. LocalPCGuy

    LocalPCGuy New Member

    I ended up having to do the factory reset anyways. After restoring the 5 files, the phone wouldn't come out of Airplane mode, and the phone would not work. Wifi actually seemed to be working fine, despite it not coming out of Airplane mode.

    If I tried to actually make a call, it just say at a screen saying it was enabling radio.

    Booting up from the factory reset now, just will need to reinstall everything. It worked as far as allowing non-market apps, was able to install the Amazon app store and then install apps from it. But obviously the other issues prevent me from leaving it that way.
  25. thenishland

    thenishland New Member

    hi guys,
    i m new android user, and i have HTC Magic with Android 1.5,
    anybody can tell me how to install vending apk and how to upgrade to Android 2.3...
    thanks in advance.

Share This Page