How to install *.zip with Hboot?


  1. bluemsw

    bluemsw Well-Known Member

    Is there anyone that can give me step by step instructions on how to use hboot to install files from the root directory on my sd card. Ex.

    "
    This is what I did:
    I downloaded Clockworkmod 2.5.0.5, renamed the Clockworkmod zip to PB31IMG.zip, and placed it on the root of my SD card. Power-off, and boot into HBOOT (pressing the down vol+power button).

    Then I downloaded Superuser 2.3.6.1 and place it on the SD card, use Clockworkmod Recovery and choose "Install .zip from SD" option.

    Restarted my phone, and there's Superuser."

    Can anyone give me step by step to do this please? I have tried going through hboot and never see these files once I have installed them on the SD card. Please help.

    Advertisement
    :
  2. jbdan

    jbdan Well-Known Member

    Hook your phone up to your PC and go search through your "clockwork" folder on your SD card. Everything you download through clockwork will be in that folder. I've never used clockwork although I've had it installed since day 1 of rooting my Inc. I just find it easier to do it the old fashioned way: I download what I want to my PC then hook up my phone and drag and drop my zip's onto my SD card. Then boot into recovery through HBOOT or through my ROM's reboot options if the particular ROM has that option.

    Are you booting into HBOOT with volume down then press power button? Then use volume key down to RECOVERY then press power button to enter into RECOVERY?
  3. bluemsw

    bluemsw Well-Known Member


    I don't have clockwork installed. I am trying to install the clockworkmod. When I boot into recovery i get the black screen with the white bars down the side.
  4. doug piston

    doug piston Well-Known Member

    Mahalo and geekswrath like this.
  5. bluemsw

    bluemsw Well-Known Member

    ok will try that. I did check the properties of my sd card and the comp shows its FAT32. I will reformat it and see if that helps.
  6. jbdan

    jbdan Well-Known Member

    Sorry I wasn't understanding what you said my bad

    Yeah you have the slcd version of the Inc follow doug's advice and your gravy.

    Reformat it anyways.
  7. Mahalo

    Mahalo Well-Known Member

    jbdan is right. I downloaded and tried, FAIL. Re-downloaded and tried. FAIL, Re-downloaded the file again and FAILED... checking the MD5 each time. I'll try to find some utility that can help me discover how my originally perfectly FAT32 formatted card got corrupted but it did. I think it is likely that it was unmounted uncleanly at some point and while it remained OK to use, it had a bad file allocation table (FAT) so the digits just didn't add up right. I finally copied all of my files off, reformatted it and copied the same file that had previously failed and it worked just fine.

    I'm still nervous about using nandroid, but at some point I have to take the leap so I think I may as well do it tonight rather than trying it after a gaggle of Makers Mark 46 on the rocks.

    OK, backup is looking good. My next step will be a restore. IF I don't post a positive reply it means that my phone is, again, hosed since I am using it as my only internet source.
  8. masully1984

    masully1984 Well-Known Member

    use ROM Manager to flash your recovery menu
  9. doug piston

    doug piston Well-Known Member


    Can not do that if you have lcd.
Loading...

Share This Page